Failure to have openoffice.org-math intalled causes "data corruption"

Bug #223476 reported by Ryan Zeigler on 2008-04-28
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
openoffice.org (Ubuntu)
High
Chris Cheney
Hardy
High
Unassigned
Intrepid
High
Unassigned

Bug Description

Binary package hint: openoffice.org

When editing an .odt file that contains formulas without the openoffice.org-math package installed, formulas in the document are somehow corrupted. If the same file is opened in an instance of openoffice that does have -math installed, the formulas show visual glitches, and the only way to restore them is to make a change to each one, one at a time. As far as I can tell the actual formula is still there. I'm unsure if this is a bug in openoffice or if -math should just always be included as a dependency. My default hardy install did not come with openoffice.org-math installed.

Steps to reproduce
Installed openoffice.org-math
Create a document with a formula in it
Uninstall openoffice.org-math
Reopen the document and make some change and save
Reinstall openoffice.org-math
Observe strange drawing of formulas.

I'd agree that the simple fact that this package is not installed by default is a bug. Formulas are an integral ( :) ) part of OOo.

And if Hardy's OOo packages silently trash any document that CONTAINS a formula, that's a severe bug.

I didn't discover that Hardy's install of OOo was broken until Hardy had trashed an entire day's worth of my work (editing documents for my summer chemistry classes). Every one of those documents has formulas, and every one was corrupted by this bug. I will be spending the rest of today cleaning up the mess. (I didn't discover what the problem *was* until I tried to *edit* one of the formulas.)

On my install, the corrupted formulas display as mostly blanks. Editing them once ooo-math was installed would cause them to come back, but in the wrong sized box. The only way I could get the formulas back to normal was to open each one, copy the text version of the formula, then insert a new formula and paste the formula text back in.

Chris Cheney (ccheney) on 2008-06-14
Changed in openoffice.org:
importance: Undecided → Critical
Markus Barthel (markusbarthel) wrote :

The information are given, isn't it?
So I set the status to confirmed. Ok?

Changed in openoffice.org:
status: New → Confirmed
Jonathan Marsden (jmarsden) wrote :

I think this would be solved by making openoffice.org-{writer,calc,base,...} binary .debs depend on openoffice.org-math ? Is there any reason *not* to attempt that approach?

Jonathan

Jonathan Marsden (jmarsden) wrote :

Here is a (possibly naive?) first attempt at a patch. It simply places an additional dependency on each of the main OOo components (writer, calc, draw and base) so that the -math package will be installed whenever any of them are installed. There seems to be no need for doing this to the impress package, because it depends on the draw package anyway.

The attached .debdiff has *many* lintian warnings, a few of which I can probably clean up without too much work.

At this point I have *not* build the resulting updated OOo binary .deb files, as this needs a beefier machine than I have running for several hours...!

I'd value feedback on whether this is a useful approach to this bug.

Jonathan

Chris Cheney (ccheney) wrote :

One of these two libraries is probably all that is needed to be able to properly open the files. I will look into adding those to a package instead of pulling all of openoffice.org-math in, there is very little space left on the CD's so we can't just pull everything we want in or we would have all of openoffice.org in to begin with.

/usr/lib/openoffice/program/libsm680li.so
/usr/lib/openoffice/program/libsmd680li.so

Changed in openoffice.org:
importance: Critical → High
milestone: none → intrepid-alpha-4
assignee: nobody → ccheney
Jonathan Marsden (jmarsden) wrote :

> One of these two libraries is probably all that is needed to be
> able to properly open the files. I will look into adding those to
> a package instead of pulling all of openoffice.org-math in,
> there is very little space left on the CD's ...

OK. openoffice.org-math is all of 240Kbytes... are we truly *that* short of space? When -writer (for example) is 5MB and -core is over 25MB, I'm surprised we're concerned about trying extra hard to save (some fraction of) 240KB.

Jonathan

Chris Cheney (ccheney) wrote :

That is the deb size, the installed size is 1084KB (slightly over 1MB) and probably will cause a problem on the desktop/live cd. Intrepid alpha 2 was too large to even release a desktop/live cd and some more programs were removed to make alpha 3 actually releasable. However most of the size of the openoffice.org-math package is those two libraries so I'll have to see if I can get the whole package onto the cd somehow.

Chris

Scott Beamer (angrykeyboarder) wrote :

OpenOffice.org Math belongs in the suite, period. I've never understood why it's not included. Ubuntu tries to be friendly to "new users" and many of those users may accustomed to ussing OOo on other platforms. And OOo for Windows includes "Math" installed by default.

The best workaround is just to include it, period.

Martin Pitt (pitti) on 2008-08-12
Changed in openoffice.org:
milestone: intrepid-alpha-4 → intrepid-alpha-5
Chris Cheney (ccheney) on 2008-09-03
Changed in openoffice.org:
milestone: intrepid-alpha-5 → intrepid-alpha-6
Chris Cheney (ccheney) on 2008-10-15
Changed in openoffice.org:
assignee: ccheney → nobody
milestone: intrepid-alpha-6 → none
status: Confirmed → Triaged
Steve Langasek (vorlon) wrote :

I'm able to reproduce this corruption problem with the attached simple test case. Here is the xmldiff of the content.xml, before and after opening it without openoffice.org-math installed.

[append, /office:document-content[1]/office:automatic-styles[1]/style:style[1]/style:graphic-properties[1],
<@draw:visible-area-height>
1.9685in
</draw:visible-area-height>
]
[append, /office:document-content[1]/office:automatic-styles[1]/style:style[1]/style:graphic-properties[1],
<@draw:visible-area-width>
1.9685in
</draw:visible-area-width>
]
[append, /office:document-content[1]/office:automatic-styles[1]/style:style[1]/style:graphic-properties[1],
<@style:horizontal-pos>
from-left
</style:horizontal-pos>
]
[append, /office:document-content[1]/office:automatic-styles[1]/style:style[1]/style:graphic-properties[1],
<@style:horizontal-rel>
paragraph-content
</style:horizontal-rel>
]
[rename, /office:document-content[1]/office:body[1]/office:text[1]/text:p[1]/draw:frame[1]/draw:object[1], draw:object-ole]

Chris, I think we can afford the space for -math still on the CDs, and I'll try seeding it to confirm this is the case. I think it would have been preferable to escalate this bug sooner so we could try to change the dependencies in the OOo packages themselves rather than relying on the seeds, but we'll work with what we've got.

Jonathan Marsden (jmarsden) wrote :

Steve, *thanks* for taking this seriously even at this very late stage.

I came across this, verified it, and tried to create a patch altering the dependencies, back in July, but Chris said there were space issues and he'd try to fit it on the CD. Then there was no change to the bug in LP until Oct 14, when I got an email from LP saying:

** Changed in: openoffice.org (Ubuntu)
     Assignee: Chris Cheney (ccheney) => (unassigned)
       Status: Confirmed => Triaged
       Target: intrepid-alpha-6 => None

I interpreted that as basically meaning something like "Chris gave up on getting this into Intrepid".

You asked for any bugs not in your lists that should be fixed... so I pointed you to this one. As a relative newcomer to the world of Ubuntu bug-fixing and MOTU work, what could or should I have done to raise the visibility of this bug earlier? It was already marked as High importance... and it looked like Chris was aware of it and had a plan to deal with it. How could I have done better in handling this bug?

Thanks,

Jonathan

Chris Cheney (ccheney) wrote :

I'm pretty certain I brought this issue up before but we were already over space on the disk at that time so it couldn't be made to fit. I guess I should have just been more vocal about it once something was done to allow a little more space.

Chris Cheney (ccheney) on 2008-10-18
Changed in openoffice.org:
status: Triaged → Fix Released
importance: Undecided → High
milestone: none → ubuntu-8.04.2
status: New → Triaged

On Sat, Oct 18, 2008 at 02:39:47AM -0000, Jonathan Marsden wrote:
> I interpreted that as basically meaning something like "Chris gave up on
> getting this into Intrepid".

That sounds like a pretty accurate interpretation, yes.

> You asked for any bugs not in your lists that should be fixed... so I
> pointed you to this one. As a relative newcomer to the world of Ubuntu
> bug-fixing and MOTU work, what could or should I have done to raise the
> visibility of this bug earlier? It was already marked as High
> importance... and it looked like Chris was aware of it and had a plan to
> deal with it. How could I have done better in handling this bug?

Launchpad has a 'nominate for release' button which lets you bring the bug
directly to the attention of the release managers. This is recommended for
any bugs that need to be fixed before release, even if they appear to
already be in hand.

Cheers,
--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Jags_FL (jags-fl) wrote :

Going through the comments I couldn't help but notice that by not including packages like these might free up some space on Desktop/Live CD, though I don't know how much or how many are there in first place :

Packages most user may not need:

- splix : Driver for samsung laser printers
- min12xxw : Driver for KonicaMinolta PagePro

vs

Package most users would certainly need:

- OpenOffice.org

Just my 2 cents, - jags

Jonathan Marsden (jmarsden) wrote :

Now the rush of Intrepid release is over... should we add the math package as a dependency now, for Jaunty?

Steve Langasek (vorlon) wrote :

Chris, AIUI the only change here has been to add -math to the Ubuntu seed - shouldn't OOo-writer also be adjusted to depend/recommend -math directly, or to otherwise fix OOo-writer to not corrupt these files?

This is also still unresolved for Ubuntu 8.04. I think we have plenty of room on the CDs to add -math in, it's just a question of adding the dependency to the right package.

Changed in openoffice.org:
milestone: ubuntu-8.04.2 → ubuntu-8.04.3
Chris Cheney (ccheney) on 2009-01-25
Changed in openoffice.org:
assignee: nobody → ccheney
milestone: none → jaunty-alpha-4
status: Fix Released → Triaged
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package openoffice.org - 1:3.0.1-1ubuntu1

---------------
openoffice.org (1:3.0.1-1ubuntu1) jaunty; urgency=low

  * Resynchronise with Debian (r1395). Remaining changes:
    - Add Launchpad integration support.
    - Add Launchpad translations support.
    - Add package openoffice.org-style-human.
    - Add some Ubuntu-specific bitmaps. Adjust broffice diversions for these.
    - Add support for compressing debs with lzma.
    - Add support for shared /usr/share/doc directories.
    - Add support to build l10n as a separate source.
    - Add support to build on lpia.
    - Add support to turn off building on sparc.
    - Add Xb-Npp-xxx tags according to "firefox distro add-on suport" spec.
    - Set startcenter.desktop to not display in the menu.
    - Use imagemagick instead of graphicsmagick.
    - openoffice.org-help switch to internal copy of lucene.
    - Add Depends openoffice.org-math to openoffice.org-writer.
      Closes LP: #223476
    - Remove extra ooo-build changelog. Closes LP: #262579
    - boost1.35 transtition. Closes LP: #297152
    - Add & to ooo87965.execute.sh. Closes LP: #313495
    - OOo needs stlport on i386 for extension compatibility.
      Closes LP: #322188
    - calc needs depends on lp-solve since it links to it.
      Closes LP: #322189
  * Resynchronise with ooo-build-3-0-1 (r15230).
    - Update launchpad-integration menu entries. Closes LP: #41694
    - Add indentation to flat odt files. Closes LP: #226075
    - Change code from Err:529 to Err:519. Closes LP: #226457

 -- Chris Cheney <email address hidden> Thu, 29 Jan 2009 01:00:00 -0600

Changed in openoffice.org:
status: Triaged → Fix Released
dino99 (9d9) on 2013-04-04
Changed in openoffice.org (Ubuntu Hardy):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers