Ubuntu

SRU: progress bar oddities break creation of diskless clients

Reported by laga on 2008-04-25
10
Affects Status Importance Assigned to Milestone
mythbuntu-control-centre (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned
Intrepid
Undecided
Unassigned

Bug Description

Binary package hint: mythbuntu-control-centre

When creating a diskless image in the Control Centre, the progress bar finishes before ltsp-build-client run in the background is finished. The usually will usually exit the control centre before ltsp-build-client has finished, resulting in unbootable clients. This leads to lots of questions in the Mythbuntu forums, which makes me sad.

This upload should have gone in before Archives were hard frozen, but it didn't make it so we need an SRU now. There's no risk for regression as it only touches the progress bar code.

Debdiff will be attached soon.

laga (laga) wrote :

Debdiff attached. You'll notice another changelog entry about the addition of a MCC_DEBUG variable - having this is essential for any debugging and certainly doesn't hurt.

John Dong (jdong) wrote :

(1) Target should be hardy-proposed, not hardy, since this is now a SRU
(2) Version number should be either 0.27-0ubuntu1.1 or 0.28-0ubuntu1~hardy1 to prevent clashing with Intrepid.

Please revise your debdiff and set back to New

Thanks,
MOTU-SRU

Changed in mythbuntu-control-centre:
status: New → Incomplete
laga (laga) wrote :

Thank you, I've updated the debdiff.

Changed in mythbuntu-control-centre:
status: Incomplete → New
John Dong (jdong) wrote :

ACK from MOTU-SRU, please proceed to upload to hardy-proposed and verification.

Changed in mythbuntu-control-centre:
status: New → Confirmed
Martin Pitt (pitti) wrote :

Accepted into hardy-proposed, please test.

BTW, sorry for the reject/unreject/accept for 0.28-0ubuntu1~hardy1. There were two uploads in the queue, and first I rejected the 'wrong' one.

Changed in mythbuntu-control-centre:
status: Confirmed → Fix Committed
Verzweifler (michael-robrecht) wrote :

Tested it and determined some oddities with respect to Medibuntu-packages... They were not included (an error saying they could not be authenticated) although I checked the "allow unsigned packages" checkbox beforehand.

laga provided an updated .deb to me, which then worked and which therefore should replace the one still in hardy-proposed.

laga (laga) wrote :

I'm providing a new debdiff for a ~hardy2 upload. I've found some issues (thanks Verzweifler!):

* Unauthenticated packages wouldn't install even if the "allow unsigned packages" checkbox was checked.
* There was no feedback whether the diskless image was built successfully or not. Now the user will see an error message if ltsp-build-client failed.

The debdiff is meant to apply on top of the ~hardy1 package which is already in hardy-proposed. It is not necessary to invoke the get-orig-source rule, all changes are supposed to be in the .diff.gz and will eventually end up in the orig.tar.gz for intrepid.

Changed in mythbuntu-control-centre:
status: Fix Committed → New
John Dong (jdong) wrote :

ACK from MOTU-SRU to upload and test this debdiff

laga (laga) wrote :

Martin Pitt rejected the upload of ~hardy2 to hardy-proposed:

> your m-c-c upload does not refer to an LP bug#, and has string
> changes, etc. Please create an SRU bug#, refer to it in the changelog,
> and get it approved by motu-sru.

> I rejected your package for now, please upload another one with a
> fixed changelog and approved bug.

I'll attach a third debdiff in a few minutes. This will fix ~hardy2 to include a reference to this bug report in the changelog. I can't avoid the string change, but it doesn't matter because that part of the package hasn't been localied yet. Translations only apply to the glade files (of course, that's a bad thing, but nothing I can fix now).

> Also, 0.28-0ubuntu1~hardy1 is already in -proposed and not in -updates
> yet. Shouldn't that version finish the SRU process first? If you
> upload another one, the testing for ~hardy1 needs to be dropped and
> done again for ~hardy2.

Yes, I do want ~hardy2 to supersede ~hardy1. ~hardy1 doesn't need to go to hardy-updates first.

laga (laga) wrote :

The only change is the addition of the bug number, so this should be quick to review. This debdiff is meant to apply on top of ~hardy1 from hardy-proposed.

Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here

Changed in mythbuntu-control-centre:
status: New → Fix Committed
Steve Langasek (vorlon) wrote :

Has anyone confirmed that diskless client creation works now with the latest version in the archive?

Is this something that could be tested using the 8.04.1 candidate images (http://cdimage.ubuntu.com/mythbuntu/hardy/daily/current/)?

Mario Limonciello (superm1) wrote :

Yes: I just confirmed that it works now.

Steve Langasek (vorlon) wrote :

copied to hardy-updates and to intrepid, thanks.

Changed in mythbuntu-control-centre:
status: Fix Committed → Fix Released
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers