Ubuntu

Blinking cursor can not be deactivated anymore

Reported by Chardon Bertrand on 2008-02-03
84
This bug affects 9 people
Affects Status Importance Assigned to Milestone
GNOME Terminal
Fix Released
Medium
gnome-terminal (Ubuntu)
Low
Ubuntu Desktop Bugs
Hardy
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: gnome-terminal

Using a fully upgraded Ubuntu Hardy Heron Development Release (as of today Sun Feb 3 2008) and gnome-terminal 2.21.90, there is no option to disable the blinking of the cursor in the terminal anymore. This option used to be located in the "Edit Current Profile" menu. I even tried to activate it through gconf-editor, to no avail (in apps/gnome-terminal/profiles/Default).

Pedro Villavicencio (pedro) wrote :

Thanks for your report, It's now following the GNOME Settings, you can disable it in Keyboard Preferences, for further reference: http://bugzilla.gnome.org/show_bug.cgi?id=342921

Changed in gnome-terminal:
status: New → Invalid
Seth (hexcat) wrote :

This is kind of annoying - I like not having the blinking cursor in gnome-terminal but I want it to blink elsewhere.

mhakali (ubuntu-nexticom) wrote :

I 2nd that. I want the cursor to blink elsewhere but in the terminal it's just annoying.

Me too! Cursors SHOULD normally blink in my opinion, it's just that in the terminal the cursor is a large block which is really annoying when it blinks all the time. The rather large response in favour of a non-blinking cursor at the referenced bug makes me a bit mad at the people who pushed this change through.

So it seems now they're waiting for a patch which only makes things more complicated... some combo box option with values "System default", "Always", "Never". I call for a revert since that would bloat the UI even more than before.

jcornwall (jay-jcornwall) wrote :

I installed Hardy RC1 today and this feature revocation really annoyed me.

Until a proper patch is in the works, I threw together this to force blinking off in the terminal:
http://www.jcornwall.me.uk/2008/04/hardy-heron-and-the-blinkin-terminal/

Source patch and optional binaries for the lazy.

Ben Thornton (smenjas) wrote :

I also found this frustrating, particularly because the help documentation hasn't been updated. It still describes the old checkbox, which doesn't exist.

The command line is different from GUIs, where blinking helps convey focus. Seems like a lot of other people think so too. Perhaps this is a case of over simplification.

John C Kendall (johnckendall) wrote :

This option absolutely, positively must be restored. I was about to move from Fedora but now that I see this, there is no way! I cannot spend 8-16 hours a day staring at a big black blinking cursor!

It's fine to default it to whatever the keyboard option is set to, but the terminal application must be able to override that setting.

Please please please change it back.

I understand this is a Gnome change, but they've applied logic a step too far. There's a big physical difference between a one-pixel-wide cursor used in Gtk+ text areas, etc., and a one-character-filled-rectangle used by gnome-terminal. The former I want to blink because it can be hard to spot. The latter is easy to spot and its blinking is a distraction, just like animated ads or blink text on a web page; and we block those!

I see why it was set to Invalid, this isn't a bug but a `feature' imposed by Gnome. But it is a bug because they made it based on them both being `cursors' without regard for their different physical appearance, so I'm setting this bug to Confirmed. There seems to be a considerable body of people that had the two cursors with different blink settings.

Changed in gnome-terminal:
status: Invalid → Confirmed
Aaron Grattafiori (cogitate) wrote :

I just signed up on launchpad to note my disapproval for this change in gnome-terminal. There's lots of things I've wanted to do a launchpad but, this was the last straw.
Having to disable *ALL* cursor blinking for the sake of only gnome-terminal seems silly. After being an option for so long.. why change it now? Is it *really* making gnome more simple? No.
I also think this setting is obfuscated being located in keyboard settings (what is this.. KDE? :-P). I hope this bug gets assigned to someone soon, if its not fixed in the next release of gnome-terminal, I'll probably switch to using urxvt for all my systems (which I already use on my laptop).

Gnome have accepted this change was a mistake. See http://bugzilla.gnome.org/show_bug.cgi?id=342921 which I've just link this bug too. However, they're being sensitive flowers and are deleting comments from the bug report. Some were from Jay L. T. Cornwall willing to provide a patch he'd already prepared to revert this change. Olav deleted them; see my comment #46. Olav is insisting that reverting isn't an option and someone must write a new patch that provides a three-way option, Blink, Don't blink, Use system default.

In lieu of a useful change from Gnome, perhaps Jay Cornwall's patch can be examined to see if Ubuntu can pick it up directly?

Changed in gnome-terminal:
status: Unknown → Invalid
Aaron Grattafiori (cogitate) wrote :

Invalid? Really? Because nobody has submitted a patch to fix something that shouldn't have been changed in the first place?.. A patch put something BACK in that a developer took out?

Ben Thornton (smenjas) wrote :

This is ridiculous. Clearly a huge number of people are upset by this development. <a href="http://lwn.net/Articles/278995/">It even got a mention on LWN.</a>

As Ralph pointed out, someone even submitted a patch to revert the bug, and had his comments deleted for his trouble.

The least you can do is leave the bug open until the help docs get updated. As it stands the old behavior is still documented but not available.

This is sound of community feedback. A big fat "Invalid" with no explanation is not likely to win over users. Please let us know why this bug is invalid or leave it open until the documentation gets updated.

Pedro Villavicencio (pedro) wrote :

as already pointed out that's an upstream task please raise your comments in their bug tracker. thanks.

Changed in gnome-terminal:
status: Confirmed → Invalid

Changing from Invalid to Confirmed. I'm assuming some bot changed it to Invalid based on the Gnome bug status, hopefully it'll leave it alone now. But journeying into the realms of the Gnome community made me remember why I'm glad Ubuntu came to exist; it's a more polite society. ;-) Anyway, I've tracked down Jay Cornwall; http://www.jcornwall.me.uk/2008/04/hardy-heron-and-the-blinkin-terminal/

Changed in gnome-terminal:
status: Invalid → Confirmed
Pedro Villavicencio (pedro) wrote :

It will be fixed for ubuntu 8.04.1, setting the appropiate milestone for now.

Changed in gnome-terminal:
assignee: nobody → desktop-bugs
importance: Undecided → Low
milestone: none → ubuntu-8.04.1
jcornwall (jay-jcornwall) wrote :

It is unfortunate that the upstream developers chose to deal with this matter in the manner in which they have done.

I will assume by Pedro's comment that all is now in hand, but in case it helps here is a reversal of the offending patch against 8.04's sources:
http://www.jcornwall.me.uk/patches/gnome/gnome-terminal-2.22.1-reverseblink.patch

For users wishing to restore blink functionality before the next milestone, apply like this:

apt-get source gnome-terminal
cd gnome-terminal-2.22.1
patch -p0 < /path/to/gnome-terminal-2.22.1-reverseblink.patch
dpkg-buildpackage -rfakeroot (from package dpkg-dev for this)
sudo cp debian/tmp/usr/bin/* /usr/bin
sudo cp debian/tmp/etc/gconf/schemas/* /etc/gconf/schemas
sudo cp debian/tmp/usr/share/gnome-terminal/glade/* /usr/share/gnome-terminal/glade

(You will need to use another terminal, like xterm, to overwrite the gnome-terminal binary. I'd advise against installing the whole built .dpkg file as it will conflict with the apt repository.)

Pedro Fragoso (ember) wrote :

That patch is wrong. Here's the output when trying to edit a profile.

Changed in gnome-terminal:
status: Invalid → Fix Released
Pedro Villavicencio (pedro) wrote :

a bug was opened to track this feature: http://bugzilla.gnome.org/show_bug.cgi?id=533522

Switch to watching the new Gnome bug. Hope that's the right thing to do. Couldn't see how to add two Gnome bug watches.

Changed in gnome-terminal:
status: Unknown → Confirmed
Changed in gnome-terminal:
assignee: nobody → seb128
importance: Undecided → Low
status: New → Triaged
Changed in gnome-terminal:
assignee: seb128 → desktop-bugs
Changed in gnome-terminal:
status: Confirmed → Fix Released
Pedro Villavicencio (pedro) wrote :

fixed upstream now, thanks.

Changed in gnome-terminal:
status: Confirmed → Fix Committed

Even though the upstream fix won't make it into an actual release for quite some time (since Gnome 2.22 is frozen), will this fix still make it into Hardy soon? I hope so.

Steve Langasek (vorlon) on 2008-06-07
Changed in gnome-terminal:
milestone: ubuntu-8.04.1 → none

This is still present in Intrepid.

Clarification: in Intrepid, the gconf entry apps/gnome-terminal/profiles/*/cursor_blink_mode exists and works, but the preference control is still missing from the edit profile preferences dialog. It took me ages to find that, though.

Chris Coulson (chrisccoulson) wrote :

According to the upstream bug, this was fixed in 2.23.x, and Intrepid has 2.24. Marking as fixed.

Changed in gnome-terminal:
status: Fix Committed → Fix Released

On Sun, Jan 11, 2009 at 4:22 PM, Chris Coulson <snip> wrote:

> According to the upstream bug, this was fixed in 2.23.x, and Intrepid
> has 2.24. Marking as fixed.
>
> ** Changed in: gnome-terminal (Ubuntu)
> Status: Fix Committed => Fix Released
>

I can confirm that it's fixed.

Martin Pool (mbp) wrote :

This seems to have regressed in Lucid: there is no control for blinking, though the gconf key does still work. See also bug 538612 that the cursor blinks even when it shouldn't.

It's unfortunately not a regression, this bug has never really been fixed. Unless the addition of some hidden gconf key is considered a fix. The control to set the blinking behaviour was never added back.

Ioannis Drositis (jdros) wrote :

Although there is no control for blinking behaviour in gnome-terminal settings, the gconf entry apps/gnome-terminal/profiles/*/cursor_blink_mode (on | off | system) exists and works for me, from 9.04 to 10.04.

stefankaerst (stefankaerst) wrote :

I use Ubuntu GNU/Linux for several years and this bug, or whatever you call it, never goes away. This is really annoying and sad.
After upgrading from 9.10 to 10.4 the blinking cursor in gnome-terminal is back!
/apps/gnome-terminal/profiles/Default/cursor_blink_mode OFF
/desktop/gnome/interface/cursor_blink NOT ENABLED
/desktop/gnome/interface/cursor_blink_time 0
the other options I found with searching for "blink" in gconf-editor are set to <schema>

this is sooooo frustrating to change this setting over and over again after each upgrade of Ubuntu. the upgrade itselfs takes less time than searching the internet for a solution to this!
As for me this bug is not fixed! Why was the setting ever removed from gnome-terminal? The developer(s) how did this should be punished with a HUGE BLINKING BLOCK CURSOR!!!

knoedel@section60:~/Documents$ aptitude show gnome | grep -i version
Version: 1:2.28+1ubuntu3
knoedel@section60:~/Documents$ uname -a
Linux section60 2.6.32-22-generic #33-Ubuntu SMP Wed Apr 28 13:28:05 UTC 2010 x86_64 GNU/Linux
knoedel@section60:~/Documents$ cat /etc/*release*
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=10.04
DISTRIB_CODENAME=lucid
DISTRIB_DESCRIPTION="Ubuntu 10.04 LTS"
knoedel@section60:~/Documents$ gnome-about

shows 2.30.0 (build date 03/31/2010)

at least, there is xterm
really sad all this!

Stefan

Changed in gnome-terminal:
importance: Unknown → Medium
Tom Adams (holizz) wrote :

I thought I'd mention that I spun off the portion of this bug dealing with UI changes into bug #762399.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.