xvidcap crashed with SIGSEGV in avcodec_open()

Bug #207406 reported by kr0ots on 2008-03-26
168
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Xvidcap
Unknown
Unknown
ffmpeg (Ubuntu)
High
Unassigned
Hardy
Medium
Unassigned
xvidcap (Ubuntu)
Undecided
Unassigned
Hardy
Undecided
Unassigned

Bug Description

Binary package hint: xvidcap

Crashed when i try to capture my screen
I use Hardy Heron Beta

ProblemType: Crash
Architecture: i386
CrashCounter: 1
Date: Wed Mar 26 23:16:09 2008
DistroRelease: Ubuntu 8.04
ExecutablePath: /usr/bin/xvidcap
NonfreeKernelModules: nvidia
Package: xvidcap 1.1.6-0.1ubuntu1
PackageArchitecture: i386
ProcCmdline: xvidcap
ProcEnviron:
 PATH=/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/usr/games
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: xvidcap
StacktraceTop:
 avcodec_open () from /usr/lib/libavcodec.so.1d
 ?? ()
 ?? () from /lib/ld-linux.so.2
 ?? ()
 ?? ()
Title: xvidcap crashed with SIGSEGV in avcodec_open()
Uname: Linux 2.6.24-12-generic i686
UserGroups: adm admin audio cdrom dialout dip floppy lpadmin plugdev video

kr0ots (kr0ots) wrote :

StacktraceTop:avcodec_open (avctx=0x8478960, codec=0x0) at utils.c:811
add_audio_stream (job=<value optimized out>) at xtoffmpeg.c:483
xvc_ffmpeg_save_frame (fp=0x8352ac8, image=0x8386cd8) at xtoffmpeg.c:1532
commonCapture (capfunc=SHM) at capture.c:1160
do_record_thread () at gnome_ui.c:518

Changed in xvidcap:
importance: Undecided → Medium
Changed in xvidcap:
status: New → Confirmed

I forwarded this bug upstream: http://sourceforge.net/support/tracker.php?aid=1969996

From upstream developer:

"Can you try to reproduce with current SVN? ... because I cannot."

If any one is willing to try the development version, they can check it out with this command:

"svn co https://xvidcap.svn.sourceforge.net/svnroot/xvidcap/trunk xvidcap"

If it is working there, we can try and update the Ubuntu version.

Todd Deshane (deshantm) wrote :

I just tried the SVN. It works great, even with audio enabled.

It is easy to build and install from source too.

Todd Deshane (deshantm) wrote :

For those that stumble across this before a ubuntu package is added, here is what I did:

sudo apt-get install subversion autoconf automake
svn co https://xvidcap.svn.sourceforge.net/svnroot/xvidcap/trunk xvidcap
cd xvidcap
make
./autogen.sh
make
sudo apt-get remove xvidcap
sudo make install
xvidcap

I had the same problem. But only happens when the MP3 audio codec is selected. With the MP2, Vorbis and PCM16 works. I downloaded the current version svn and build but not worked. The problem persists in a different way, the program hangs and dont close. I have all of mp3 codecs installed. To circumvent the problem rec with Audio Vorbis codec, after convert if necessary.

I am using xubuntu 8.04 LTS...

Martin Kossick (hacktick) wrote :

When will an update be available for the update-manager?

James Westby (james-w) on 2008-06-12
Changed in xvidcap:
importance: Medium → High

I want to also comment that when you perfrom what Todd Deshane stated above, do the following prior to those commands.

sudo apt-get build-dep xvidcap

This will keep you from having to look for stray deps, I found that there are a few more steps to take w/ the latest xvidcap.
It now works flawlessly with sound as well.

Also for a quick fix (sorry for the extra post) you can use xterm since its installed by default anyways w/ Xorg.
Go to "Preferences -> Commands -> Go to the transcoding and editing commands, change x-terminal-emulator to xterm"
All should work fine from there.

Luca Falavigna (dktrkranz) wrote :

This is fixed in Intrepid with ffmpeg-debian, could be worth fixing it in Hardy. I attach a debdiff which fixes this issue in ffmpeg source package and subscribe ubuntu-sru for approval.

Changed in ffmpeg:
status: Confirmed → Fix Released
importance: Undecided → Medium
status: New → Triaged
Martin Pitt (pitti) wrote :

Looks good to me, approved.

Martin Pitt (pitti) wrote :

Accepted into -proposed, please test and give feedback here. Please see https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in ffmpeg:
status: Triaged → Fix Committed
Changed in xvidcap:
status: New → Invalid
status: New → Invalid
Paul Elliott (omahn) wrote :

It appears the issue still exists in -proposed. After recreating the issue with 3:0.cvs20070307-5ubuntu7.1 I installed 3:0.cvs20070307-5ubuntu7.2 from -proposed and once again recreated the issue. Updated crash file attached.

Martin Pitt (pitti) wrote :

I removed the package from hardy-proposed.

Changed in ffmpeg:
status: Fix Committed → Confirmed
Reinhard Tartler (siretart) wrote :

from a quick glance, I don't think the problem is in ffmpeg, but in avidemux.

avidemux tries to load the codec for mp3. ffmpeg does not have mp3 support built-in, but uses lame. lame support is only available in libavcodec-unstripped-51 in multiverse, not in main.

the correct fix is to add a check for null in avidemux and report a "codec not found" to the user instead of relying that lame is available.

browe (brianmrowe-7effect) wrote :

I'm using intel with 8.04 x32. latest updates. xvidcap crashes usually in less than 30 secs. I'm trying to capture a small box of firefox session. Really doesn't matter what I do. I have tried without audio. I tried changing the audio to PCM16 but that didn't help. Vorbis lasted almost 1 min.

Here is the term session:
b@saturn:~$ xvidcap
/home/browe/.themes/Darker theme/gtk-2.0/gtkrc:50: Clearlooks configuration option "menuitemstyle" is not supported and will be ignored.
/home/browe/.themes/Darker theme/gtk-2.0/gtkrc:51: Clearlooks configuration option "listviewitemstyle" is not supported and will be ignored.
/home/browe/.themes/Darker theme/gtk-2.0/gtkrc:52: Clearlooks configuration option "progressbarstyle" is not supported and will be ignored.
[mpeg4 @ 0xb77356e8]removing common factors from framerate
Locking assertion failure. Backtrace:
#0 /usr/lib/libxcb-xlib.so.0 [0xb6b7c767]
#1 /usr/lib/libxcb-xlib.so.0(xcb_xlib_unlock+0x31) [0xb6b7c8b1]
#2 /usr/lib/libX11.so.6 [0xb702a421]
#3 /usr/lib/libX11.so.6(XPending+0x43) [0xb70149b3]
#4 /usr/lib/libgdk-x11-2.0.so.0 [0xb7a6e04d]
#5 /usr/lib/libgdk-x11-2.0.so.0 [0xb7a6e141]
#6 /usr/lib/libglib-2.0.so.0(g_main_context_prepare+0x18f) [0xb786357f]
#7 /usr/lib/libglib-2.0.so.0 [0xb7863d39]
#8 /usr/lib/libglib-2.0.so.0(g_main_loop_run+0x1e7) [0xb7864467]
#9 /usr/lib/libgtk-x11-2.0.so.0(gtk_main+0xb4) [0xb7d19264]
#10 xvidcap(xvc_ui_run+0xb) [0x805b02b]
#11 xvidcap(main+0x84f) [0x806732f]
#12 /lib/tls/i686/cmov/libc.so.6(__libc_start_main+0xe0) [0xb70f6450]
#13 xvidcap [0x8051371]

browe (brianmrowe-7effect) wrote :

On 8.04 on compiled trunk and it worked great. I am not on 8.10 so I can retest again.

gnowak (gnowak-gmail) wrote :

I am trying to get xvidcap working in Jaunty Kubuntu 9.04

I can't get sound because the bulit-in library is without audio.

And when I try to compile for trung i get the folowing errors:

No package 'gtk+-2.0' found
No package 'libglade-2.0' found

sudo apt-get build-dep xvidcap
Reading package lists... Done
Building dependency tree
Reading state information... Done
E: Build-dependencies for xvidcap could not be satisfied.

Rolf Leggewie (r0lf) wrote :

Hardy has seen the end of its life and is no longer receiving any updates. Marking the Hardy task for this ticket as "Won't Fix".

Changed in ffmpeg (Ubuntu Hardy):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.