Comment 313 for bug 173890

> Perhaps. Or turned into a package that tells you how, or helps, to enable the other one? Other options?

Maybe temporarily until the next release when it is removed completely? It wouldn't make sense to keep the package long-term.

>> how will end users use the intrepid partner repository pasted above?
>
>System->Administration->Software Sources->Third Party. Enable the "partner" choices.

To paraphrase Greg's point, that will not work for his mom/grandma. This sounds like a small issue, but things like this are what keep Ubuntu as more of a 'geek' option. On Windows, you click 'Get Adobe Flash Player' and it installs and just works. On Linux, you get a combo box which lets you select .tar.gz, .deb, etc and it downloads those files. You're now forced to know what they are in the first place, how to use archives or how to use dpkg to install a deb file. Or, you have to know about adobe-flashplugin, know how to enable the 'partner' repo and know how to install it. There is nothing connecting the ubiquitous 'Get Adobe Flash Player' icon with installing the package. Any technical issues which prevent this from occurring (e.g. browser support, the 'partner' repo isn't enabled by default) need to be resolved for the overall Ubuntu user experience to be successful.

Ideal situation:

Ubuntu user goes to Adobe.com, clicks on 'Get Adobe Flash Player'. They are presented with a dialog saying 'To install the Adobe flash player, the adobe-flashplugin package needs to be installed.' with a button to click on to spawn the installation of the package in the update manager.