Add Dell Privacy Mic Mute Key mapping

Bug #1926547 reported by Andy Chi
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Critical
Andy Chi
Focal
Undecided
Unassigned
systemd (Ubuntu)
Medium
Unassigned
Focal
Critical
Andy Chi
Groovy
Critical
Andy Chi
Hirsute
Critical
Andy Chi

Bug Description

[Impact]

 * Dell introduces new function called Dell Privacy, it utilizes hardware mute to control audio and camera. The commit map the reported key event to mic mute for making userspace can work as before, "Mic Mute" dialog pop-up while the mic mute button is pressed.

[Test Plan]

 * Use a Dell machine, which has Dell privacy function, and press mic mute key.
   GUI will pop up "Mic Mute" icon.

[Where problems could occur]

 * This change adds key event mapping in hwdb, which won't impact other hardware.

 any regression would likely cause problems with key(s) from the specific dell kb matching the modified listing in the hw db.

[Other Info]

 * The change can only work with kernel commit on some specific hardware, ex. Latitude 9520. The commit series is "hardware-privacy-implementation-for-dell-laptop" in alsa-devel kernel tree.
   https://patchwork.kernel.org/project/alsa-devel/list/?series=465445
 * This change has been verified on Dell machine.

Andy Chi (andch)
Changed in systemd (Ubuntu):
assignee: nobody → Andy Chi (andch)
tags: added: oem-priority originate-from-1895961 somerville
Changed in systemd (Ubuntu):
assignee: Andy Chi (andch) → nobody
Changed in oem-priority:
assignee: nobody → Andy Chi (andch)
description: updated
description: updated
summary: - Add Dell Privacy Mic Mute Key
+ Add Dell Privacy Mic Mute Key event mapping
summary: - Add Dell Privacy Mic Mute Key event mapping
+ Add Dell Privacy Mic Mute Key mapping
Revision history for this message
Andy Chi (andch) wrote :

Upload debdiff of focal.

Revision history for this message
Andy Chi (andch) wrote :

Upload debdiff of hirsute.

Mathew Hodson (mhodson)
Changed in systemd (Ubuntu):
importance: Undecided → Medium
Balint Reczey (rbalint)
Changed in systemd (Ubuntu):
status: New → Triaged
Revision history for this message
Balint Reczey (rbalint) wrote :

I've picked up the fix for the next upload to Impish, then it can be SRUd together with other fixes.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 247.3-5ubuntu1

---------------
systemd (247.3-5ubuntu1) impish; urgency=medium

  [ Balint Reczey ]
  * Merge to Ubuntu from Debian unstable
    - Dropped changes:
      * LoadCredentials: do not assert on invalid syntax (now present in Debian)
  * debian/tests: Split upstream test to two parts.
    The test can take very long time and may time out as it could be
    observed in Ubuntu's CI system many times.
    Files:
    - debian/tests/control
    - debian/tests/upstream
    - debian/tests/upstream-1
    - debian/tests/upstream-2
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=a7f894c42d650e3ec62c88c34bdd693a9dfd8df6
  * debian/gbp.conf: Update debian-branch to ubuntu-impish
    File: debian/gbp.conf
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=98449bf7530b1b834ba71c80c1a58f2e3909c668

  [ Andy Chi ]
  * Apply upstream patch to correct key and device mapping (LP: #1926547)
    File: debian/patches/0001-hwdb-60-keyboard-Update-Dell-Privacy-Micmute-Hotkey-.patch
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=0ad362c1975705805c94a17e1887cd3982cc192f

systemd (247.3-5) unstable; urgency=medium

  * udev-udeb: setup /dev/fd, /dev/std{in,out,err} symlinks.
    As systemd-udevd no longer sets them up itself, we create them manually
    after mounting devtmpfs. This avoids breaking applications which expect
    those symlinks. (Closes: #975018)

systemd (247.3-4) unstable; urgency=medium

  [ Luca Boccassi ]
  * Backport patch to fix assert with invalid LoadCredentials=
    Regression introduced in v247, fixed in v249, see:
    https://github.com/systemd/systemd/issues/19178
    (Closes: #986302)

  [ Michael Biebl ]
  * network: Delay addition of IPv6 Proxy NDP addresses.
    Fixes "IPv6 Proxy NDP addresses are being lost from interfaces after
    networkd adds them". (Closes: #985510)

 -- Balint Reczey <email address hidden> Tue, 04 May 2021 14:20:02 +0200

Changed in systemd (Ubuntu):
status: Triaged → Fix Released
Revision history for this message
Kai-Chuan Hsieh (kchsieh) wrote :

@rbalint

Hello,

Can the change be picked to focal systemd SRU? Dell would like to start the feature from focal.

Thanks,

no longer affects: oem-priority/focal
Rex Tsai (chihchun)
Changed in oem-priority:
importance: Undecided → Critical
Revision history for this message
Dan Streetman (ddstreet) wrote :

sorry for the delay. It's queued up for f/g/h and will be in the next uploads.

Changed in systemd (Ubuntu Focal):
status: New → In Progress
Changed in systemd (Ubuntu Groovy):
status: New → In Progress
Changed in systemd (Ubuntu Hirsute):
status: New → In Progress
importance: Undecided → Medium
Changed in systemd (Ubuntu Focal):
importance: Undecided → Critical
Changed in systemd (Ubuntu Groovy):
importance: Undecided → Critical
Changed in systemd (Ubuntu Hirsute):
importance: Medium → Critical
Changed in systemd (Ubuntu Focal):
assignee: nobody → Andy Chi (andch)
Changed in systemd (Ubuntu Groovy):
assignee: nobody → Andy Chi (andch)
Changed in systemd (Ubuntu Hirsute):
assignee: nobody → Andy Chi (andch)
description: updated
Revision history for this message
Andy Chi (andch) wrote :

Hello @ddstreet,
Is Groovy also need to apply this change? I thought it's non LTS, so I didn't make diff file.

Revision history for this message
Dan Streetman (ddstreet) wrote :

> Is Groovy also need to apply this change

yes, the SRU process does require all changes to be applied in all affected releases, or at least all newer affected releases (meaning, if we want to patch focal, we have to patch groovy and hirsute too).

Revision history for this message
Andy Chi (andch) wrote :

Hi @Dan,
Audio doesn't work on the platform since lack of SRU LP#1924970, I locally build a workable alsa-ucm-conf and systemd to test mic mute key on groovy for the platform. Also it needs oem kernel to support Dell Privacy. Since audio is not supported on groovy, could we pass it? Can we proceed for focal first?

Thanks.

Revision history for this message
Dan Streetman (ddstreet) wrote :

I uploaded the patched systemd to the groovy queue already; will the patch for this bug actually break/regress anything? if not then let's leave it in

Revision history for this message
Andy Chi (andch) wrote :

Hi @Dan,
No, the patch won't break anything in groovy.

Thanks for help.

Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Andy, or anyone else affected,

Accepted systemd into hirsute-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/247.3-3ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-hirsute to verification-done-hirsute. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-hirsute. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in systemd (Ubuntu Hirsute):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-hirsute
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello Andy, or anyone else affected,

Accepted systemd into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/246.6-1ubuntu1.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in systemd (Ubuntu Groovy):
status: In Progress → Fix Committed
tags: added: verification-needed-groovy
Revision history for this message
Brian Murray (brian-murray) wrote :

Hello Andy, or anyone else affected,

Accepted systemd into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/245.4-4ubuntu3.7 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in systemd (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed-focal
Revision history for this message
Andy Chi (andch) wrote (last edit ):

Test with machine which supports Dell privacy. Mic mute key works well in groovy and focal.

[kernel version]
linux-oem-20.04b (1029)

[systemd version]
246.6-1ubuntu1.4 (groovy)
245.4-4ubuntu3.7 (focal)

[alsa-ucm-conf]
local build deb (groovy)
1.2.2-1ubuntu0.7

tags: added: verification-done-focal verification-done-groovy
removed: verification-needed-focal verification-needed-groovy
Dan Streetman (ddstreet)
tags: added: verification-done verification-done-hirsute
removed: verification-needed verification-needed-hirsute
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (systemd/246.6-1ubuntu1.4)

All autopkgtests for the newly accepted systemd (246.6-1ubuntu1.4) for groovy have finished running.
The following regressions have been reported in tests triggered by the package:

casync/2+20190213-1 (s390x)
udisks2/2.9.1-2ubuntu1 (arm64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/groovy/update_excuses.html#systemd

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (systemd/247.3-3ubuntu3.1)

All autopkgtests for the newly accepted systemd (247.3-3ubuntu3.1) for hirsute have finished running.
The following regressions have been reported in tests triggered by the package:

systemd/247.3-3ubuntu3.1 (armhf)
udisks2/2.9.2-1ubuntu1 (arm64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/hirsute/update_excuses.html#systemd

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 247.3-3ubuntu3.1

---------------
systemd (247.3-3ubuntu3.1) hirsute; urgency=medium

  [ Andy Chi ]
  * debian/patches/lp1926547-hwdb-60-keyboard-Update-Dell-Privacy-Local-Mic-Mute-.patch
    - Apply upstream patch to correct key and device mapping.
      (LP: #1926547)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=f360a705d992205e3da511910c859e81390e93c6

  [ Łukasz 'sil2100' Zemczak ]
  * d/p/lp1664844/0001-network-add-ActivationPolicy-configuration-parameter.patch,
    d/p/lp1664844/0002-test-add-ActivationPolicy-unit-tests.patch,
    d/p/lp1664844/0003-save-link-activation-policy-to-state-file-and-displa.patch:
    - add support for configuring the activation policy for an interface
      (LP: #1664844)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=ae75627f573f5946169819e4fdfe89290badaf21

  [ Dan Streetman ]
  * d/p/debian/UBUNTU-resolved-Mitigate-DVE-2018-0001-by-retrying-NXDOMAIN-with.patch,
    d/p/lp1785383-resolved-address-DVE-2018-0001.patch:
    - Use upstream patch for DVE-2018-0001 handling (LP: #1785383)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=6c6e948e4364649a4a803a8f1c9cdd5c70e1f0ab
  * d/p/lp1929849-rfkill-add-some-casts-to-silence-Werror-sign-compare.patch:
    - Fix FTBFS due to kernel header change (LP: #1929849)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=656bfde76b7a2d172d84d4e7905d80e1dfa2b68d

 -- Dan Streetman <email address hidden> Thu, 27 May 2021 11:09:57 -0400

Changed in systemd (Ubuntu Hirsute):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for systemd has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 246.6-1ubuntu1.4

---------------
systemd (246.6-1ubuntu1.4) groovy; urgency=medium

  [ Andy Chi ]
  * debian/patches/lp1926547-hwdb-60-keyboard-Update-Dell-Privacy-Local-Mic-Mute-.patch
    - Apply upstream patch to correct key and device mapping.
      (LP: #1926547)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=a4c14d1c8370445e315ffa59b0a7ce593a79fbf4

  [ Dan Streetman ]
  * d/p/lp1921696/0001-rfkill-improve-error-logging.patch,
    d/p/lp1921696/0002-rfkill-use-short-writes-and-accept-long-reads.patch:
    Handle rfkill api change in kernel 5.10 (LP: #1921696)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=b683c842c74b5f193555fd79bc76e574a025f5b1
  * d/p/lp1929560-network-move-set-MAC-and-set-nomaster-operations-out.patch:
    Move link mac and master config out of link_up() (LP: #1929560)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=a90963d52a70c0ed1b429b1025b95f8c0fa6e7aa
  * d/p/lp1902891-core-mount-mount-command-may-fail-after-adding-the-c.patch:
    Handle failed mount command (LP: #1902891)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=d83f3bce38e04395c6406c3c45efbc9977ae1138
  * d/p/debian/UBUNTU-resolved-Mitigate-DVE-2018-0001-by-retrying-NXDOMAIN-with.patch,
    d/p/lp1880258-log-nxdomain-as-debug.patch,
    d/p/lp1785383-resolved-address-DVE-2018-0001.patch:
    - Use upstream patch for DVE-2018-0001 handling (LP: #1785383)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=eb311ad89c5fd570bf3af362d8a2af1b357be3dd

  [ Łukasz 'sil2100' Zemczak ]
  * d/p/lp1664844/0001-network-add-ActivationPolicy-configuration-parameter.patch,
    d/p/lp1664844/0002-test-add-ActivationPolicy-unit-tests.patch,
    d/p/lp1664844/0003-save-link-activation-policy-to-state-file-and-displa.patch:
    - add support for configuring the activation policy for an interface
      (LP: #1664844)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=0b0a9202964b24fb8d9fb4b28bdb22c6aadd25b7

 -- Dan Streetman <email address hidden> Thu, 27 May 2021 11:13:07 -0400

Changed in systemd (Ubuntu Groovy):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 245.4-4ubuntu3.7

---------------
systemd (245.4-4ubuntu3.7) focal; urgency=medium

  [ Andy Chi ]
  * debian/patches/lp1926547-hwdb-60-keyboard-Update-Dell-Privacy-Local-Mic-Mute-.patch
    - Apply upstream patch to correct key and device mapping.
      (LP: #1926547)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=62c3ce6d6b2cab762b24aa610d6d135a67bdd76a

  [ Dan Streetman ]
  * d/p/lp1921696/0001-rfkill-improve-error-logging.patch,
    d/p/lp1921696/0002-rfkill-use-short-writes-and-accept-long-reads.patch:
    Handle rfkill api change in kernel 5.10 (LP: #1921696)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=ff0c23ba4fbcfa7f68e98adb6d62798ce54ca1da
  * d/p/lp1929122-network-check-that-received-ifindex-is-valid.patch:
    Check if ifindex is valid (LP: #1929122)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=6378191818bc7d169b657e6f7a2b50cfddb4275e
  * d/p/lp1929560-network-move-set-MAC-and-set-nomaster-operations-out.patch:
    Move link mac and master config out of link_up() (LP: #1929560)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=28cff7ee02a9ebd4ab93026af9fceaa2283725b3
  * d/p/lp1902891-core-mount-mount-command-may-fail-after-adding-the-c.patch:
    Handle failed mount command (LP: #1902891)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=b425189a483d7455db870b0ec5b2443c0eea7d76
  * d/p/resolved-Mitigate-DVE-2018-0001-by-retrying-NXDOMAIN-with.patch,
    d/p/lp1880258-log-nxdomain-as-debug.patch,
    d/p/lp1785383-resolved-address-DVE-2018-0001.patch:
    - Use upstream patch for DVE-2018-0001 handling (LP: #1785383)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=ec45ebfee362ad3e429642f7519e8b88f16dc221

  [ Łukasz 'sil2100' Zemczak ]
  * d/p/lp1664844/0001-network-add-ActivationPolicy-configuration-parameter.patch,
    d/p/lp1664844/0002-test-add-ActivationPolicy-unit-tests.patch,
    d/p/lp1664844/0003-save-link-activation-policy-to-state-file-and-displa.patch:
    - add support for configuring the activation policy for an interface
      (LP: #1664844)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=94f7b72d8128c743f35b308101a87d2c53a4074c

 -- Dan Streetman <email address hidden> Thu, 27 May 2021 11:16:17 -0400

Changed in systemd (Ubuntu Focal):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.