upgrading systemd on groovy terminates sessions

Bug #1923618 reported by Thadeu Lima de Souza Cascardo on 2021-04-13

This bug report will be marked for expiration in 30 days if no further activity occurs. (find out why)

8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
systemd (Ubuntu)
Undecided
Unassigned
Groovy
Undecided
Unassigned

Bug Description

Whenever I upgrade systemd on my groovy system, my gnome session is terminated.

This is very annoying, as everything that was running on that session is terminated.

NetworkManager also stops running.

Revision history for this message
Dan Streetman (ddstreet) wrote :

I tried reproducing this in a VM, but it was able to upgrade systemd with no problems, is there anything in your logs indicating why the gnome session was terminated?

Changed in systemd (Ubuntu Groovy):
status: New → Incomplete
Changed in systemd (Ubuntu):
status: New → Incomplete
Revision history for this message
Thadeu Lima de Souza Cascardo (cascardo) wrote :

Hey, Dan.

Thanks for looking into this. I am attaching a journal log from the time I got the failure.

Cascardo.

Revision history for this message
Dan Streetman (ddstreet) wrote :

It looks like something happened to dbus, but it's hard to tell what, if anything.

Was this upgrading from 246.6-1ubuntu1.2 to 246.6-1ubuntu1.3, or some other versions?

Revision history for this message
Thadeu Lima de Souza Cascardo (cascardo) wrote :

This was the upgrade in question.

Aptitude 0.8.12: log report
Tue, Apr 13 2021 10:34:25 -0300

  IMPORTANT: this log only lists intended actions; actions which fail
  due to dpkg problems may not be completed.

Will install 16 packages, and remove 0 packages.
7168 B of disk space will be used
========================================
[HOLD, DEPENDENCIES] grub-common:amd64 2.04-1ubuntu35.4
[HOLD, DEPENDENCIES] grub-efi-amd64-bin:amd64 2.04-1ubuntu35.4
[HOLD, DEPENDENCIES] grub-pc:amd64 2.04-1ubuntu35.4
[HOLD, DEPENDENCIES] grub-pc-bin:amd64 2.04-1ubuntu35.4
[HOLD, DEPENDENCIES] grub2-common:amd64 2.04-1ubuntu35.4
[HOLD, DEPENDENCIES] libseccomp2:amd64 2.4.3-1ubuntu4
[HOLD, DEPENDENCIES] linux-firmware:amd64 1.190.3
[HOLD] grub-efi-amd64-signed:amd64 1.155.4+2.04-1ubuntu35.4
[UPGRADE] alsa-ucm-conf:amd64 1.2.2-1ubuntu5.1 -> 1.2.2-1ubuntu5.2
[UPGRADE] apt:amd64 2.1.10ubuntu0.2 -> 2.1.10ubuntu0.3
[UPGRADE] apt-utils:amd64 2.1.10ubuntu0.2 -> 2.1.10ubuntu0.3
[UPGRADE] libapt-pkg6.0:amd64 2.1.10ubuntu0.2 -> 2.1.10ubuntu0.3
[UPGRADE] libnss-mymachines:amd64 246.6-1ubuntu1.2 -> 246.6-1ubuntu1.3
[UPGRADE] libnss-systemd:amd64 246.6-1ubuntu1.2 -> 246.6-1ubuntu1.3
[UPGRADE] libpam-systemd:amd64 246.6-1ubuntu1.2 -> 246.6-1ubuntu1.3
[UPGRADE] libsystemd-dev:amd64 246.6-1ubuntu1.2 -> 246.6-1ubuntu1.3
[UPGRADE] libsystemd0:amd64 246.6-1ubuntu1.2 -> 246.6-1ubuntu1.3
[UPGRADE] libudev-dev:amd64 246.6-1ubuntu1.2 -> 246.6-1ubuntu1.3
[UPGRADE] libudev1:amd64 246.6-1ubuntu1.2 -> 246.6-1ubuntu1.3
[UPGRADE] systemd:amd64 246.6-1ubuntu1.2 -> 246.6-1ubuntu1.3
[UPGRADE] systemd-container:amd64 246.6-1ubuntu1.2 -> 246.6-1ubuntu1.3
[UPGRADE] systemd-sysv:amd64 246.6-1ubuntu1.2 -> 246.6-1ubuntu1.3
[UPGRADE] systemd-timesyncd:amd64 246.6-1ubuntu1.2 -> 246.6-1ubuntu1.3
[UPGRADE] udev:amd64 246.6-1ubuntu1.2 -> 246.6-1ubuntu1.3
========================================

Revision history for this message
Dan Streetman (ddstreet) wrote :

i've tried a few times upgrading with different combinations of package versions, but i can't seem to reproduce any problem that terminates the gnome session. I assume you haven't seen it happen again, since there hasn't been another systemd upgrade yet for groovy?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers