hyperv: unable to distinguish PTP devices

Bug #1913763 reported by Gauthier Jolly
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
systemd (Ubuntu)
Fix Released
Medium
Balint Reczey
Xenial
Fix Released
Undecided
Unassigned
Bionic
Fix Released
Medium
Unassigned
Focal
Fix Released
Medium
Unassigned
Groovy
Fix Released
Medium
Unassigned

Bug Description

[impact]

the /dev/ptp0 device for a hyperv instance may not be the correct, hyperv-provided, ptp device.

[test case]

on some hyperv instance types, particularly those that might contain passthrough network card(s) that also provide ptp, the first ptp device may not be the correct one to use for ptp, e.g. there may be multiple ones:

$ ls /dev/ptp*
/dev/ptp0 /dev/ptp1
$ cat /sys/class/ptp/ptp0/clock_name
hyperv
$ cat /sys/class/ptp/ptp1/clock_name
mlx5_p2p

the order can change across boots, so a consistent way of addressing the hyperv-provided one is needed

[regression potential]

any regression would involve failure to properly create the ptp symlink, or other failure while udev is processing newly detected ptp device(s)

[scope]

this is needed in all releases

this was fixed upstream with the commit 32e868f058da8b90add00b2958c516241c532b70 which is not yet included in any release

[original description]

Hyperv provides a PTP device. On system with multiple PTP devices, services like Chrony don't have a way to know which one is which.

We would like to have a udev rule to create a symlink to the hyperv clock. This way, services could be configured to always use this clock no matter if it is ptp0, ptp1, etc..

For example:

```
SUBSYSTEM=="ptp", ATTR{clock_name}=="hyperv", SYMLINK += "ptp_hyperv"
```

Revision history for this message
Gauthier Jolly (gjolly) wrote :

A similar rule has already been added upstream for KVM PTP device, see: https://github.com/systemd/systemd/pull/5495

Revision history for this message
Gauthier Jolly (gjolly) wrote :
tags: added: rls-hh-incoming
Balint Reczey (rbalint)
Changed in systemd (Ubuntu):
assignee: nobody → Balint Reczey (rbalint)
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in systemd (Ubuntu):
status: New → Confirmed
Balint Reczey (rbalint)
Changed in systemd (Ubuntu):
status: Confirmed → Fix Committed
Dan Streetman (ddstreet)
description: updated
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Gauthier, or anyone else affected,

Accepted systemd into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/246.6-1ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

description: updated
Changed in systemd (Ubuntu Groovy):
status: New → Fix Committed
tags: added: verification-needed verification-needed-groovy
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Hello Gauthier, or anyone else affected,

Accepted systemd into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/245.4-4ubuntu3.5 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in systemd (Ubuntu Focal):
status: New → Fix Committed
tags: added: verification-needed-focal
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Hello Gauthier, or anyone else affected,

Accepted systemd into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/237-3ubuntu10.45 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in systemd (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (systemd/237-3ubuntu10.45)

All autopkgtests for the newly accepted systemd (237-3ubuntu10.45) for bionic have finished running.
The following regressions have been reported in tests triggered by the package:

corosync/2.4.3-0ubuntu1.1 (armhf)
lxc/3.0.3-0ubuntu1~18.04.1 (amd64)
openssh/1:7.6p1-4ubuntu0.3 (amd64, ppc64el, arm64, i386, armhf, s390x)
linux-hwe-5.0/5.0.0-65.71 (i386)
linux-hwe-5.4/5.4.0-67.75~18.04.1 (i386)
gvfs/1.36.1-0ubuntu1.3.3 (amd64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#systemd

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Mathew Hodson (mhodson) wrote :

This bug was fixed in the package systemd - 247.3-1ubuntu4

---------------
systemd (247.3-1ubuntu4) hirsute; urgency=medium

  [ Dimitri John Ledkov ]
  * d/p/debian/UBUNTU-resolved-Mitigate-DVE-2018-0001-by-retrying-NXDOMAIN-with.patch:
    Patch updated to reduce log level to debug
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=299002546ec2d62e7f0dd7d614ba958fc9df83c2

  [ Dan Streetman ]
  * d/p/lp1906331-sd-event-ref-event-loop-while-in-sd_event_prepare-ot.patch:
    Take event reference while processing (LP: #1906331)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=1bc38abcd3b62d317fcb62b72e26d9cb2e35ccf9
  * d/p/lp1917458-udev-rules-add-rule-to-create-dev-ptp_hyperv.patch:
    Create symlink for hyperv-provided ptp device (LP: #1917458)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=8f1ee790ad66395457ca64cb5f8a01fdd8aabe47

  [ Balint Reczey ]
  * Pick proposed patch for not returning early in udevadm (LP: #1914062)
    File: debian/patches/lp1914062-udevadm-don-t-return-early.patch
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=d8c80751a97b0c6c4df972f6f8325293aa1607c4
  * debian/tests/control: Mark systemd-fsckd flaky again.
    As promised in LP: 1915126, until further investigation.
    File: debian/tests/control
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=68fbaab272af81aab29497f7c6a3e4e6e9aa091b

 -- Balint Reczey <email address hidden> Thu, 04 Mar 2021 12:19:05 +0100

Changed in systemd (Ubuntu):
importance: Undecided → Medium
status: Fix Committed → Fix Released
Changed in systemd (Ubuntu Bionic):
importance: Undecided → Medium
Changed in systemd (Ubuntu Focal):
importance: Undecided → Medium
Changed in systemd (Ubuntu Groovy):
importance: Undecided → Medium
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (systemd/245.4-4ubuntu3.5)

All autopkgtests for the newly accepted systemd (245.4-4ubuntu3.5) for focal have finished running.
The following regressions have been reported in tests triggered by the package:

prometheus-apache-exporter/0.7.0+ds-1 (arm64)
udisks2/2.8.4-1ubuntu1 (amd64, ppc64el)
munin/2.0.56-1ubuntu1 (arm64)
docker.io/19.03.8-0ubuntu1.20.04.2 (s390x)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/focal/update_excuses.html#systemd

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (systemd/246.6-1ubuntu1.2)

All autopkgtests for the newly accepted systemd (246.6-1ubuntu1.2) for groovy have finished running.
The following regressions have been reported in tests triggered by the package:

snapd/2.48.3+20.10 (amd64)
nut/2.7.4-12ubuntu1 (ppc64el)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/groovy/update_excuses.html#systemd

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Gauthier Jolly (gjolly) wrote :

Thanks for this.

@rbalint or @ddstreet, do you plan to also backport this to Xenial?

Revision history for this message
Dan Streetman (ddstreet) wrote :

root@test-b:~# dpkg -l systemd|grep systemd
ii systemd 237-3ubuntu10.44 amd64 system and service manager
root@test-b:~# ls -l /dev/ptp*
crw------- 1 root root 246, 0 Mar 10 15:47 /dev/ptp0
crw------- 1 root root 246, 1 Mar 10 15:47 /dev/ptp1
root@test-b:~# grep . /sys/class/ptp/*/clock_name
/sys/class/ptp/ptp0/clock_name:hyperv
/sys/class/ptp/ptp1/clock_name:mlx5_p2p

root@test-b:~# dpkg -l systemd|grep systemd
ii systemd 237-3ubuntu10.45 amd64 system and service manager
root@test-b:~# ls -l /dev/ptp*
crw------- 1 root root 246, 0 Mar 10 15:53 /dev/ptp0
crw------- 1 root root 246, 1 Mar 10 15:53 /dev/ptp1
lrwxrwxrwx 1 root root 4 Mar 10 15:53 /dev/ptp_hyperv -> ptp0
root@test-b:~# grep . /sys/class/ptp/*/clock_name
/sys/class/ptp/ptp0/clock_name:hyperv
/sys/class/ptp/ptp1/clock_name:mlx5_p2p

Revision history for this message
Dan Streetman (ddstreet) wrote :

root@test-f:~# dpkg -l systemd|grep systemd
ii systemd 245.4-4ubuntu3.4 amd64 system and service manager
root@test-f:~# ls -l /dev/ptp*
crw------- 1 root root 246, 0 Mar 10 15:49 /dev/ptp0
crw------- 1 root root 246, 1 Mar 10 15:49 /dev/ptp1
root@test-f:~# grep . /sys/class/ptp/*/clock_name
/sys/class/ptp/ptp0/clock_name:hyperv
/sys/class/ptp/ptp1/clock_name:mlx5_p2p

ddstreet@test-f:~$ dpkg -l systemd|grep systemd
ii systemd 245.4-4ubuntu3.5 amd64 system and service manager
ddstreet@test-f:~$ ls -l /dev/ptp*
crw------- 1 root root 246, 0 Mar 10 16:04 /dev/ptp0
crw------- 1 root root 246, 1 Mar 10 16:04 /dev/ptp1
lrwxrwxrwx 1 root root 4 Mar 10 16:04 /dev/ptp_hyperv -> ptp0
ddstreet@test-f:~$ grep . /sys/class/ptp/*/clock_name
/sys/class/ptp/ptp0/clock_name:hyperv
/sys/class/ptp/ptp1/clock_name:mlx5_p2p

Revision history for this message
Dan Streetman (ddstreet) wrote :

ddstreet@test-g:~$ dpkg -l systemd|grep systemd
ii systemd 246.6-1ubuntu1.1 amd64 system and service manager
ddstreet@test-g:~$ ls -l /dev/ptp*
crw------- 1 root root 246, 0 Mar 10 15:50 /dev/ptp0
crw------- 1 root root 246, 1 Mar 10 15:50 /dev/ptp1
ddstreet@test-g:~$ grep . /sys/class/ptp/*/clock_name
/sys/class/ptp/ptp0/clock_name:hyperv
/sys/class/ptp/ptp1/clock_name:mlx5_p2p

ddstreet@test-g:~$ dpkg -l systemd|grep systemd
ii systemd 246.6-1ubuntu1.2 amd64 system and service manager
ddstreet@test-g:~$ ls -l /dev/ptp*
crw------- 1 root root 246, 0 Mar 10 16:07 /dev/ptp0
crw------- 1 root root 246, 1 Mar 10 16:07 /dev/ptp1
lrwxrwxrwx 1 root root 4 Mar 10 16:07 /dev/ptp_hyperv -> ptp0
ddstreet@test-g:~$ grep . /sys/class/ptp/*/clock_name
/sys/class/ptp/ptp0/clock_name:hyperv
/sys/class/ptp/ptp1/clock_name:mlx5_p2p

Revision history for this message
Dan Streetman (ddstreet) wrote :

> @rbalint or @ddstreet, do you plan to also backport this to Xenial?

sure

tags: added: verification-done verification-done-bionic verification-done-focal verification-done-groovy
removed: verification-needed verification-needed-bionic verification-needed-focal verification-needed-groovy
Revision history for this message
Gauthier Jolly (gjolly) wrote : Re: [Bug 1913763] Re: hyperv: unable to distinguish PTP devices

Awesome, thanks

On Wed, Mar 10, 2021 at 4:15 PM Dan Streetman <email address hidden>
wrote:

> > @rbalint or @ddstreet, do you plan to also backport this to Xenial?
>
> sure
>
> ** Tags removed: verification-needed verification-needed-bionic
> verification-needed-focal verification-needed-groovy
> ** Tags added: verification-done verification-done-bionic
> verification-done-focal verification-done-groovy
>
> --
> You received this bug notification because you are a member of Canonical
> Cloudware, which is subscribed to the bug report.
> https://bugs.launchpad.net/bugs/1913763
>
> Title:
> hyperv: unable to distinguish PTP devices
>
> Status in systemd package in Ubuntu:
> Fix Released
> Status in systemd source package in Bionic:
> Fix Committed
> Status in systemd source package in Focal:
> Fix Committed
> Status in systemd source package in Groovy:
> Fix Committed
>
> Bug description:
> [impact]
>
> the /dev/ptp0 device for a hyperv instance may not be the correct,
> hyperv-provided, ptp device.
>
> [test case]
>
> on some hyperv instance types, particularly those that might contain
> passthrough network card(s) that also provide ptp, the first ptp
> device may not be the correct one to use for ptp, e.g. there may be
> multiple ones:
>
> $ ls /dev/ptp*
> /dev/ptp0 /dev/ptp1
> $ cat /sys/class/ptp/ptp0/clock_name
> hyperv
> $ cat /sys/class/ptp/ptp1/clock_name
> mlx5_p2p
>
> the order can change across boots, so a consistent way of addressing
> the hyperv-provided one is needed
>
> [regression potential]
>
> any regression would involve failure to properly create the ptp
> symlink, or other failure while udev is processing newly detected ptp
> device(s)
>
> [scope]
>
> this is needed in all releases
>
> this was fixed upstream with the commit
> 32e868f058da8b90add00b2958c516241c532b70 which is not yet included in
> any release
>
> [original description]
>
> Hyperv provides a PTP device. On system with multiple PTP devices,
> services like Chrony don't have a way to know which one is which.
>
> We would like to have a udev rule to create a symlink to the hyperv
> clock. This way, services could be configured to always use this clock
> no matter if it is ptp0, ptp1, etc..
>
> For example:
>
> ```
> SUBSYSTEM=="ptp", ATTR{clock_name}=="hyperv", SYMLINK += "ptp_hyperv"
> ```
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/systemd/+bug/1913763/+subscriptions
>

Revision history for this message
Łukasz Zemczak (sil2100) wrote : Update Released

The verification of the Stable Release Update for systemd has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 246.6-1ubuntu1.2

---------------
systemd (246.6-1ubuntu1.2) groovy; urgency=medium

  [ Ioanna Alifieraki ]
  * d/p/lp1911187-systemctl-do-not-shutdown-immediately-on-scheduled-shutdo.patch:
    Do not shutdown immediately when scheduled shutdown fails (LP: #1911187)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=bbca658178d27e0ffaf759ba3115878d26c917a6

  [ Dan Streetman ]
  * d/p/debian/patches/lp1880258-log-nxdomain-as-debug.patch:
    Change NXDOMAIN 'errors' to log level debug (LP: #1880258)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=b8e864eb907469616d688eab39b20491693d7c3a
  * d/p/lp1913763-udev-rules-add-rule-to-create-dev-ptp_hyperv.patch:
    Create symlink for hyperv-provided ptp device (LP: #1913763)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=83c7476c80e4139ee7c1ec18a549c30d37d3b4b2

 -- Ioanna Alifieraki <email address hidden> Tue, 23 Feb 2021 02:31:55 +0200

Changed in systemd (Ubuntu Groovy):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 245.4-4ubuntu3.5

---------------
systemd (245.4-4ubuntu3.5) focal; urgency=medium

  [ Ioanna Alifieraki ]
  * d/p/lp1911187-systemctl-do-not-shutdown-immediately-on-scheduled-shutdo.patch:
    Do not shutdown immediately when scheduled shutdown fails (LP: #1911187)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=3899c9d5c171e84fc503c6ab46aea7cc9def7235

  [ Dimitri John Ledkov ]
  * d/p/lp1878969-meson-initialize-time-epoch-to-reproducible-builds-compat.patch:
    meson: initialize time-epoch to reproducible builds compatible value
    (LP: #1878969)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=84212797d21ed08031e1d71fe5e118bdd9873c0f

  [ Dan Streetman ]
  * d/p/lp1913189-test-accept-that-char-device-0-0-can-now-be-created-.patch:
    - Fix failing test case under 5.8 kernel (LP: #1913189)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=782a382017ce188dbf9a40adabd265943d7db119
  * d/p/lp1913423-hashmap-make-sure-to-initialize-shared-hash-key-atom.patch:
    Thread-safe init of hashmap shared key (LP: #1913423)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=fc8dde7c4b1944d1583866f61c2314174b4dd06a
  * d/p/lp1902236-nss-systemd-don-t-synthesize-root-nobody-when-iterat.patch:
    Don't synthesize root/nobody when iterating (LP: #1902236)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=4d20e415ecd5b0fd032b4cf45bd9fd344cc434ac
  * d/p/debian/patches/lp1880258-log-nxdomain-as-debug.patch:
    Change NXDOMAIN 'errors' to log level debug (LP: #1880258)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=80163a2097aa876fe73b6071495ae4ad8749d04e
  * d/p/lp1913763-udev-rules-add-rule-to-create-dev-ptp_hyperv.patch:
    Create symlink for hyperv-provided ptp device (LP: #1913763)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=b02053da2ff3fee6221bd8310488af0f52b140f1

 -- Ioanna Alifieraki <email address hidden> Tue, 23 Feb 2021 00:18:57 +0000

Changed in systemd (Ubuntu Focal):
status: Fix Committed → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 237-3ubuntu10.45

---------------
systemd (237-3ubuntu10.45) bionic; urgency=medium

  [ Ioanna Alifieraki ]
  * d/p/lp1911187-systemctl-do-not-shutdown-immediately-on-scheduled-shutdo.patch:
    Do not shutdown immediately when scheduled shutdown fails (LP: #1911187)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=257135a59455f4e4063e78cdd3f5cfeca2597b5b

  [ Dimitri John Ledkov ]
  * d/p/lp1878969-meson-initialize-time-epoch-to-reproducible-builds-compat.patch:
    meson: initialize time-epoch to reproducible builds compatible value
    (LP: #1878969)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=6f5a0c94ff4a486ee0b72af926672b24d16ff5a8

  [ Dan Streetman ]
  * d/p/lp1913189-test-accept-that-char-device-0-0-can-now-be-created-.patch:
    - Fix failing test case under 5.8 kernel (LP: #1913189)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=15143ec6cd584a18866390a042348a543e5aa22d
  * d/p/lp1913423-hashmap-make-sure-to-initialize-shared-hash-key-atom.patch:
    Thread-safe init of hashmap shared key (LP: #1913423)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=95c189adb9c3e22576b26b084c7edf001cbc8307
  * d/p/lp1890448-hwdb-Add-EliteBook-to-use-micmute-hotkey.patch:
    Add EliteBook to use micmute hotkey (LP: #1890448)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=19b48bdac5129aa772fbcd2dbf8d1bb5c30c1510
  * d/p/debian/patches/lp1902553-test-disable-QEMU-based-testing-for-TEST-16-EXTEND-T.patch:
    Disable TEST-03 run under qemu (LP: #1902553)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=4e37d20ec379d169cfd53088d0c3b4d7bb65d25b
  * d/p/debian/patches/lp1883447-seccomp-add-all-time64-syscalls.patch:
    Add *time64 syscalls (LP: #1883447)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=a459492c67c5c5855b03daca4b44141705495376
  * d/p/lp1685754-pid1-by-default-make-user-units-inherit-their-umask-.patch:
    Inherit umask for --user processes (LP: #1685754)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=00df8d0e76975594adb765182c587ef495262fe1
  * d/p/debian/patches/lp1880258-log-nxdomain-as-debug.patch:
    Change NXDOMAIN 'errors' to log level debug (LP: #1880258)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=9684abed02669bfcf696763b887518cf54cd3f69
  * d/p/lp1913763-udev-rules-add-rule-to-create-dev-ptp_hyperv.patch:
    Create symlink for hyperv-provided ptp device (LP: #1913763)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=ff2a9ed2ece6bbd86a3d57f42b26cb1a6ca2845a

 -- Ioanna Alifieraki <email address hidden> Tue, 23 Feb 2021 03:45:01 +0200

Changed in systemd (Ubuntu Bionic):
status: Fix Committed → Fix Released
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Please test proposed package

Hello Gauthier, or anyone else affected,

Accepted systemd into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/229-4ubuntu21.30 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in systemd (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial
removed: verification-done
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (systemd/229-4ubuntu21.30)

All autopkgtests for the newly accepted systemd (229-4ubuntu21.30) for xenial have finished running.
The following regressions have been reported in tests triggered by the package:

upstart/unknown (armhf)
umockdev/0.8.11-2 (i386)
systemd/229-4ubuntu21.30 (amd64)
linux-aws-hwe/unknown (arm64)
snapd/2.48.3 (i386)
gvfs/1.28.2-1ubuntu1~16.04.3 (amd64)
cloudprint/0.14-5 (ppc64el)
nplan/0.32~16.04.7 (ppc64el, amd64)
cups/2.1.3-4ubuntu0.11 (ppc64el)
apt/1.2.32ubuntu0.2 (arm64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/xenial/update_excuses.html#systemd

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Dan Streetman (ddstreet) wrote :

ddstreet@ddstreet-test:~$ dpkg -l systemd|grep systemd
ii systemd 229-4ubuntu21.29 amd64 system and service manager
ddstreet@ddstreet-test:~$ ls -l /dev/ptp*
crw------- 1 root root 247, 0 Apr 1 17:29 /dev/ptp0
crw------- 1 root root 247, 1 Apr 1 17:29 /dev/ptp1
ddstreet@ddstreet-test:~$ grep . /sys/class/ptp/*/clock_name
/sys/class/ptp/ptp0/clock_name:hyperv
/sys/class/ptp/ptp1/clock_name:mlx5_p2p

ddstreet@ddstreet-test:~$ dpkg -l systemd|grep systemd
ii systemd 229-4ubuntu21.30 amd64 system and service manager
ddstreet@ddstreet-test:~$ ls -l /dev/ptp*
crw------- 1 root root 247, 0 Apr 1 17:33 /dev/ptp0
crw------- 1 root root 247, 1 Apr 1 17:33 /dev/ptp1
lrwxrwxrwx 1 root root 4 Apr 1 17:33 /dev/ptp_hyperv -> ptp0
ddstreet@ddstreet-test:~$ grep . /sys/class/ptp/*/clock_name
/sys/class/ptp/ptp0/clock_name:hyperv
/sys/class/ptp/ptp1/clock_name:mlx5_p2p

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Revision history for this message
Brian Murray (brian-murray) wrote : Please test proposed package

Hello Gauthier, or anyone else affected,

Accepted systemd into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/systemd/229-4ubuntu21.31 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-xenial
removed: verification-done verification-done-xenial
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (systemd/229-4ubuntu21.30)

All autopkgtests for the newly accepted systemd (229-4ubuntu21.30) for xenial have finished running.
The following regressions have been reported in tests triggered by the package:

linux-aws-hwe/unknown (arm64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/xenial/update_excuses.html#systemd

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Dan Streetman (ddstreet) wrote :

ddstreet@ddstreet-test:~$ dpkg -l systemd|grep systemd
ii systemd 229-4ubuntu21.29 amd64 system and service manager
ddstreet@ddstreet-test:~$ ls -l /dev/ptp*
crw------- 1 root root 247, 0 Apr 2 17:12 /dev/ptp0
crw------- 1 root root 247, 1 Apr 2 17:12 /dev/ptp1
ddstreet@ddstreet-test:~$ grep . /sys/class/ptp/*/clock_name
/sys/class/ptp/ptp0/clock_name:hyperv
/sys/class/ptp/ptp1/clock_name:mlx5_p2p

ddstreet@ddstreet-test:~$ dpkg -l systemd|grep systemd
ii systemd 229-4ubuntu21.31 amd64 system and service manager
ddstreet@ddstreet-test:~$ ls -l /dev/ptp*
crw------- 1 root root 247, 0 Apr 2 17:20 /dev/ptp0
crw------- 1 root root 247, 1 Apr 2 17:20 /dev/ptp1
lrwxrwxrwx 1 root root 4 Apr 2 17:20 /dev/ptp_hyperv -> ptp0
ddstreet@ddstreet-test:~$ grep . /sys/class/ptp/*/clock_name
/sys/class/ptp/ptp0/clock_name:hyperv
/sys/class/ptp/ptp1/clock_name:mlx5_p2p

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Revision history for this message
Ubuntu SRU Bot (ubuntu-sru-bot) wrote : Autopkgtest regression report (systemd/229-4ubuntu21.31)

All autopkgtests for the newly accepted systemd (229-4ubuntu21.31) for xenial have finished running.
The following regressions have been reported in tests triggered by the package:

conntrack-tools/unknown (armhf)
pyudev/unknown (armhf)
linux-aws-hwe/unknown (arm64)
kwin/unknown (armhf)
nplan/0.32~16.04.7 (amd64, ppc64el)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/xenial/update_excuses.html#systemd

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package systemd - 229-4ubuntu21.31

---------------
systemd (229-4ubuntu21.31) xenial; urgency=medium

  * d/p/lp1878969-time-epoch-use-source-date-epoch.patch:
    - Fix configure.ac change to set time epoch
      (LP: #1878969)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=30bf11d2759499ec94d3b82eaf22f55583f4758b

systemd (229-4ubuntu21.30) xenial; urgency=medium

  * d/p/lp1878969-time-epoch-use-source-date-epoch.patch:
    - Set time epoch using $SOURCE_DATE_EPOCH
      (LP: #1878969)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=9e1ad364d94b3619947c541b72aa506010ee3f38
  * d/p/lp1913763-udev-rules-add-rule-to-create-dev-ptp_hyperv.patch:
    - Create symlink for hyperv-provided ptp device
      (LP: #1913763)
    https://git.launchpad.net/~ubuntu-core-dev/ubuntu/+source/systemd/commit/?id=ae39f8878ca5dabb4e9d8ba5ebdb6ed003993b9f

 -- Dan Streetman <email address hidden> Thu, 01 Apr 2021 22:51:58 -0400

Changed in systemd (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers