Commands do not build windows paths correctly

Bug #1888869 reported by Patrick Wu
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
wslu (Ubuntu)
High
Patrick Wu
Focal
High
Patrick Wu
Groovy
High
Patrick Wu

Bug Description

> Original bug here: https://github.com/wslutilities/wslu/issues/133
> This is for SRU purpose.

**Background Information:**
 - Build:
```
➜ ~ wslview --version
/bin/wslview: line 108: /mntc/Windows/System32/reg.exe: No such file or directory
wslu v2.3.6; wslview v06
```
 - WSL:
```
➜ ~ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=20.04
DISTRIB_CODENAME=focal
DISTRIB_DESCRIPTION="Ubuntu 20.04.1 LTS"
```
 - Version: See above

**Describe the bug**
Binaries seem to drop a slash from the mountpath of disks, resulting in no tool under windows to be found:
```
➜ ~ wslfetch
/bin/wslfetch: line 108: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 108: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 183: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 185: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 187: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 189: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 108: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 183: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 185: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 187: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 189: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 108: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 183: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 185: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 187: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 189: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 108: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 183: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 185: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 187: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 189: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 108: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 183: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 185: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 187: /mntc/Windows/System32/reg.exe: No such file or directory
/bin/wslsys: line 189: /mntc/Windows/System32/reg.exe: No such file or directory

               .-/+oossssoo+/-. Windows 10 Linux Subsystem
           `:+ssssssssssssssssss+:` bendem@CL1277
         -+ssssssssssssssssssyyssss+- BUILD:
       .ossssssssssssssssssdMMMNysssso. BRANCH:
      /ssssssssssshdmmNNmmyNMMMMhssssss/ RELEASE: Ubuntu 20.04.1 LTS
     +ssssssssshmydMMMMMMMNddddyssssssss+ KERNEL: Linux 4.4.0-18362-Microsoft
    /sssssssshNMMMyhhyyyyhmNMMMNhssssssss/ UPTIME: 1d 5h 59m
   .ssssssssdMMMNhsssssssssshNMMMdssssssss.
   +sssshhhyNMMNyssssssssssssyNMMMysssssss+
   ossyNMMMNyMMhsssssssssssssshmmmhssssssso
   ossyNMMMNyMMhsssssssssssssshmmmhssssssso
   +sssshhhyNMMNyssssssssssssyNMMMysssssss+
   .ssssssssdMMMNhsssssssssshNMMMdssssssss.
    /sssssssshNMMMyhhyyyyhdNMMMNhssssssss/
     +sssssssssdmydMMMMMMMMddddyssssssss+
      /ssssssssssshdmNNNNmyNMMMMhssssss/
       .ossssssssssssssssssdMMMNysssso.
         -+sssssssssssssssssyyyssss+-
           `:+ssssssssssssssssss+:`
               .-/+oossssoo+/-.

```

**To Reproduce**
Steps to reproduce the behavior:
Run any command, see error

**Expected behavior**
A clear and concise description of what you expected to happen:
No error

**Additional context**
Add any other context about the problem here.

```
➜ ~ cat /etc/wsl.conf
[automount]
root = /mnt
options = "metadata,umask=22,fmask=11"
```

Patrick Wu (callmepk)
Changed in wslu (Ubuntu):
status: New → Confirmed
importance: Undecided → High
assignee: nobody → Patrick Wu (callmepk)
status: Confirmed → In Progress
Changed in wslu (Ubuntu Focal):
importance: Undecided → High
assignee: nobody → Patrick Wu (callmepk)
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package wslu - 3.2.1-0ubuntu1

---------------
wslu (3.2.1-0ubuntu1) groovy; urgency=medium

  * Update from 2.3.6 to 3.2.1 to provide new features and
    address some issues (ffe lp: #1895525)
    - Documentation: add section 7 manpage: `wslu`
    - Documentation: updated manpage system
    - Documentation: New README language Esperanto
    - Project: updated build system
    - Project: versioning system update
    - Project: add separate Fedora Remix support
    - header: add `--verbose`
    - header: refactor the header in order to speed up
    - header: handling empty ~/.config/wslu/baseexec
    - header: use the proper color definition
    - header: fix `ubuntu.exe` detection issue
    - header: prevent localappdata not found in env
    - header: improvements on the system drive detection.
      (GH: #133, LP: #1888869)
    - header: fix badly generated shortcut issue (GH: #141)
    - wslact: brand new CLI
    - wslact: adding `--mount-options` for auto-mounting feature
    - wslact: fix an i18n related issue in time-sync feature
      (GH: #113 by @ricardosantos9521)
    - wslact: add back-compatibility for the auto-mounting feature.
    - wslusc: brand new helper script (GH: #93)
    - wslusc: brand new shortcut icon
    - wslusc: always use the absolute path (fixes #129)
    - wslusc: fixes a possible white space path issue
    - wslusc: add convert not found warning
    - wslusc: fix the problem that the previous version that GUI shortcut
      generated won't work.
    - wslusc: When TMP is empty, try TEMP
    - wslusc: fix an issue that wsl.exe execute with wrongly passed param
      (GH: #138)
    - wslfetch: colorbar expanded
    - wslfetch: `--no-colorbar` become `--colorbar`
    - wslfetch: speed up execution time (GH: #100)
    - wslfetch: new display for WSL with WSL version displayed
    - wslfetch: use the proper logo for Ubuntu
      (Reported by Martin Wimpress, LP: #1883920)
    - wslview: alias of `wslstart`, `wstart`, `wview` (GH: #64)
    - wslview: browser registration parameter change
    - wslview: handling file:/// protocol (GH: #66)
    - wslview: fix a mistake in `converted_file_path`
    - wslview: properly detect all different protocols and path styles
      (GH: #118)
    - wslview: mistake in calling a variable (fixes #118 again)
    - wslview: fix a bug that it won't open `file:///mnt/c/...`
      or `/mnt/c/...`
    - wslview: add wslview.desktop (GH: #143 and #146)
    - wslsys: Display Scaling Factor (help with Pengwin GH: #559)
    - wslsys: Windows Locale
    - wslsys: Windows Theme
    - wslsys: speed up execution time
    - wslsys: add WSL version option
    - wslsys: fix an issue in DPI scaling getting wrong value due to the API
      change in Latest fast ring insider build (Reported by @crramirez)
    - wslsys: fix an issue that the WSL Version shown is wrong.
    - package: missing call to `configure.sh`
    - package: fix alpine dependency issue (GH: #117)
    - tests: update the test system and tests. (GH: #125)

 -- Patrick Wu <email address hidden> Sun, 13 Sep 2020 22:36:33 +0800

Changed in wslu (Ubuntu Groovy):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers