Shadowing the vim-window results in vim-gtk3 crash

Bug #1833174 reported by Vasilis
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
vim
Unknown
Unknown
vim (Ubuntu)
High
Unassigned
Focal
High
Unassigned
Groovy
High
Unassigned

Bug Description

With XFCE when I try to "shadow" the vim-gtk3 window (just to show only the title bar) it results in a vim crash and the window just disappears without any core dump neither .swp files on.
The only message I get on the terminal is

BadMatch (invalid parameter attributes)
Vim: Got X error
Vim: Finished.

This behaviour started from Xubuntu 18.04.
The vim-gtk package is not suffering from this problem.

ProblemType: Bug
DistroRelease: Ubuntu 19.04
Package: vim-gtk3 2:8.1.0320-1ubuntu3.1
ProcVersionSignature: Ubuntu 5.0.0-16.17-generic 5.0.8
Uname: Linux 5.0.0-16-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.10-0ubuntu27
Architecture: amd64
CurrentDesktop: XFCE
Date: Tue Jun 18 09:10:38 2019
InstallationDate: Installed on 2019-04-23 (55 days ago)
InstallationMedia: Xubuntu 19.04 "Disco Dingo" - Release amd64 (20190416)
SourcePackage: vim
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Vasilis (vasilis-vlachoudis) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in vim (Ubuntu):
status: New → Confirmed
Revision history for this message
Justin Huff (jjhuff) wrote :

Still happens on xubuntu 20.04. Unfortunately, vim-gtk2 isn't around anymore, so the workaround is invalid.

Revision history for this message
Vasilis (vasilis-vlachoudis) wrote :

Indeed 20.04 still has the problem

Revision history for this message
Justin Huff (jjhuff) wrote :

This is apparently fixed upstream, but I haven't had a chance to verify.

https://github.com/vim/vim/issues/4835

tags: added: focal groovy
Changed in vim (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → High
tags: added: rls-gg-incoming
Changed in vim (Ubuntu Focal):
milestone: none → ubuntu-20.04.1
importance: Undecided → High
status: New → Triaged
tags: added: id-5ecfd55ec365863c5d5f6027
tags: removed: rls-gg-incoming
Revision history for this message
Steve Langasek (vorlon) wrote :
Steve Langasek (vorlon)
Changed in vim (Ubuntu Focal):
milestone: ubuntu-20.04.1 → focal-updates
tags: added: fr-330
Changed in vim (Ubuntu):
status: Triaged → Fix Committed
Changed in vim (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.