ZFS installation crash when ESP already exists

Bug #1860957 reported by Soundwave
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Medium
Jean-Baptiste Lallement
Focal
Medium
Jean-Baptiste Lallement

Bug Description

Tried installing Ubuntu with ZFS auto partitioning. Crashed

ProblemType: Bug
DistroRelease: Ubuntu 19.10
Package: ubiquity 19.10.21
ProcVersionSignature: Ubuntu 5.3.0-18.19-generic 5.3.1
Uname: Linux 5.3.0-18-generic x86_64
NonfreeKernelModules: zfs zunicode zavl icp zcommon znvpair
ApportVersion: 2.20.11-0ubuntu8
Architecture: amd64
CasperVersion: 1.427
CurrentDesktop: ubuntu:GNOME
Date: Sun Jan 26 22:18:05 2020
InstallCmdLine: BOOT_IMAGE=/casper/vmlinuz file=/cdrom/preseed/ubuntu.seed only-ubiquity quiet splash ---
LiveMediaBuild: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
ProcEnviron:
 LANGUAGE=en_US.UTF-8
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 LC_NUMERIC=C.UTF-8
SourcePackage: ubiquity
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Soundwave (soundwave123) wrote :
Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

Thanks for your report.

Repartitioning failed because the ESP partition of the target disk was already mounted:

----------------

Jan 27 06:17:57 ubuntu ubiquity: Checking that no-one is using this disk right now ... FAILED
Jan 27 06:17:57 ubuntu ubiquity:
Jan 27 06:17:57 ubuntu ubiquity: This disk is currently in use - repartitioning is probably a bad idea.
Jan 27 06:17:57 ubuntu ubiquity: Umount all file systems, and swapoff all swap partitions on this disk.
Jan 27 06:17:57 ubuntu ubiquity: Use the --no-reread flag to suppress this check.

----------------

05efi: debug: /dev/nvme0n1p1 is a FAT partition (mounted by GRUB)

----------------

Changed in ubiquity (Ubuntu):
importance: Undecided → High
status: New → Confirmed
tags: added: rls-ff-incoming
summary: - Tried installing Ubuntu with ZFS auto partitioning. Crashed
+ ZFS installation crash when ESP already exists
tags: added: zfs
Steve Langasek (vorlon)
tags: removed: rls-ff-incoming
Changed in ubiquity (Ubuntu Focal):
assignee: nobody → Jean-Baptiste Lallement (jibel)
milestone: none → ubuntu-20.04-beta
Revision history for this message
Łukasz Zemczak (sil2100) wrote :

Do we still want to get this fixed for the beta? What is the status of this one?

Revision history for this message
Iain Lane (laney) wrote :

Feels like it's probably too late to me to be fixing ubiquity, I think it's move the milestone + release note.

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

It won't be fixed for Beta. I don't have a reproducible case yet.

Changed in ubiquity (Ubuntu Focal):
milestone: ubuntu-20.04-beta → ubuntu-20.04
Changed in ubiquity (Ubuntu Focal):
importance: High → Medium
Changed in ubiquity (Ubuntu Focal):
milestone: ubuntu-20.04 → ubuntu-20.04.1
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers