strange IPv6 NDP behaviour with OVN on Focal

Bug #1896938 reported by Frode Nordahl
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ovn (Ubuntu)
Undecided
Unassigned
Focal
High
Unassigned
Groovy
Undecided
Unassigned

Bug Description

[Impact]
The issue I'm seeing is that if I have multiple OVN routers connected to the same external OVS uplink switch (which in turn is connected via veth to a native linux bridge), when NDP solicit packets are sent from the native linux bridge into the logical OVN switch, for some reason every OVN router that is connected to the OVN switch retransmits the NDP packet from its own MAC address. Which in turn causes them all to receive another NDP packet, which are then all retransmitted (a flood then ensues until OVS rate limiting takes effect).

This occurs even for IPs that do not exist on the network that the OVN routers dont know anything about.

It doesn't happen for ARP, nor does it occur in Groovy.

[Test Case]
Setup single node LXD with and OVN network and then ping a non-existant IP in the uplink network from the LXD host and watch for the OVN gateway to retransmit the IPv6 NS packet from lxdbr0 back into the uplink network.

# Install OVN and setup.
sudo apt install ovn-host ovn-central tcpdump -y

sudo ovs-vsctl set open_vswitch . \
    external_ids:ovn-encap-type=geneve \
    external_ids:ovn-remote="unix:/var/run/ovn/ovnsb_db.sock" \
    external_ids:ovn-encap-ip=127.0.0.1

# Install LXD and get lxdbr0 address and subnet.
snap install lxd
lxd init --auto
lxc network show lxdbr0
  config:
    ipv4.address: 10.154.225.1/24
    ipv4.nat: "true"
    ipv6.address: fd42:37a6:2a0:c014::1/64
    ipv6.nat: "true"

# Configure lxdbr0 as compatible OVN uplink network.
lxc network set lxdbr0 ipv4.dhcp.ranges=10.154.225.2-10.154.225.10 ipv4.ovn.ranges=10.154.225.11-10.154.225.20

# Create OVN network.
lxc network create ovn1 --type=ovn network=lxdbr0

# In separate window run tcpdump on lxdbr0 with -e flag to show MAC address.
sudo tcpdump -i lxdbr0 -n -e ip6

Now ping a non-existant IP in the subnet of lxdbr0 from the LXD host, e.g. fd42:37a6:2a0:c014::2

ping fd42:37a6:2a0:c014::2

# Check tcpdump window showing duplicate IPv6 NS (from from lxdbr0 MAC address and one from the OVN network's external router port's MAC addres):
12:46:27.123496 00:16:3e:b5:3d:5e > 33:33:ff:00:00:02, ethertype IPv6 (0x86dd), length 86: fd42:37a6:2a0:c014::1 > ff02::1:ff00:2: ICMP6, neighbor solicitation, who has fd42:37a6:2a0:c014::2, length 32
12:46:27.124320 00:16:3e:ab:cc:5a > 33:33:ff:00:00:02, ethertype IPv6 (0x86dd), length 86: fd42:37a6:2a0:c014::1 > ff02::1:ff00:2: ICMP6, neighbor solicitation, who has fd42:37a6:2a0:c014::2, length 32

# Create another OVN network.
lxc network create ovn2 --type=ovn network=lxdbr0

# Check tcpdump window showing a duplicate IPv6 NS storm, now from 3 MACs:
12:48:30.025836 00:16:3e:b5:3d:5e > 33:33:ff:00:00:02, ethertype IPv6 (0x86dd), length 86: fd42:37a6:2a0:c014::1 > ff02::1:ff00:2: ICMP6, neighbor solicitation, who has fd42:37a6:2a0:c014::2, length 32
12:48:30.028238 00:16:3e:ab:cc:5a > 33:33:ff:00:00:02, ethertype IPv6 (0x86dd), length 86: fd42:37a6:2a0:c014::1 > ff02::1:ff00:2: ICMP6, neighbor solicitation, who has fd42:37a6:2a0:c014::2, length 32
12:48:30.028239 00:16:3e:31:9a:ff > 33:33:ff:00:00:02, ethertype IPv6 (0x86dd), length 86: fd42:37a6:2a0:c014::1 > ff02::1:ff00:2: ICMP6, neighbor solicitation, who has fd42:37a6:2a0:c014::2, length 32

I would only expect to see the IPv6 NS packet from the LXD host's MAC address, not the OVN gateways as well.

[Regression Potential]

[Other Info]

Revision history for this message
Frode Nordahl (fnordahl) wrote :
Changed in ovn (Ubuntu):
status: New → Fix Released
description: updated
description: updated
description: updated
description: updated
Revision history for this message
Frode Nordahl (fnordahl) wrote :

Looks like the patch is already on branch-20.03 [0] and should be included in the v20.03.1 tag.

0: https://github.com/ovn-org/ovn/commit/0924bcb07ef25f93fde683fe8f15d376eca005ec

Let's see if we can get this through as a upstream point release update.

Frode Nordahl (fnordahl)
Changed in ovn (Ubuntu Focal):
status: New → Triaged
importance: Undecided → High
Revision history for this message
Frode Nordahl (fnordahl) wrote :

This was fixed in Focal in 20.03.1-0ubuntu1 and the fix is also in the most recent 20.03.2-0ubuntu0.20.04.1 package.

Changed in ovn (Ubuntu Focal):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers