[SRU] [20.04] Update NGINX version string to 1.18.0

Bug #1875231 reported by Thomas Ward on 2020-04-26
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
nginx (Ubuntu)
Undecided
Unassigned
Focal
Undecided
Unassigned

Bug Description

[Impact]

 * NGINX 1.17.x has been retired in favor of 1.18.x branch

 * NGINX 1.18.0 is directly based off of 1.17.10 (already in the repositories) with no other major changes but a version string change and no functional differences

 * The server team in the past several LTS cycles has wanted to get latest stable into the LTS as soon as it was able. While attempted to get in before release, it was NACK'd and requested to SRU the version string change.

[Test Case]

 * N/A

[Regression Potential]

 * None - no code changes except a version string change.

[Other Info]

 * During Focal cycle, we have always planned to update nginx to 1.18.0, or SRU it soon after Focal release. This finishes off this plan to get nginx 1.17.0 stable into the repositories.

 * This only changes the version string upstream. Other changes are a result of post-Focal configuration issue discoveries, or an updated patch due to the version bump.

$ git log --pretty=oneline release-1.17.10..release-1.18.0
e6b3a11581a8040baf7aded3319b0dec433b2461 (tag: release-1.18.0) nginx-1.18.0-RELEASE
6acdee5e3213fc6054f3bbb23a44ef2576278f63 Stable branch.
3ba88365b5acef17f01671cd969c909dee5e2cde release-1.17.10 tag

I agree there aren't any changes in between 1.17.10 and 1.18.0.

Unsure about the change though.

nginx
  Reverse Depends: diaspora-common (0.7.6.1+debian1)
  Reverse Depends: fusiondirectory (1.3-2)
  Reverse Depends: kopano-webapp-nginx (3.5.14+dfsg1.orig-1)
  Reverse Depends: python3-certbot-nginx (0.39.0-1)
  Reverse Depends: rainloop (1.12.1-2)

as long as there are no hard dependencies on versioning (wonder if you're thinking in changing deb version as well)... Ubuntu SRU team would make the last call anyway.

Let me know if you're pursuing this, I'm flagging as a server team low priority queue item for now.

Thanks @teward!

Ah nm, I see you subscribed the release team already, their call then! Cheers o/

All autopkgtests for the newly accepted nginx (1.18.0-0ubuntu1) for focal have finished running.
The following regressions have been reported in tests triggered by the package:

piuparts/1.1.1build1 (amd64, ppc64el, s390x, arm64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/focal/update_excuses.html#nginx

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in nginx (Ubuntu Focal):
status: New → Confirmed
Changed in nginx (Ubuntu):
status: New → Confirmed
Thomas Ward (teward) wrote :

RE: Failures

I don't think those failures in piuparts is NGINX related rather they are debootstrap related. Digging deeper though...

Muhammad Hernawan (mhernawan) wrote :

so there is no update to nginx stable version?

The piuparts test failures is fixed now. Up to the SRU team to review it.

Thomas Ward (teward) on 2020-06-24
tags: added: verification-done-focal
Łukasz Zemczak (sil2100) wrote :

Next time please include more information about which packages were tested and what testing has been performed. That being said, as this is indeed only a version number bump, I'll accept the verification as-is.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package nginx - 1.18.0-0ubuntu1

---------------
nginx (1.18.0-0ubuntu1) focal; urgency=medium

  * Stable Release Update for Version String (LP: #1875231)
  * New upstream Stable release (1.18.0) - full changelog available from
    http://nginx.org/en/CHANGES
  * Remaining Ubuntu-specific changes:
    - debian/patches/ubuntu-branding.patch: add Ubuntu branding (refreshed)
    - d/{control,rules,nginx-core.*}: add new binary package for main,
      nginx-core, which contains only source-tarball-included modules
      and no third-party modules.
    - debian/tests/control: add nginx-core test.
    - debian/apport/source_nginx.py: Add apport hooks for additional bug
      information gathering.
    - debian/nginx-common.install: Add install rule for apport hooks.
    - d/nginx-{core,light,full,extras}.postinst: Add checks for whether
      port 80 is in use or not to determine whether or not to attempt
      starting of the NGINX service during install/upgrade
    - d/control: Add dependencies to nginx-{core,light,full,extras} on
      `iproute2` as the postinst scripts now use `ss` to determine if
      Port 80 is open or not.
    - d/rules: Enable --with-compat build option for all nginx package
      flavors
    - d/{control,rules,copyright,modules/http-geoip2*}: Add GeoIP2 third party
      module to nginx-full and nginx-extras (and use proper DEP5 syntax for
      d/copyright).
    - d/control, d/rules: Drop GeoIP from nginx-core due to demotion of
      libgeoip.

 -- Thomas Ward <email address hidden> Tue, 21 Apr 2020 10:49:01 -0400

Changed in nginx (Ubuntu Focal):
status: Confirmed → Fix Released

The verification of the Stable Release Update for nginx has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers