CML: perf enabling for core

Bug #1848978 reported by quanxian on 2019-10-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
OEM Priority Project
Critical
Yuan-Chen Cheng
intel
Undecided
Unassigned
linux (Ubuntu)
Status tracked in Focal
Bionic
Undecided
Unassigned
Disco
Undecided
You-Sheng Yang
Eoan
Medium
You-Sheng Yang
Focal
Undecided
Unassigned
linux-oem-osp1 (Ubuntu)
Status tracked in Focal
Bionic
High
You-Sheng Yang
Disco
Undecided
Unassigned
Eoan
Undecided
Unassigned
Focal
Undecided
Unassigned

Bug Description

[SRU Justification]

[Impact]
There is no complete perf support for Comet Lake CPU. For Ice Lake, some
changes has been included in v5.3, but still misses CPU IDs.

[Fix]
perf support for Comet Lake is based on previous works for Ice Lake, so
changes for both have to be backported.

[Test Case]
On platforms with Comet Lake/Ice Lake CPUs, one should find new
cstate_pkg events c{8,9,10}-residency appear in output of `perf list`
for use.

[Regression Potential]
Low. This backports perf support for previously incompletedly supported
cpu models.

========== original bug description ==========

Description:

CML perf enabling for core

v5.4-rc3
1ffa6c04dae39776a3c222bdf88051e394386c01 9066288b2aab1804dc1eebec6ff88474363b89cb 9674b1cc0f94c34f76e58c102623a866836f269e

Target Kernel: 5.4
Target Release: 20.04

quanxian (quanxian-wang) on 2019-10-21
Changed in intel:
status: New → Fix Committed

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1848978

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: focal
Changed in linux (Ubuntu):
status: Incomplete → Fix Released
Changed in linux (Ubuntu Bionic):
status: New → Confirmed
Changed in linux-oem-osp1 (Ubuntu Bionic):
status: New → Confirmed
Changed in linux-oem-osp1 (Ubuntu):
status: New → Confirmed
Changed in linux-oem-osp1 (Ubuntu Bionic):
assignee: nobody → You-Sheng Yang (vicamo)
importance: Undecided → High
You-Sheng Yang (vicamo) on 2019-11-15
Changed in linux-oem-osp1 (Ubuntu Bionic):
status: Confirmed → In Progress
You-Sheng Yang (vicamo) on 2019-11-19
Changed in linux-oem-osp1 (Ubuntu Disco):
status: New → Confirmed
Changed in linux-oem-osp1 (Ubuntu Eoan):
status: New → Confirmed
Changed in linux (Ubuntu Focal):
status: Fix Released → Confirmed
You-Sheng Yang (vicamo) wrote :

There are still something already committed to mainline but missed on the list. I have to include also IceLake support for CometLake backports to D/OEM-OSP1-B, but `perf list` doesn't give PC8-10 for IceLake platforms. However, by installing v5.4-generic kernel from https://launchpad.net/~canonical-kernel-team/+archive/ubuntu/unstable, they're back.

You-Sheng Yang (vicamo) wrote :

Fixed that for two more patches for IceLake, but the resulting tree fails to enter deeper state than PC3.

You-Sheng Yang (vicamo) wrote :

This (cannot enter PC8,9,10 on Ice Lake) can still be reproduced on 5.3.0-24.26+lp1848978.3 in my PPA, but not in ubuntu unstable kernel 5.4.0-6.7. Perhaps still some other fixes should be included as well.

You-Sheng Yang (vicamo) wrote :

Sorry, that should be a false alarm. Verified built kernels for oem-osp1, disco and eoan in my ppa on an Ice Lake platform, PC10 residency is still valid. Will proceed to send SRU patches after verified on CML as well.

You-Sheng Yang (vicamo) wrote :

To read PC10 residency, one may want to install `powertop` from ppa:canonical-hwe-team/powertop[1], which contains the latest version 2.11+.

[1]: https://launchpad.net/~canonical-hwe-team/+archive/ubuntu/powertop

You-Sheng Yang (vicamo) wrote :

For Comet Lake to read PC10 residency, please use `perf` from linux-tools packages:

  $ perf stat -e cstate_pkg/c10-residency/ \
              -e cstate_pkg/c9-residency/ \
              -e cstate_pkg/c8-residency/
  (this will block until interrupted)

as `powertop` doesn't currently support CML, either.

You-Sheng Yang (vicamo) wrote :

Mark linux-4.15 bionic as WONFIX as the scope is limited to 5.0. Actually this depends on Ice Lake function, so it has to be 5.0+ as well.

Changed in linux (Ubuntu Bionic):
status: Confirmed → Won't Fix
Changed in linux (Ubuntu Disco):
assignee: nobody → You-Sheng Yang (vicamo)
status: New → In Progress
Changed in linux (Ubuntu Eoan):
assignee: nobody → You-Sheng Yang (vicamo)
status: New → In Progress
Changed in oem-priority:
assignee: nobody → Yuan-Chen Cheng (ycheng-twn)
importance: Undecided → Critical
status: New → Confirmed
tags: added: oem-priority
Stefan Bader (smb) on 2019-11-29
Changed in linux (Ubuntu Eoan):
importance: Undecided → Medium
Changed in linux (Ubuntu Eoan):
status: In Progress → Fix Committed
You-Sheng Yang (vicamo) wrote :

Mark linux/disco as WONTFIX per review comment.

Changed in linux (Ubuntu Disco):
status: In Progress → Won't Fix
Timo Aaltonen (tjaalton) on 2019-12-04
Changed in linux-oem-osp1 (Ubuntu Bionic):
status: In Progress → Fix Committed

This bug is awaiting verification that the kernel in -proposed solves the problem. Please test the kernel and update this bug with the results. If the problem is solved, change the tag 'verification-needed-eoan' to 'verification-done-eoan'. If the problem still exists, change the tag 'verification-needed-eoan' to 'verification-failed-eoan'.

If verification is not done by 5 working days from today, this fix will be dropped from the source code, and this bug will be closed.

See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you!

tags: added: verification-needed-eoan
You-Sheng Yang (vicamo) wrote :

Verified 5.3.0-25.27/eoan-proposed

description: updated
tags: added: verification-done-eoan
removed: verification-needed-eoan
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers