btrfs fill_fs test in fallocate06 from ubuntu_ltp_syscalls failed

Bug #1866323 reported by Po-Hsu Lin
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
ubuntu-kernel-tests
Triaged
Undecided
Unassigned
linux (Ubuntu)
Incomplete
Undecided
Unassigned
Bionic
Confirmed
Undecided
Unassigned
Focal
Fix Released
Undecided
Unassigned
linux-oem-5.6 (Ubuntu)
Invalid
Undecided
Unassigned
Bionic
Confirmed
Undecided
Unassigned
Focal
Confirmed
Undecided
Unassigned

Bug Description

Test failure in fallocate06 was composed by two issues, one is xfs fill_fs test issue addressed in bug 1865967.

Another is this one, this is the case 2 of btrfs (fill_fs):

tst_test.c:1290: INFO: Testing on btrfs
tst_mkfs.c:90: INFO: Formatting /dev/loop1 with btrfs opts='' extra opts=''
tst_test.c:1229: INFO: Timeout per run is 0h 05m 00s
fallocate06.c:117: INFO: Copy-on-write is supported
fallocate06.c:168: INFO: Case 1. Fill FS: no; Use copy on write: no
fallocate06.c:157: PASS: write() successful
fallocate06.c:201: PASS: Misaligned allocation works as expected
fallocate06.c:157: PASS: fallocate(FALLOC_FL_PUNCH_HOLE | FALLOC_FL_KEEP_SIZE) successful
fallocate06.c:237: PASS: fallocate(FALLOC_FL_PUNCH_HOLE | FALLOC_FL_KEEP_SIZE) cleared the correct file range
fallocate06.c:168: INFO: Case 2. Fill FS: yes; Use copy on write: no
tst_fill_fs.c:32: INFO: Creating file mntpoint/file0 size 21710183
tst_fill_fs.c:32: INFO: Creating file mntpoint/file1 size 8070086
tst_fill_fs.c:32: INFO: Creating file mntpoint/file2 size 3971177
tst_fill_fs.c:32: INFO: Creating file mntpoint/file3 size 36915315
tst_fill_fs.c:32: INFO: Creating file mntpoint/file4 size 70310993
tst_fill_fs.c:32: INFO: Creating file mntpoint/file5 size 4807935
tst_fill_fs.c:32: INFO: Creating file mntpoint/file6 size 90739786
tst_fill_fs.c:32: INFO: Creating file mntpoint/file7 size 76896492
tst_fill_fs.c:32: INFO: Creating file mntpoint/file8 size 72228649
tst_fill_fs.c:32: INFO: Creating file mntpoint/file9 size 36207821
tst_fill_fs.c:32: INFO: Creating file mntpoint/file10 size 81483962
tst_fill_fs.c:59: INFO: write(): ENOSPC (28)
fallocate06.c:157: PASS: write() successful
fallocate06.c:201: PASS: Misaligned allocation works as expected
fallocate06.c:146: FAIL: fallocate(FALLOC_FL_PUNCH_HOLE | FALLOC_FL_KEEP_SIZE) failed unexpectedly: ENOSPC (2

This issue can be found from X to F
X - https://pastebin.ubuntu.com/p/9FfVrZkQN8/
B - https://pastebin.ubuntu.com/p/Zc9TW4sQKF/
D - https://pastebin.ubuntu.com/p/cryTnnn5wF/
E - https://pastebin.ubuntu.com/p/FXTZpsX7Qb/
F - https://pastebin.ubuntu.com/p/FKPJKCS2zr/

Note that the hint printed in the test:
  HINT: You _MAY_ be missing kernel fixes, see:

 https://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git/commit/?id=e093c4be760e

It something that will get printed after the test, as it's for XFS so it has nothing to do with this issue here.

Po-Hsu Lin (cypressyew)
description: updated
tags: added: bionic disco eoan focal xenial
tags: added: kqa-blocker sru-20200217
Revision history for this message
Ubuntu Kernel Bot (ubuntu-kernel-bot) wrote : Missing required logs.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1866323

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Revision history for this message
Sean Feole (sfeole) wrote :

Just as bug# 1865967 going to unmark this as a blocker since it appears to not be a regression in the kernel

tags: removed: kqa-blocker
Changed in ubuntu-kernel-tests:
status: New → Triaged
Po-Hsu Lin (cypressyew)
tags: added: sru-20200316
tags: added: 4.15 4.4 5.3
Po-Hsu Lin (cypressyew)
tags: added: 5.4 sru-20200629
Revision history for this message
Po-Hsu Lin (cypressyew) wrote :
tags: added: sru-20200921
tags: added: aws
Revision history for this message
Kelsey Skunberg (kelsey-skunberg) wrote :

Spotted on Focal/azure : 5.4.0-1029.29 : amd64

tags: added: azure
Revision history for this message
Kelsey Skunberg (kelsey-skunberg) wrote :

Failed on Bionic/oracle : 5.4.0-1026.26~18.04.1 : amd64

tags: added: oracle
Revision history for this message
Po-Hsu Lin (cypressyew) wrote :

Still visible in Xenial 4.4.0-1118.132 AWS c5.metal

tags: added: sru-20201109
Revision history for this message
Po-Hsu Lin (cypressyew) wrote :

Fix landed in Focal 5.4, didn't see this issue on 5.4.0-1030.32~18.04.1 - oracle

Po-Hsu Lin (cypressyew)
Changed in linux (Ubuntu Focal):
status: New → Fix Released
Revision history for this message
Po-Hsu Lin (cypressyew) wrote :

Still affecting oem-5.6 5.6.0-1035.37

tags: added: 5.6
Po-Hsu Lin (cypressyew)
Changed in linux-oem-5.6 (Ubuntu Focal):
status: New → Confirmed
Changed in linux-oem-5.6 (Ubuntu):
status: New → Invalid
tags: added: sru-20210104
tags: added: fips sru-20210125
Revision history for this message
Kleber Sacilotto de Souza (kleber-souza) wrote :

Failed on xenial/linux-oracle: 4.15.0-1069.77~16.04.1 for sru-20210315

tags: added: sru-20210315
tags: added: aws-hwe sru-20210412
tags: added: oem oem-5.6
Revision history for this message
Krzysztof Kozlowski (krzk) wrote :

Found on bionic/azure-4.15 4.15.0-1120.133

tags: added: sru-20210621
Revision history for this message
Krzysztof Kozlowski (krzk) wrote :

fallocate06 issues still found on bionic/azure-4.15: 4.15.0-1119-azure and 4.15.0-1120.133

Revision history for this message
Krzysztof Kozlowski (krzk) wrote :

Fix would require backport of commit 6d4572a9d71d ("btrfs: allow btrfs_truncate_block() to fallback to nocow for data space reservation"). The v5.4 got its own backport but it does not apply into v4.15.

Revision history for this message
Guilherme G. Piccoli (gpiccoli) wrote :

Observed in B/aws (kernel 4.15), cycle sru-20210621.

Revision history for this message
Guilherme G. Piccoli (gpiccoli) wrote :

Observed in B/oracle (kernel 4.15), cycle sru-20210621.

Revision history for this message
Guilherme G. Piccoli (gpiccoli) wrote :

Observed in B/aws-fips (kernel 4.15), cycle sru-20210621.

tags: added: hinted
Revision history for this message
Krzysztof Kozlowski (krzk) wrote :

Found on xenial/linux-aws/4.4.0-1132.146

tags: added: sru-20210816
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux (Ubuntu Bionic):
status: New → Confirmed
Changed in linux-oem-5.6 (Ubuntu Bionic):
status: New → Confirmed
Revision history for this message
Luke Nowakowski-Krijger (lukenow) wrote :

Found on bionic/gcp-4.15 on 4.15.0-1109.123

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers