kdeconnect-app broken on Focal

Bug #1905341 reported by Robie Basak
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
kdeconnect (Ubuntu)
Undecided
Unassigned
Focal
High
Rik Mills

Bug Description

On a default Ubuntu (not Kubuntu) desktop install, kdeconnect-app does not work at all. When running it from a terminal, it outputs:

QQmlApplicationEngine failed to load component
qrc:/qml/main.qml:93 Cannot assign object of type "DevicesModel" to property of type "QAbstractItemModel*" as the former is neither the same as the latter nor a sub-class of it.

And then hangs.

This is fixed in upstream release v1.4.1, specifically upstream commit 58a400a.

Groovy and Hirsute are not affected.

Robie Basak (racb)
Changed in kdeconnect (Ubuntu Focal):
status: New → Triaged
importance: Undecided → High
Changed in kdeconnect (Ubuntu):
status: New → Fix Released
Revision history for this message
Rik Mills (rikmills) wrote :

Thanks for reporting. This has been on my todo list for a little while, so good to have this to track things.

Rik Mills (rikmills)
Changed in kdeconnect (Ubuntu Focal):
assignee: nobody → Rik Mills (rikmills)
status: Triaged → In Progress
Revision history for this message
Robie Basak (racb) wrote :

Thanks Rik. I was going to prepare an SRU myself, but although locally cherry-picking this patch fixes this particular issue, after also working around bug 1888215, I still couldn't get it all working, so I left it for now. I got the impression some of the plugin panels were silently failing.

Revision history for this message
James (jsparker512) wrote :

Any update to this bug? Thanks

Rik Mills (rikmills)
Changed in kdeconnect (Ubuntu Focal):
status: In Progress → Incomplete
Revision history for this message
Lasakro (lasakro) wrote :

I'm running Ubuntu Studio 20.04 and after running kdeconnect-app from terminal I'm also getting the atk-bridge failed to load:

kdeconnect-app
qt5ct: using qt5ct plugin
Gtk-Message: 13:04:50.619: Failed to load module "atk-bridge"
QQmlApplicationEngine failed to load component
qrc:/qml/main.qml:93 Cannot assign object of type "DevicesModel" to property of type "QAbstractItemModel*" as the former is neither the same as the latter nor a sub-class of it.

Revision history for this message
Lasakro (lasakro) wrote :

apt install libatk-adaptor

Got rid of my atk-bridge failed to load.

qt5ct: using qt5ct plugin
QQmlApplicationEngine failed to load component
qrc:/qml/main.qml:93 Cannot assign object of type "DevicesModel" to property of type "QAbstractItemModel*" as the former is neither the same as the latter nor a sub-class of it.

Still remains.

Revision history for this message
Francivan Bezerra (fba-rio) wrote :

Confirmed in Xubuntu 20.04 as well.

Is this bug intended to be fixed in Focal or will we have to wait for the next LTS release?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers