KDE Connect constantly loses pairing, can't share/receive files

Bug #1895469 reported by Ascaris
This bug affects 2 people
Affects Status Importance Assigned to Milestone
kdeconnect (Ubuntu)
Won't Fix

Bug Description

When I pair KDE Connect with another PC running KDE connect, the pairing works as expected, and some of the functions work. Most of them are not useful to me, connecting PC to PC rather than PC to phone, so I only really use the shared clipboard and file sharing, and ping for testing. Ping and shared clipboard work, but files cannot be sent (using "share") in either direction. The "receiving file" dialog appears on the receiving PC, but it never progresses. It does not work from the KDE Connect tray menu or from the command line either.

The pairing is not persistent either. When the PCs are paired, pressing the "refresh" button in the KDE Connect dialog causes the pairing to be lost on both PCs, and so does rebooting.

This happens any time at least one of the paired PCs is running Kubuntu 20.04 or another Ubuntu 20.04 derivative, like KDE Neon (20.04 rebase), or even Mint Cinnamon 20 with KDE Connect Indicator.

It doesn't matter what distro is on the other end, or which of my PCs is the one running Kubuntu 20.04 (or if they both are). Fedora 32, Kubuntu 18.04, Neon (18.04 base), OpenSUSE Tumbleweed, and Manjaro all work with one another as expected in all the combinations I tried. I tried it with the PCs connected wirelessly, by ethernet, or one of each, and it was all the same.

I even tried booting to a live session of Kubuntu 20.04 and pairing that with a PC running a non-Ubuntu 20.04 release, and it did the same. The issue is apparently not in any of the changes I made.

I had made a bunch of modifications to my Kubuntu 20.04 installation previously, like grabbing the Qt and frameworks version from the Groovy repo, so I just today reinstalled Kubuntu to use the ubuntu-bug tool with the default packages showing.

I tried the thing in the KDE Connect troubleshooting guide to open the necessary ports in UFW, and it didn't help, so I tried just removing UFW (with the Kubuntu installation I had before this fresh one) as a test, and it made no difference.

Kernel versions have no effect on any of this. I've tried 5.4 to 5.8, Ubuntu and mainline, as well as those from the other distros I tried, and they made no difference.

I reported this issue in KDE's bug tracker also, but it seems that the bug originates upstream from Neon, in Ubuntu. The last iteration of Neon that was based on 18.04 had all the same KDE package versions as the 20.04 version that replaced it, yet Neon (18.04)'s combination of KDE Connect 1.4.0, Qt 5.14.2, frameworks 5.72(?), etc., worked fine, while the 20.04 version of Neon worked the same as Kubuntu 20.04, which is to say, badly.

The report from ubuntu-bug should be attached.

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: kdeconnect 1.4-0ubuntu5
ProcVersionSignature: Ubuntu 5.4.0-47.51-generic 5.4.55
Uname: Linux 5.4.0-47-generic x86_64
NonfreeKernelModules: nvidia_modeset nvidia
ApportVersion: 2.20.11-0ubuntu27.8
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: KDE
Date: Sun Sep 13 09:54:02 2020
InstallationDate: Installed on 2020-09-13 (0 days ago)
InstallationMedia: Kubuntu 20.04.1 LTS "Focal Fossa" - Release amd64 (20200731)
SourcePackage: kdeconnect
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Ascaris (ascaris) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in kdeconnect (Ubuntu):
status: New → Confirmed
Revision history for this message
Omar Dzinic (odzinic) wrote :

I am experiencing this same issue when connecting between Kubuntu 20.04 and Manjaro KDE. Both devices are able to send and receive files to my phone but not between each other. Clipboard sharing and pinging worked fine but file transferring would appear as (Failed) on the sending machine and would me a continuously "loading" dialog on the receiving machine. Pairing also gets lost after a suspend/network disconnect from either device.

Ascaris (ascaris)
tags: added: groovy
Revision history for this message
Ascaris (ascaris) wrote :

This bug also affects the Kubuntu Groovy Gorilla beta right now, with so I added the tag 'groovy'. The current version of Kubuntu Groovy uses KDE Connect version 20.08.1-0ubuntu1.

Revision history for this message
Thomas Ward (teward) wrote :

Per an email on <email address hidden>, this affects the Kubuntu 20.10 beta as well. [1]

I've adjusted the tasks on here as well.

[1]: https://lists.ubuntu.com/archives/ubuntu-quality/2020-October/007254.html

Changed in kdeconnect (Ubuntu Focal):
status: New → Confirmed
Revision history for this message
Ascaris (ascaris) wrote :

As I wrote in the parallel bug I filed in KDE's tracker (https://bugs.kde.org/show_bug.cgi?id=424606#c2), I've found what may be the root of the bug. Initially I did not report this here because (after finding that KDE Neon, which previously shared the same bug, was now working with KDE Connect) when I tried it in Kubuntu 20.04, it didn't work as it had in KDE Neon. Just now, though, I tried Kubuntu 20.04 again, and it worked as it should for the first time since the upgrade to 20.04 from 18.04.

The upgrade to Plasma 5.20 on Neon a few weeks ago brought a new detail in the log that was not there previously. It mentioned an SSL issue with certificate validation with KDE Connect when I attempted a file transfer, so I did some poking around and found that the version of libssl and openssl in Ubuntu is not the one in any of the distros whose KDE Plasma works well (Fedora 32, Manjaro, OpenSUSE Tumbleweed). The one in Ubuntu was/is 1.1.1f, while the version in each of the distros above was 1.1.1g or 1.1.1h (don't really remember which, only that it was newer than Ubuntu). I did a package search and found that Debian Sid had 1.1.1h in .deb form, and I was able to install that in Kubuntu and Neon without a hitch (openssl and libssl, 1.1.1h, as well as the 32-bit version of libssl 1.1.1h).

Neon began to work after that, while back then Kubuntu 20.04 changed its failure behavior a little, but still was not working. For some reason, it's working now in Kubuntu 20.04 too.

Revision history for this message
Brian Murray (brian-murray) wrote :

The Groovy Gorilla has reached end of life, so this bug will not be fixed for that release

Changed in kdeconnect (Ubuntu Groovy):
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.