GNOME 40: GTK3 apps crash with: Settings schema 'org.gnome.settings-daemon.plugins.xsettings' does not contain a key named 'antialiasing'

Bug #1922464 reported by Michael Gratton
18
This bug affects 2 people
Affects Status Importance Assigned to Milestone
gtk+3.0 (Ubuntu)
Fix Released
Low
Unassigned
Focal
Triaged
High
Unassigned

Bug Description

Applications running with GTK < 3.24.26 crash when running under GNOME 40. This was fixed in GTK 3.24.26 by MR https://gitlab.gnome.org/GNOME/gtk/-/merge_requests/3219

Please package either current GTK 3 (3.24.28) or include the given MR in the current build.

Thanks!

Example crash:

```
Starting program: /home/mjog/Projects/GNOME/geary/+build/test/test-client
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/x86_64-linux-gnu/libthread_db.so.1".
[New Thread 0x7fffeb8a7640 (LWP 58239)]
[New Thread 0x7fffeb086640 (LWP 58240)]
[New Thread 0x7fffea839640 (LWP 58241)]

(test-client:58235): GLib-GIO-ERROR **: 10:42:55.448: Settings schema 'org.gnome.settings-daemon.plugins.xsettings' does not contain a key named 'antialiasing'

Thread 1 "test-client" received signal SIGTRAP, Trace/breakpoint trap.
0x00007ffff74a5ea7 in g_log_structured_array () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
(gdb) bt
#0 0x00007ffff74a5ea7 in g_log_structured_array ()
    at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#1 0x00007ffff74a62b9 in g_log_default_handler () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#2 0x00007ffff74a64fe in g_logv () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#3 0x00007ffff74a67b3 in g_log () at /lib/x86_64-linux-gnu/libglib-2.0.so.0
#4 0x00007ffff735d9d1 in () at /lib/x86_64-linux-gnu/libgio-2.0.so.0
#5 0x00007ffff735e030 in () at /lib/x86_64-linux-gnu/libgio-2.0.so.0
#6 0x00007ffff73625d1 in g_settings_get_enum () at /lib/x86_64-linux-gnu/libgio-2.0.so.0
#7 0x00007ffff10d90ea in update_xft_settings (screen=0x555555a8d810)
    at wayland/../../../../../gdk/wayland/gdkscreen-wayland.c:404
#8 0x00007ffff10d3c7d in init_settings (screen=0x555555a8d810)
    at wayland/../../../../../gdk/wayland/gdkscreen-wayland.c:828
#9 _gdk_wayland_screen_new (display=0x555555a8a0e0)
    at wayland/../../../../../gdk/wayland/gdkscreen-wayland.c:1320
#10 _gdk_wayland_display_open (display_name=<optimised out>)
    at wayland/../../../../../gdk/wayland/gdkdisplay-wayland.c:617
#11 0x00007ffff1072635 in gdk_display_manager_open_display
    (manager=<optimised out>, name=0x0) at ../../../../gdk/gdkdisplaymanager.c:462
#12 0x00007ffff6d011fb in gtk_init_check (argc=<optimised out>, argv=<optimised out>)
    at ../../../../gtk/gtkmain.c:1110
#13 gtk_init_check (argc=<optimised out>, argv=<optimised out>)
    at ../../../../gtk/gtkmain.c:1102
#14 0x00007ffff6d0122d in gtk_init (argc=<optimised out>, argv=<optimised out>)
    at ../../../../gtk/gtkmain.c:1167
#15 0x00005555555b4854 in _vala_main (args=0x7fffffffdda8, args_length1=1)
    at ../test/test-client.vala:32
#16 0x00005555555b5213 in main (argc=1, argv=0x7fffffffdda8) at ../test/test-client.vala:9
```

ProblemType: Bug
DistroRelease: Ubuntu 21.04
Package: libgtk-3-0 3.24.25-1ubuntu3
ProcVersionSignature: Ubuntu 5.11.0-13.14-generic 5.11.7
Uname: Linux 5.11.0-13-generic x86_64
ApportVersion: 2.20.11-0ubuntu61
Architecture: amd64
CasperMD5CheckResult: unknown
CurrentDesktop: GNOME
Date: Sun Apr 4 11:11:05 2021
InstallationDate: Installed on 2018-08-13 (964 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
SourcePackage: gtk+3.0
UpgradeStatus: Upgraded to hirsute on 2021-04-03 (0 days ago)

Revision history for this message
Michael Gratton (mjog) wrote :
description: updated
Revision history for this message
Michael Gratton (mjog) wrote :

I just rebuilt the current packaged version of GTK 3 with the patch from the MR and can confirm it fixes the crash.

Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, Ubuntu doesn't have GNOME 40 though so it seems rather a bug in the ppa your are using, shouldn't you make the request there to fix the issue they are creating?

Changed in gtk+3.0 (Ubuntu):
status: New → Incomplete
importance: Undecided → Low
Revision history for this message
Michael Gratton (mjog) wrote :

As you're no doubt aware, using a PPA is at the moment the only way to use GNOME 40 without compiling it from scratch or switching to another distro. However the PPA does not ship GTK3, only GTK4 - hence this is a bug in an Ubuntu package.

Since this bug occurs in Ubuntu's packaged version of GTK3, and has already been fixed upstream in an API & ABI compatible branch, surely it is reasonable to request the fix be packaged here?

Revision history for this message
Sebastien Bacher (seb128) wrote :

it's clearly a bug in the ppa if they ship updates that trigger a bug in GTK without either shipping that fix or having worked with the distro to get the issue fixed in the main package.

We are post beta and the archive is frozen for release at this point, adding changes always carry a risk so we usually focus on things impacting the incoming release which isn't the case here

I will see if we can still try to get that one in though...

Revision history for this message
Michael Gratton (mjog) wrote :

Much appreciated, thanks!

Changed in gtk+3.0 (Ubuntu):
status: Incomplete → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gtk+3.0 - 3.24.25-1ubuntu4

---------------
gtk+3.0 (3.24.25-1ubuntu4) hirsute; urgency=medium

  * debian/patches/git_wayland_fonts.patch:
    - cherry pick a fix for GTK applications hitting errors under wayland
      on GNOME40, it isn't in Ubuntu yet but it should make testing the
      new version easier and also updates packages are provided in ppa
      already for testing so it should avoid surprises for those users
      (lp: #1922464)

 -- Sebastien Bacher <email address hidden> Thu, 08 Apr 2021 11:17:35 +0200

Changed in gtk+3.0 (Ubuntu):
status: Fix Committed → Fix Released
Mattia Rizzolo (mapreri)
no longer affects: gtk+3.0 (Ubuntu Hirsute)
Changed in gtk+3.0 (Ubuntu Focal):
status: New → Confirmed
Revision history for this message
Mattia Rizzolo (mapreri) wrote :

@seb128: but is the patch that you uploaded with 3.24.25-1ubuntu4 (i.e. this http://launchpadlibrarian.net/532459482/gtk+3.0_3.24.25-1ubuntu3_3.24.25-1ubuntu4.diff.gz ) really that inappropriate for a SRU on top of the current version in focal-updates?

Revision history for this message
Sebastien Bacher (seb128) wrote :

What would be the point, it's to handle changes from GNOME 40 which only landed in impish? If someone want to skip several GNOME cycles ahead they probably would have an easy job updating to a new serie than trying to get the updates in focal

Changed in gtk+3.0 (Ubuntu Focal):
importance: Undecided → Wishlist
status: Confirmed → Incomplete
Revision history for this message
Ted Gould (ted) wrote :

The problem is that snaps that are built on focal don't work on GNOME 40. So in my case I'm concerned about Inkscape, but most Electron apps will fall into the same boat.

Revision history for this message
Sebastien Bacher (seb128) wrote :

snaps build is a valid reason indeed, thank you Ted!

Changed in gtk+3.0 (Ubuntu Focal):
status: Incomplete → Triaged
importance: Wishlist → High
Revision history for this message
Mattia Rizzolo (mapreri) wrote :

@seb128: would you take care of uploading that patch, or should somebody else do it?

I'm not a core-dev, so I would still need a sponsor for the actual upload (though I have them already), so if you have the tuits it might just be quicker/easier if you could do it ^^

Revision history for this message
Sebastien Bacher (seb128) wrote :

Sorry for the delay, I finally got back to that request but it's not as simple as backporting the one patch, the codebase changed between .20 and .25 and other changes are needed. Would anyone interest to work on a proper backport and testing, I personally doesn't really have the free slots for doing that at the moment.

Revision history for this message
Sebastien Bacher (seb128) wrote :

I'm not able to spend more time on that one at the moment but still having it in a my backlog of things to check. Could someone give a testcase showing the issue?

The original issue has to do with gsettings key changes but confined snaps aren't using host schemas but a copy of their own or the ones provided by the sdk so the schemas shouldn't be different even if they are started on a newer serie and GNOME?

We also didn't get report of such issues on our snaps today, they work fine on impish, what is inkscape doing differently?

Revision history for this message
Ken VanDine (ken-vandine) wrote :

Snaps which use the gnome-38 snapcraft extension wouldn't be affected, but snaps that use gnome-3-34 may.

Revision history for this message
Ted Gould (ted) wrote :

In our case we're not using either of the gnome snaps but just the distro packages. We trust @seb128 more than those crazy snap people ;-)

I imagine that the fix for Inkscape is to switch to core22, which will grab the newer GTK3. The next release for Inkscape is roughly aligned with when 22.04 is likely to ship. My intention is to start looking at switching to see if I can get it done before that release.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers