Experimental setting to enable fractional Hi-DPI scaling offers no option larger than 200% on 15.6 inch, 3840 x 2160 pixel display (Dell XPS 15 9575)

Bug #1795483 reported by Mario Vukelic
36
This bug affects 7 people
Affects Status Importance Assigned to Milestone
gnome-control-center (Ubuntu)
Fix Released
Medium
Marco Trevisan (Treviño)
Focal
In Progress
Medium
Marco Trevisan (Treviño)
Hirsute
Fix Released
Medium
Marco Trevisan (Treviño)

Bug Description

[ Impact ]

On my laptop's 15.6 inch, 3840 x 2160 pixel (282 PPI) display, the available scaling options in the gnome-control-center display settings are limited to 100, 200, 300, and 400%. This is insufficient as 200% is too small and 300% is too large. The missing fractional scaling options are dealt with in bug #1687246. However, the currently available experimental feature to enable fractional scaling (provided in the bug description of #1687246) does not solve the problem on my machine:

gsettings set org.gnome.mutter experimental-features "['scale-monitor-framebuffer']"

After applying and rebooting, the options offered change to 100, 125, 150, 175, and 200%. Note that there is no value larger than 200% which is too small on this display at least for me.

In addition, the 25% steps enabled by the experimental option seem too far apart. With 200%, I am using a font scaling value in Gnome Tweaks of 1.20, so I suppose a fractional scaling of approx 240% would be equivalent.

In bug #1687246, Daniel van Vugt (vanvugt) advised to open a new bug for gnome-control-center and added that "gnome-control-center seems to limit the scale to 200% on some machines, 300% on others. And I think I have seen 400% offered in some cases. I don't know why, but the inconsistency is definitely annoying."

[ Test case ]

In a setup with a display with HighDPi resolution (higher than 2880x1800)
 - Open gnome-control-center display panel
 - Scaling should show 5 level buttons to select
 - Selecting higher values will show all the selectable values closer to the chosen one
 - Any value could be used from 100% up to 400% (maximum varies on resolution)

[ Regression potential ]

Control center won't show any scaling value, or scaling value may be wrong.

---

ProblemType: BugDistroRelease: Ubuntu 18.10
Package: gnome-control-center 1:3.30.0-0ubuntu1
Uname: Linux 4.19.0-041900rc5-generic x86_64
ApportVersion: 2.20.10-0ubuntu11
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Mon Oct 1 19:29:11 2018
InstallationDate: Installed on 2018-09-13 (17 days ago)
InstallationMedia: Ubuntu 18.10 "Cosmic Cuttlefish" - Alpha amd64 (20180912)SourcePackage: gnome-control-center
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Mario Vukelic (kreuzsakra) wrote :
description: updated
description: updated
description: updated
description: updated
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-control-center (Ubuntu):
status: New → Confirmed
tags: added: hidpi
Revision history for this message
Mario Vukelic (kreuzsakra) wrote :

I see the same behavior on a display with the same dimensions on a different laptop:
Asus ZenBook Flip 15 UX561UD
15.6 inch 16:9, 3840 x 2160 pixel, 282 PPI

On both the Dell and the Asus:
Without the experimental setting, options offered are 100, 200 (too small), 300 (too large), 400%.
With the experimental setting, options are 100, 125, 150, 175, 200 (still too small)

description: updated
description: updated
Revision history for this message
Mario Vukelic (kreuzsakra) wrote :

Still reproducible with Ubuntu 20.04 beta with gnome-control-center 1:3.36.1-1ubuntu4 and gnome-3.36.1, where the option to enable fractional scaling is exposed in the GUI

Changed in gnome-control-center (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Revision history for this message
Marco Trevisan (Treviño) (3v1n0) wrote :

While I'm fixing this upstream to show all the values and we're SRUing it to ubuntu stable versions, I've made a ppa for hisute (21.04) and focal (20.04) so you can test it (packages are building right now, so may take some moments):

https://launchpad.net/~ci-train-ppa-service/+archive/ubuntu/4565/

Note: since it's preferable not to change design in a SRU, the values will be still limited to 5 and will shoe exactly like before, but now selecting higher values, more scaling values will be visible and selectable.

Changed in gnome-control-center (Ubuntu Hirsute):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → Medium
status: New → Triaged
Changed in gnome-control-center (Ubuntu Focal):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
importance: Undecided → Medium
status: New → Triaged
description: updated
Changed in gnome-control-center (Ubuntu):
status: Triaged → In Progress
status: In Progress → Fix Committed
Changed in gnome-control-center (Ubuntu Hirsute):
status: Triaged → In Progress
Changed in gnome-control-center (Ubuntu Focal):
status: Triaged → In Progress
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.38.6-0ubuntu2

---------------
gnome-control-center (1:3.38.6-0ubuntu2) impish; urgency=medium

  [ Gunnar Hjalmarsson ]
  * Added note to the header of patch 0030

  [ Marco Trevisan (Treviño) ]
  * debian/patches: Ensure we list all the usable scaling values.
    List all the usable scaling values without limiting us to the first 5
    available, but try instead to show the values closer to the one selected.
    (LP: #1795483)
  * debian/patches: Do not leak a variant builder on single monitor setup

 -- Marco Trevisan (Treviño) <email address hidden> Fri, 28 May 2021 20:48:42 +0200

Changed in gnome-control-center (Ubuntu):
status: Fix Committed → Fix Released
Revision history for this message
Mario Vukelic (kreuzsakra) wrote :

Thank you, I tested the new values and it all works as expected for me.
However, not sure what it is but the 225% value seems to change the rendering in an unpleasant way. Not sure if it's only not being used to it, but for the time being it feels more "comfortable" reverting to 200% and upping the font scaling a bit, as I did before.

Revision history for this message
Robie Basak (racb) wrote : Please test proposed package

Hello Mario, or anyone else affected,

Accepted gnome-control-center into hirsute-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/gnome-control-center/1:3.38.5-1ubuntu2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-hirsute to verification-done-hirsute. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-hirsute. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in gnome-control-center (Ubuntu Hirsute):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-hirsute
Revision history for this message
Brian Murray (brian-murray) wrote :

Is there anybody who can verify this bug fix for Hirsute?

tags: added: verification-done-hirsute
removed: verification-needed-hirsute
Revision history for this message
Michael Zanetti (mzanetti) wrote (last edit ):

I'm using this patch on hirsute since the day Marco created it and it's working fine for me with the package from the ci-train manually installed. It is working just fine on the Dell XPS 15 9575, where I'm using 250% scaling.

For the verification now, I've removed the package, enabled the proposed repo and installed gnome-control-center from there. Then I changed scaling a bit down and back up to 250.

Everything working with that too.

tags: added: verification-needed-hirsute
removed: verification-done-hirsute
tags: added: verification-done-hirsute
removed: verification-needed-hirsute
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package gnome-control-center - 1:3.38.5-1ubuntu2

---------------
gnome-control-center (1:3.38.5-1ubuntu2) hirsute; urgency=medium

  [ Marco Trevisan (Treviño) ]
  * debian/control, debian/gbp.conf:
    Update references to ubuntu/hirsute branch
  * 0033-display-Ensure-we-list-available-scaling-values-keeping-t.patch:
    Ensure we list all the usable scaling values (LP: #1795483)

  [ Hui Wang ]
  * d/p/git-Fix-volume-adjustment-failure-on-volume-slider.patch:
    Can't adjust the output volume via volume-slider after changing
    the current output-device. (LP: #1938747)

 -- Gunnar Hjalmarsson <email address hidden> Tue, 03 Aug 2021 15:23:41 +0200

Changed in gnome-control-center (Ubuntu Hirsute):
status: Fix Committed → Fix Released
Revision history for this message
Brian Murray (brian-murray) wrote : Update Released

The verification of the Stable Release Update for gnome-control-center has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers