Location services work with location services off, 20.04

Bug #1890924 reported by NoBugs!
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
geoclue-2.0 (Ubuntu)
Fix Released
High
Unassigned
Focal
Triaged
High
Sebastien Bacher
Groovy
Won't Fix
Undecided
Unassigned

Bug Description

* Impact

Disabling the location service in settings isn't reflection on traditional deb applications

* Test case

- Log in an Ubuntu desktop session
- install geoclue-2-demo
- go to gnome-control-center, privacy, location and ensure the service is disabled
- $ /usr/libexec/geoclue-2.0/demos/where-am-i

the script should return a permission error and not a location

* Regression potential

[racb] Users who are currently relying on a working location service despite having a setting disabling it will find that the location service will stop working because the setting will start to be honoured.

The change is in the client library, try a few applications, deb and snap or flatpak and make sure the status is correct respected

-----------------------------

Not sure if this is the right package, but in the privacy -> location settings, in 18.04 I had to have my application be approved by user to access location with Geoclue. Now it seems this is working without the location services "enabled"??

My application is repeater-START: https://sourceforge.net/projects/repeater-start/

Steps to see issue:
1) install Repeater-START and click the locate me button circle to the left. It goes to your rough location on map.

2) Go to settings, privacy, location, note that location is turned off!?

ProblemType: Bug
DistroRelease: Ubuntu 20.04
Package: gnome-settings-daemon 3.36.1-0ubuntu1
ProcVersionSignature: Ubuntu 5.4.0-40.44-generic 5.4.44
Uname: Linux 5.4.0-40-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.20.11-0ubuntu27.3
Architecture: amd64
CasperMD5CheckResult: skip
Date: Sat Aug 8 19:38:12 2020
InstallationDate: Installed on 2017-07-29 (1106 days ago)
InstallationMedia: Ubuntu 17.04 "Zesty Zapus" - Release amd64 (20170412)
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-settings-daemon
UpgradeStatus: Upgraded to focal on 2020-06-22 (47 days ago)

Revision history for this message
NoBugs! (luke32j) wrote :
Revision history for this message
Sebastien Bacher (seb128) wrote :

Thank you for your bug report, that seems similar to what is discussed in https://gitlab.gnome.org/GNOME/gnome-control-center/-/issues/805 and a geoclue issue

affects: gnome-settings-daemon (Ubuntu) → geoclue-2.0 (Ubuntu)
Changed in geoclue-2.0 (Ubuntu):
importance: Undecided → High
Revision history for this message
Danielle Foré (danrabbit) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in geoclue-2.0 (Ubuntu):
status: New → Confirmed
Revision history for this message
Danielle Foré (danrabbit) wrote :

Sorry, the version number is 2.5.7. Struggling to read a bit here. We're also tracking this issue downstream here: https://github.com/elementary/pantheon-agent-geoclue2/issues/41

Revision history for this message
Olivier Tilloy (osomon) wrote :

I'm marking this fixed as geoclue 2.5.7 is already in the development series (hirsute).
I have added the rls-gg-incoming and rls-hh-incoming tags to mark it as a candidate for a SRU to groovy (20.10) and focal (20.04). This will be reviewed at the next desktop team meeting.

tags: added: rls-ff-incoming rls-gg-incoming
Changed in geoclue-2.0 (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
Danielle Foré (danrabbit) wrote :

Thank you very much for adding the SRU to the desktop team's agenda!

Revision history for this message
Sebastien Bacher (seb128) wrote :

SRU uploaded to the focal queue now

description: updated
Revision history for this message
Robie Basak (racb) wrote : Please test proposed package

Hello NoBugs!, or anyone else affected,

Accepted geoclue-2.0 into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/geoclue-2.0/2.5.6-0ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

description: updated
Changed in geoclue-2.0 (Ubuntu Focal):
status: New → Fix Committed
tags: added: verification-needed verification-needed-focal
Changed in geoclue-2.0 (Ubuntu Groovy):
status: New → Triaged
Revision history for this message
NoBugs! (luke32j) wrote :

I upgraded my 20.04 with the proposed-updates, restarted, and I got an alert that I needed to accept location permissions upon hitting the lower left locate button on my app, initially. I open the privacy settings in location and my app is not listed??

However, location now works, at least every other time. I wonder if anyone else can run a similar test?
I see no applications have asked for location access, in privacy settings.

Changed in geoclue-2.0 (Ubuntu Focal):
assignee: nobody → Sebastien Bacher (seb128)
Changed in geoclue-2.0 (Ubuntu Groovy):
status: Triaged → Won't Fix
Revision history for this message
Danielle Foré (danrabbit) wrote :

I installed GeoClue 2.5.6-0ubuntu1.1 from proposed including the dev and demo packages. I cannot confirm that this fixes the issue as described in the test case above using the where-am-i demo and Pantheon's polkit agent

I then tried with GNOME Maps both from deb packaging and from Flatpak and both were able to access my location while location services were disabled

I also tried using the agent demo from geoclue-2-demo, and both where-am-i and GNOME maps were able to access location without permission while location services were marked disabled

tags: added: verification-failed-focal
removed: verification-needed-focal
Revision history for this message
Danielle Foré (danrabbit) wrote :

I can also confirm the comment from NoBugs! (luke32j) that no apps appear to have requested location access in privacy settings even though they have location access

Revision history for this message
Sebastien Bacher (seb128) wrote :

Alright, thanks for the testing. Sounds like the patch supposed to fix it doesn't work as intended there. I don't have more cycles to spent on investigating the issue more at the moment so I'm going to set it back to triaged and unassign myself, with some luck someone can help sorting it out.

Changed in geoclue-2.0 (Ubuntu Focal):
status: Fix Committed → Triaged
assignee: Sebastien Bacher (seb128) → nobody
importance: Undecided → High
Revision history for this message
Iain Lane (laney) wrote :

(sorry, just noticed I didn't assign this last week when I was supposed to)

Changed in geoclue-2.0 (Ubuntu Focal):
assignee: nobody → Sebastien Bacher (seb128)
Revision history for this message
Łukasz Zemczak (sil2100) wrote : Proposed package removed from archive

The version of geoclue-2.0 in the proposed pocket of Focal that was purported to fix this bug report has been removed because one or more bugs that were to be fixed by the upload have failed verification and been in this state for more than 10 days.

tags: removed: rls-ff-incoming rls-gg-incoming
tags: added: dt-205
Changed in geoclue-2.0 (Ubuntu Focal):
assignee: Sebastien Bacher (seb128) → nobody
assignee: nobody → Sebastien Bacher (seb128)
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.