Mutter 3.34.1 broke Night Light, screen color profiles in Wayland sessions

Bug #1847551 reported by Anders Kaseorg on 2019-10-09
104
This bug affects 16 people
Affects Status Importance Assigned to Milestone
Mutter
Fix Released
Unknown
mutter (Ubuntu)
Status tracked in Focal
Eoan
High
Marco Trevisan (Treviño)
Focal
High
Unassigned

Bug Description

[ Impact ]

Upgrading Mutter 3.34.0 to 3.34.1 has broken Night Light and screen color profile switching.
The commit at fault is 104bdde746c9ceccd9e9ab09b22ef228b8f7026e “kms: Predict state changes when processing update” (which was intended to fix LP bug 1847044).

[ Test case ]

- From gnome-control-center display panel, enable the Night Light
- Force it on, and ensure that the display color temperature increases

[ Regression potential ]

Display gamma value might be incorrect

Upstream issue: https://gitlab.gnome.org/GNOME/mutter/issues/851

Related branches

Changed in mutter:
status: Unknown → New
tags: added: eoan regression-release rls-ee-incoming
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mutter (Ubuntu):
status: New → Confirmed
tags: added: fixed-in-3.34.2 fixed-upstream
Changed in mutter (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in mutter:
status: New → Fix Released
tags: removed: rls-ee-incoming
Bickhaus (bickhaus) on 2019-10-15
Changed in mutter (Ubuntu):
status: Triaged → Confirmed
Bickhaus (bickhaus) wrote :

Apologies for changing status from triaged to confirmed. That was not my intention. Next time I get an email about a bug update, I'll wait to get to my pc, rather than checking on mobile.

Jeremy Bicha (jbicha) wrote :

No problem, I changed it back for you. 😃

Changed in mutter (Ubuntu):
status: Confirmed → Triaged

Is there a testing package including the fix that we could test please?

It has been fixed in Fedora and Arch, where is the fix for Ubuntu?

Daniel van Vugt (vanvugt) wrote :

Looks like this bug only affects Wayland sessions. So to avoid it just log into "Ubuntu" instead, to get Xorg.

summary: - Mutter 3.34.1 broke Night Light, screen color profiles
+ Mutter 3.34.1 broke Night Light, screen color profiles in Xorg sessions
summary: - Mutter 3.34.1 broke Night Light, screen color profiles in Xorg sessions
+ Mutter 3.34.1 broke Night Light, screen color profiles in Wayland
+ sessions
Daniel van Vugt (vanvugt) wrote :

Still, since this is the most popular eoan regression I've seen I will propose a fix.

Changed in mutter (Ubuntu):
assignee: nobody → Daniel van Vugt (vanvugt)
status: Triaged → In Progress
description: updated
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.34.1+git20191022-2ubuntu1

---------------
mutter (3.34.1+git20191022-2ubuntu1) focal; urgency=medium

  * Merge with debian. Remaining changes:
    + debian/control:
      - Update VCS flags to point to launchpad
    + debian/gbp.conf: update branch to point to ubuntu/master
    + debian/patches/x11-Add-support-for-fractional-scaling-using-Randr.patch:
      - X11: Add support for fractional scaling using Randr

mutter (3.34.1+git20191022-2) unstable; urgency=medium

  * debian/patches: Update X11 focus before display focus:
    - Fixes an infinite loop causing an hang when showing the "application is
      not responding" dialog (LP: #1845302)

mutter (3.34.1+git20191022-1) unstable; urgency=medium

  * New upstream snapshot release
    + Fix night mode in wayland session (LP: #1847551)
    + Don't emit key-focus-out events on destroyed actors (LP: #1848119)
    + Fix an headers syntax error (LP: #1841709)
    + backends: Update inhibited state for the monitor and respect that state
    + clutter-backend-x11: Don't push keymap events to clutter
    + Fix drag and drop for applications in wayland
    + Avoid X11 roundtrips on underscanning checks

mutter (3.34.1-3) unstable; urgency=medium

  * Bump meson test timeout multiplier from 4 to 6 for armel

 -- Iain Lane <email address hidden> Fri, 25 Oct 2019 18:07:31 +0100

Changed in mutter (Ubuntu):
status: In Progress → Fix Released
Alberto Donato (ack) wrote :

Is the fig going to be backported to Eoan?

Jeremy Bicha (jbicha) wrote :

Yes, there is a new mutter version that needs to be accepted by the Ubuntu Stable Release Team and then it will be built as a proposed update.

Changed in mutter (Ubuntu Eoan):
importance: Undecided → High
status: New → Triaged
status: Triaged → In Progress
Changed in mutter (Ubuntu):
assignee: Daniel van Vugt (vanvugt) → nobody
Changed in mutter (Ubuntu Eoan):
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
MrTux (mrtux) wrote :

A half of month and I'm still waiting for eoan release fix

Unfortunately due to a 3.34.1 git snapshot regression (https://gitlab.gnome.org/GNOME/mutter/issues/896, fixed now) we had to delay this upload, but the upload is in queue for few days now.

Hello Anders, or anyone else affected,

Accepted mutter into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mutter/3.34.1+git20191107-1ubuntu1~19.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in mutter (Ubuntu Eoan):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-eoan
Anurag Soni (anuragsoni-13) wrote :

Hi Brian,

I enabled the eoan-proposed repository and on upgrading mutter + libmutter-5-0 I am able to use Night light and change color profiles again.

Thanks,
Anurag

darkrain42 (darkrain42) wrote :

I can also confirm this is fixed after upgrading mutter / libmutter-5-0 to 3.34.1+git20191107-1ubuntu1~19.10.1.

Thank you!

tags: added: verification-done-eoan
removed: verification-needed-eoan
MrTux (mrtux) wrote :

I confirmed problem fixed after upgrade to mutter / libmutter-5-0 3.34.1+git20191107-1ubuntu1~19.10.1.

Paul W (pbryanw) wrote :

Hi, I'm new to Ubuntu bug testing, so hopefully I've done this correctly.

I can confirm the problem has been fixed, after upgrading to mutter / libmutter-5-0 3.34.1+git20191107-1ubuntu1~19.10.1. (via aptitude). Thank you.

Owen Williams (ywwg) wrote :

Can also confirm the issue is fixed with the -proposed package

tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.