cannot click on others opened applications while the "application not responding" dialog is opened

Bug #1845302 reported by betteropensource on 2019-09-25
52
This bug affects 9 people
Affects Status Importance Assigned to Milestone
GNOME Shell
Fix Released
Unknown
gnome-shell (Ubuntu)
Undecided
Unassigned
Eoan
Undecided
Unassigned
mutter (Ubuntu)
Undecided
Marco Trevisan (Treviño)
Eoan
Undecided
Marco Trevisan (Treviño)

Bug Description

[ Impact ]

The "application is not responding" can make the shell hang under X11

[ Test case ]

- Start an application (i.e. firefox)
- Stop the process
  killall -STOP firefox
- Close the window via the shell (using launcher right-click or window
  decoration button - if any - or using the activity view)
- After some moments and interactions with the window the gnome shell
  dialog to kill the window should pop-up
- The shell should be still responsive and you can get the program to
  run again (killall -CONT firefox)

[ Regression potential ]

Focus might be wrongly set to the applications or actors and instead be owned by the shell

This is uploaded under the gnome MRE, so the fix doesn't need to be explicitly verified. https://wiki.ubuntu.com/StableReleaseUpdates/GNOME

summary: - cannot click on others windows when the "application not responding"
- dialog is opened in other application
+ cannot click on others opened applications while the "application not
+ responding" dialog is opened
Chris Guiver (guiverc) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Please execute the following command only once, as it will automatically gather debugging information, in a terminal:

apport-collect 1845302

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://wiki.ubuntu.com/ReportingBugs.

Paul White (paulw2u) on 2019-10-04
affects: ubuntu → gnome-shell (Ubuntu)
tags: added: bionic
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in gnome-shell (Ubuntu):
status: New → Confirmed
tags: added: eoan fixed-in-3.34.2 fixed-upstream
affects: mutter → gnome-shell
Changed in mutter (Ubuntu):
status: New → Confirmed
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
status: Confirmed → In Progress
Changed in gnome-shell:
status: Unknown → Fix Released
Iain Lane (laney) on 2019-10-25
description: updated
Changed in gnome-shell (Ubuntu):
status: Confirmed → Invalid
Changed in gnome-shell (Ubuntu Eoan):
status: New → Invalid
Changed in mutter (Ubuntu Eoan):
status: New → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package mutter - 3.34.1+git20191022-2ubuntu1

---------------
mutter (3.34.1+git20191022-2ubuntu1) focal; urgency=medium

  * Merge with debian. Remaining changes:
    + debian/control:
      - Update VCS flags to point to launchpad
    + debian/gbp.conf: update branch to point to ubuntu/master
    + debian/patches/x11-Add-support-for-fractional-scaling-using-Randr.patch:
      - X11: Add support for fractional scaling using Randr

mutter (3.34.1+git20191022-2) unstable; urgency=medium

  * debian/patches: Update X11 focus before display focus:
    - Fixes an infinite loop causing an hang when showing the "application is
      not responding" dialog (LP: #1845302)

mutter (3.34.1+git20191022-1) unstable; urgency=medium

  * New upstream snapshot release
    + Fix night mode in wayland session (LP: #1847551)
    + Don't emit key-focus-out events on destroyed actors (LP: #1848119)
    + Fix an headers syntax error (LP: #1841709)
    + backends: Update inhibited state for the monitor and respect that state
    + clutter-backend-x11: Don't push keymap events to clutter
    + Fix drag and drop for applications in wayland
    + Avoid X11 roundtrips on underscanning checks

mutter (3.34.1-3) unstable; urgency=medium

  * Bump meson test timeout multiplier from 4 to 6 for armel

 -- Iain Lane <email address hidden> Fri, 25 Oct 2019 18:07:31 +0100

Changed in mutter (Ubuntu):
status: In Progress → Fix Released

Hello betteropensource, or anyone else affected,

Accepted mutter into eoan-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/mutter/3.34.1+git20191107-1ubuntu1~19.10.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-eoan to verification-done-eoan. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-eoan. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in mutter (Ubuntu Eoan):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-eoan
description: updated
Jaromir Obr (jaromir-obr) wrote :

I can confirm the fix helped.

I verified it according to the steps in this bug (bug 1845302) and also according to the steps in bug 1850046 (its gnome-shell's part).

BTW when I run "killall -CONT firefox" (see the original description in this issue), the app is closed. I guess it's correct behavior because in the previous step I chosen "Quit" in the context menu of the app. If I don't choose "Quit", "killall -CONT firefox" continues running of the app as expected.

Used SW:
-----------
* Ubuntu 19.10
* mutter-common: 3.34.1+git20191107-1ubuntu1~19.10.1
* mutter: 3.34.1+git20191107-1ubuntu1~19.10.1
* gir1.2-mutter-5: 3.34.1+git20191107-1ubuntu1~19.10.1
* libmutter-5-0: 3.34.1+git20191107-1ubuntu1~19.10.1
* gnome-shell (gnome-shell-common): 3.34.1+git20191024-1ubuntu1~19.10.1

tags: added: verification-done-eoan
removed: verification-needed-eoan
tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.