[SRU] libapache2-mod-mono uninstallable

Bug #92192 reported by Brandon Holtsclaw
14
Affects Status Importance Assigned to Milestone
mod-mono (Ubuntu)
Fix Released
Undecided
Brandon Holtsclaw
Edgy
Fix Released
Undecided
Brandon Holtsclaw

Bug Description

root@voyager:/# apt-get install libapache2-mod-mono
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  libapache2-mod-mono: Depends: mono-apache-server (< 1.1.14) but 1.1.17.1-2 is to be installed or
                                mono-apache-server2 (< 1.1.14) but it is not going to be installed
E: Broken packages
root@voyager:/#

Revision history for this message
Brandon Holtsclaw (imbrandon) wrote :

here is a re-build debdiff that fixes the issue on edgy against the current source package in the edgy repos

Revision history for this message
Brandon Holtsclaw (imbrandon) wrote :

here is one "works for me" ...
http://www.imbrandon.com/show-off/hello.aspx
and the server tag showing the version can be seen at http://www.imbrandon.com/show-off/

Changed in mod-mono:
assignee: nobody → imbrandon
status: Unconfirmed → In Progress
assignee: nobody → imbrandon
status: Unconfirmed → Confirmed
status: In Progress → Fix Released
Revision history for this message
Brandon Holtsclaw (imbrandon) wrote :

 mod-mono_1.1.17-3build1~proposed1 uploaded to edgy-proposed

Revision history for this message
Brandon Holtsclaw (imbrandon) wrote :

per Mithrandir slight versioning change only to mod-mono_1.1.17-3edgy1~proposed1

Changed in mod-mono:
status: Confirmed → Fix Committed
Revision history for this message
William Grant (wgrant) wrote :

Works for me too.

Revision history for this message
Brandon Holtsclaw (imbrandon) wrote :

Here is a new patch with only the changelog changed as per SRU policy, the 7 days have been met and 2 testers.

Changed in mod-mono:
status: Fix Committed → Fix Released
Revision history for this message
StefanPotyra (sistpoty) wrote :

erm... I didn't find this in edgy-updates yet -> back to Fix Committed.

Did you upload it already? (if not, please do so, motu-sru is no longer and thus won't do any uploading ;)

Cheers,
   Stefan.

Changed in mod-mono:
status: Fix Released → Fix Committed
Revision history for this message
Martin Pitt (pitti) wrote :

Accepted into edgy-updates.

Changed in mod-mono:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers