Comment 58 for bug 1850651

(In reply to Andrew DeFaria from comment #50)
> Many extensions were broken so I was waiting for them to be updated and working before I would update my desktop but you (thunderbird not you Dan) forced this update on me. Now I'll try to downgrade to 69.0b4...

Extension authors "only" had about half a year time to update their extensions. IMHO, what isn't updated by now should be considered unmaintained and not fit for use any more.

I really don't understand why after an undesired automated upgrade from 60 to 68 you'd go even further and install a 69 beta 4 version. And then blame others for that "screw up".