bcache partition within fstab prevents from booting

Bug #1833025 reported by Николай Кузьмин on 2019-06-17
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
systemd
Fix Released
Unknown
systemd (Ubuntu)
Undecided
Unassigned
Disco
High
Dan Streetman

Bug Description

Almost every boot attempt drops to initramfs prompt, requiring me to type echo /dev/sdb >/sys/fs/bcache/register. Logs showing that attempt to register caching device via udev rules was made, but failed with code == 1.

Looks like an regression were introduced in upstream (systemd 240) which breaks the order of udev commands.

Here is an upstream bug https://github.com/systemd/systemd/issues/11368
And here is a patch for this issue https://github.com/systemd/systemd/pull/11891
Can you, please merge this patch to disco branch?

Dan Streetman (ddstreet) wrote :

The commits that cause this aren't in Bionic, and the commits that fix this are already in Eoan; so the fix is only needed in Disco.

Changed in systemd (Ubuntu):
status: New → Fix Released
Changed in systemd (Ubuntu Disco):
assignee: nobody → Dan Streetman (ddstreet)
importance: Undecided → High
status: New → In Progress
Changed in systemd:
status: Unknown → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.