changeme.py crashed with SIGSEGV

Bug #1847036 reported by James Page on 2019-10-07
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
python3.7 (Ubuntu)
High
Unassigned
Bionic
High
Unassigned
Disco
High
Unassigned
python3.8 (Ubuntu)
High
Unassigned
Disco
High
Unassigned

Bug Description

Currently blocking proposed migrations as autopkgtest is failing in the same way

ProblemType: Crash
DistroRelease: Ubuntu 19.10
Package: changeme 1.2.1-1
ProcVersionSignature: Ubuntu 5.3.0-13.14-generic 5.3.0
Uname: Linux 5.3.0-13-generic x86_64
ApportVersion: 2.20.11-0ubuntu7
Architecture: amd64
Date: Mon Oct 7 08:29:05 2019
ExecutablePath: /usr/share/changeme/changeme.py
InterpreterPath: /usr/bin/python3.7
PackageArchitecture: all
ProcCmdline: /usr/bin/python3 ./changeme.py
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=C.UTF-8
Python3Details: /usr/bin/python3.7, Python 3.7.5rc1, python3-minimal, 3.7.3-1
PythonDetails: N/A
SegvAnalysis:
 Segfault happened at: 0x7f6da1d4f798: add $0x0,%al
 PC (0x7f6da1d4f798) in non-executable VMA region: 0x7f6da1d19000-0x7f6da1dd9000 rw-p None
 source "$0x0" ok
 destination "%al" ok
SegvReason: executing writable VMA None
Signal: 11
SourcePackage: changeme
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()
Title: changeme.py crashed with SIGSEGV
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups:

separator:

James Page (james-page) wrote :
information type: Private → Public

StacktraceSource:
 #0 0x00007f6da1d4f798 in ?? ()
 #1 0x00007f6da1d4f798 in ?? ()
 #2 0x00007f6da1d4f798 in ?? ()
 #3 0x0000000000000000 in ?? ()
StacktraceTop:
 ?? ()
 ?? ()
 ?? ()
 ?? ()

tags: added: apport-failed-retrace
tags: removed: need-amd64-retrace
James Page (james-page) wrote :
Download full text (4.6 KiB)

Current thread 0x00007fbd53a9a740 (most recent call first):
  File "/usr/lib/python3/dist-packages/pysnmp/carrier/sockmsg.py", line 42 in <module>
  File "<frozen importlib._bootstrap>", line 219 in _call_with_frames_removed
  File "<frozen importlib._bootstrap_external>", line 728 in exec_module
  File "<frozen importlib._bootstrap>", line 677 in _load_unlocked
  File "<frozen importlib._bootstrap>", line 967 in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 983 in _find_and_load
  File "<frozen importlib._bootstrap>", line 219 in _call_with_frames_removed
  File "<frozen importlib._bootstrap>", line 1035 in _handle_fromlist
  File "/usr/lib/python3/dist-packages/pysnmp/carrier/asyncore/dgram/base.py", line 11 in <module>
  File "<frozen importlib._bootstrap>", line 219 in _call_with_frames_removed
  File "<frozen importlib._bootstrap_external>", line 728 in exec_module
  File "<frozen importlib._bootstrap>", line 677 in _load_unlocked
  File "<frozen importlib._bootstrap>", line 967 in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 983 in _find_and_load
  File "/usr/lib/python3/dist-packages/pysnmp/carrier/asyncore/dgram/udp.py", line 9 in <module>
  File "<frozen importlib._bootstrap>", line 219 in _call_with_frames_removed
  File "<frozen importlib._bootstrap_external>", line 728 in exec_module
  File "<frozen importlib._bootstrap>", line 677 in _load_unlocked
  File "<frozen importlib._bootstrap>", line 967 in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 983 in _find_and_load
  File "<frozen importlib._bootstrap>", line 219 in _call_with_frames_removed
  File "<frozen importlib._bootstrap>", line 1035 in _handle_fromlist
  File "/usr/lib/python3/dist-packages/pysnmp/entity/config.py", line 8 in <module>
  File "<frozen importlib._bootstrap>", line 219 in _call_with_frames_removed
  File "<frozen importlib._bootstrap_external>", line 728 in exec_module
  File "<frozen importlib._bootstrap>", line 677 in _load_unlocked
  File "<frozen importlib._bootstrap>", line 967 in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 983 in _find_and_load
  File "<frozen importlib._bootstrap>", line 219 in _call_with_frames_removed
  File "<frozen importlib._bootstrap>", line 1035 in _handle_fromlist
  File "/usr/lib/python3/dist-packages/pysnmp/hlapi/auth.py", line 7 in <module>
  File "<frozen importlib._bootstrap>", line 219 in _call_with_frames_removed
  File "<frozen importlib._bootstrap_external>", line 728 in exec_module
  File "<frozen importlib._bootstrap>", line 677 in _load_unlocked
  File "<frozen importlib._bootstrap>", line 967 in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 983 in _find_and_load
  File "/usr/lib/python3/dist-packages/pysnmp/hlapi/__init__.py", line 10 in <module>
  File "<frozen importlib._bootstrap>", line 219 in _call_with_frames_removed
  File "<frozen importlib._bootstrap_external>", line 728 in exec_module
  File "<frozen importlib._bootstrap>", line 677 in _load_unlocked
  File "<frozen importlib._bootstrap>", line 967 in _find_and_load_unlocked
  File "<frozen importlib._bootstrap>", line 983 in _find_and_l...

Read more...

James Page (james-page) wrote :

Reproducer:

>>> import pysnmp.carrier.sockmsg
Segmentation fault (core dumped)

the ctype binding in pysnmp4 seems to be causing the issue

James Page (james-page) wrote :

This is the offending class:

    class in6_addr_U(ctypes.Union):
        _fields_ = [
            ('__u6_addr8', ctypes.c_uint8 * 16),
            ('__u6_addr16', ctypes.c_uint16 * 8),
            ('__u6_addr32', ctypes.c_uint32 * 4),
        ]

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package python3.7 - 3.7.5~rc1-2

---------------
python3.7 (3.7.5~rc1-2) unstable; urgency=medium

  * Apply proposed patch for issue 38368. LP: #1847036. Closes: #941650.

 -- Matthias Klose <email address hidden> Tue, 08 Oct 2019 18:47:45 +0200

Changed in python3.7 (Ubuntu):
status: New → Fix Released

Hello James, or anyone else affected,

Accepted python3.8 into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python3.8/3.8.0-1~19.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

tags: added: verification-needed verification-needed-disco
Changed in python3.8 (Ubuntu Disco):
status: New → Fix Committed
Mathew Hodson (mathew-hodson) wrote :

Fixed in the final release of 3.8.0

Changed in python3.8 (Ubuntu):
status: New → Fix Released
no longer affects: python-pysnmp4 (Ubuntu Disco)
no longer affects: python-pysnmp4 (Ubuntu)
no longer affects: changeme (Ubuntu Disco)
no longer affects: changeme (Ubuntu)
tags: added: regression-release
Changed in python3.7 (Ubuntu):
importance: Undecided → High
Changed in python3.7 (Ubuntu Disco):
importance: Undecided → High
Changed in python3.8 (Ubuntu):
importance: Undecided → High
Changed in python3.8 (Ubuntu Disco):
importance: Undecided → High
Łukasz Zemczak (sil2100) wrote :

Hello James, or anyone else affected,

Accepted python3.8 into disco-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python3.8/3.8.0-3~19.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-disco to verification-done-disco. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-disco. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Launchpad Janitor (janitor) wrote :
Download full text (3.4 KiB)

This bug was fixed in the package python3.8 - 3.8.0-3~19.04

---------------
python3.8 (3.8.0-3~19.04) disco-proposed; urgency=medium

  * SRU: LP: #1835737. Backport the final Python 3.8.0 release.

python3.8 (3.8.0-3) unstable; urgency=medium

  * python3.8-dev: Depend on zlib1g-dev, needed to link as an
    embedded interpreter.

python3.8 (3.8.0-2) unstable; urgency=medium

  * Fix a symlink to the shared debug library.
  * Install the python3.8d-embed pkg-config file.
  * Don't ship the python3-embed pkg-config file.

python3.8 (3.8.0-1) unstable; urgency=medium

  * Python 3.8.0 release.

python3.8 (3.8.0~rc1-3) unstable; urgency=medium

  * Apply proposed patch for issue 38368. LP: #1847036. Addresses: #941650.

python3.8 (3.8.0~rc1-2) unstable; urgency=medium

  * Python 3.8.0 release candidate 1.
  * Refresh patches.
  * Update symbols files.
  * Bump standards version.

python3.8 (3.8.0~b4-1) unstable; urgency=medium

  * Python 3.8.0 beta 4 release.

python3.8 (3.8.0~b3-1) unstable; urgency=medium

  * Python 3.8.0 beta 3 release.
  * Fix FTCBFS: (Helmut Grohne). Closes: #932077.
    + Build-Depends, when cross compiling we need python3.8.
    + Export CC, because dtrace needs it.
    + Honour DEB_BUILD_OPTIONS=nocheck more thoroughly.
    + Fix up sysconfigdata-name.diff.
  * Implement the native thread ids for the Hurd and KFreeBSD (Samuel
    Thibault). Closes: #931624.
  * Enable pgo/lto builds on arm64. Addresses: #934812.
  * Update symbols files.
  * Don't propagate lto flags to the _sysconfigdata module. Addresses: #934771.
  * d/patches/issue35998.diff: Disable TLS1.3 in the client on all platforms
    rather than just reducing the payload size (Michael Hudson-Doyle).

python3.8 (3.8.0~b2-5) unstable; urgency=high

  * Bump standards version.
  * Revert the KFreeBSD and Hurd fix for PyThread_get_thread_native_id,
    and use the implementation from Python3.7. Mark the symbol as linux only.
  * Don't encode the MACHDEP into the _sysconfigdata file name.

python3.8 (3.8.0~b2-4) unstable; urgency=medium

  * Fix the LTO build.

python3.8 (3.8.0~b2-3) unstable; urgency=medium

  * Define PY_HAVE_THREAD_NATIVE_ID for KFreeBSD and Hurd builds.
  * Fix issue #37504, building the texinfo docs (Dmitry Shachnev).
  * Enable LTO/PGO builds on some architectures.

python3.8 (3.8.0~b2-1) experimental; urgency=medium

  * Python 3.8.0 beta 2 release.
  * Refresh patches.
  * Update the symbols files.
  * Don't build the texinfo documentation, fails. See issue #37504.

python3.8 (3.8.0~b1-2) experimental; urgency=medium

  * Fix include links in python3.8-dbg.

python3.8 (3.8.0~b1-1) experimental; urgency=medium

  * Python 3.8.0 beta 1 release.
  * Refresh patches.
  * Add new importlib dependencies to python3-minimal.
  * Update symbols files.

python3.8 (3.8.0~a4-3) experimental; urgency=medium

  * Update symbols files.

python3.8 (3.8.0~a4-2) experimental; urgency=medium

  * Update to 20190514 from the trunk.
  * Fix interpreter name in the -dbg autopkg tests.
  * Enable dtrace/USDT probe support (--with-dtrace) and build-dep on
    systemtap-sdt-dev (Trent Lloyd). LP: #1818778.

python3.8 (3.8.0~a4-1) experimental; urgency=medium...

Read more...

Changed in python3.8 (Ubuntu Disco):
status: Fix Committed → Fix Released
Łukasz Zemczak (sil2100) wrote :

Hello James, or anyone else affected,

Accepted python3.7 into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/python3.7/3.7.5-2~18.04 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in python3.7 (Ubuntu Bionic):
status: New → Fix Committed
tags: added: verification-needed-bionic
Łukasz Zemczak (sil2100) wrote :

Please ignore the SRU bug comment above - this SRU is handled via a single SRU tracking bug.

Changed in python3.7 (Ubuntu Bionic):
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.