Upgrade to version 2.0 to satisfy pcs dependency

Bug #1825992 reported by Ben Fu on 2019-04-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
pacemaker (Ubuntu)
Status tracked in Eoan
Disco
Medium
Rafael David Tinoco
Eoan
Medium
Rafael David Tinoco

Bug Description

Is there a way we could upgrade the version to 2.0? The pcs package requires a version of pacemaker that is greater than or equal to 2.0, and there is already a debian version packaged for v2. Installing the Ubuntu package for pcs will delete the pacemaker package as there is no version of pacemaker that is greater than 2.0.

I can help with build/testing and packaging for 2.0 based on the existing debian deb if needed.

https://pkgs.org/download/pacemaker

Robie Basak (racb) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.

In which Ubuntu release are you asking for the update? If a stable release, please start by reading https://wiki.ubuntu.com/StableReleaseUpdates - we certainly won't do it without any justification, so please start by providing the justification against our SRU documented policy in this bug.

Once you've explained what versions are needed in which releases, with justifications, please change the bug status back to New. Thanks!

Changed in pacemaker (Ubuntu):
status: New → Incomplete
Ben Fu (ben-fu1) wrote :

Thanks for getting back to me. The release I am requesting the upgrade for is 19.04 (Disco). Here is the justification:

[Impact]
Installing the pcs (pacemaker configuration tool) package in Ubuntu 19.04 gives version 0.10.x. However, as documented in both the dependencies of pcs and the upstream Github (https://github.com/ClusterLabs/pcs), version 0.10.x of pcs requires both pacemaker >= 2.0 and corosync >= 3.0, neither of which are unavailable in the Ubuntu 19.04 release.

[Test Case]
1. Install the pcs package
2. Install the pacemaker package
3. The pacemaker package will cause the pcs package to be uninstalled due to dependencies not being met.

OR

1. Install pacemaker
2. Install pcs
3. The pcs package will cause the pacemaker package to be uninstalled due to dependencies not being met.

[Regression Potential]
pcs 0.10.x, pacemaker 2.x, and corosync 3.x are available in the debian testing repo:
https://packages.debian.org/buster/pcs
https://packages.debian.org/buster/pacemaker
https://packages.debian.org/buster/corosync

The releases are also available on Fedora

[Other Info]
As pcs only has been updated to version 0.10.x in Ubuntu 19.04, the recommended fix would be to update the versions of pacemaker to 2.x and corosync to 3.x in the 19.04 package repository as well. For previous stable releases, the version of pcs is 0.9.x, which is compatible with the versions of pacemaker and corosync in the corresponding releases.

summary: - Upgrade to version 2.0 to support management with PCS
+ Upgrade to version 2.0 to satisfy pcs dependency
Bryce Harrington (bryce) on 2019-05-02
Changed in pacemaker (Ubuntu Disco):
status: New → Confirmed
Bryce Harrington (bryce) wrote :

pacemaker 2.0 (and its dependencies) will first need merged into Eoan. I've added a separate task for that from the Disco backport task.

Regarding backporting pacemaker 2.0 to Disco via SRU, the amount of change from pacemaker 1.1.18 to 2.0.1 is not insignificant, and includes not only new features (over a dozen changes) but also around a dozen deprecated features that get dropped in 2.0. SRU policy likes to see minimal or no chance of regressions, and because of these changes it might be challenging to guarantee that in this case.

However, you're right that pcs lists a Breaks for pacemaker < 2.0, which creates this awkward situation. I'm not sure what the best way to address that might be.

Changed in pacemaker (Ubuntu Eoan):
status: Incomplete → Confirmed
Changed in pacemaker (Ubuntu Disco):
status: Confirmed → New
Ben Fu (ben-fu1) wrote :

Thanks for looking into this! If pacemaker is upgraded to 2.0 and corosync is upgraded to 3.0 in Eoan, then pcs will be compatible with those. For Disco, perhaps one solution would be to downgrade the version for pcs so that it is compatible with pacemaker 1.x and corosync 2.x? Please let me know if I can help in any way regarding testing these packages.

Andreas Hasenack (ahasenack) wrote :

maybe disco will need a pcs with a +really version to go back to 0.9. I think we will know more once we get pacemaker 2 into eoan.

Pacemaker2 is into eoan... help in fixing tests is appreciated!

I'm assigning this case to myself to work during our Ubuntu HA effort, together with all other HA bugs. I'll address this case when reviewing pacemaker and pcs (shortly). I'll let you know our decision for Disco as soon as we check Eoan fully.

Thanks a lot for reporting this!

tags: added: ubuntu-ha
Changed in pacemaker (Ubuntu Disco):
status: New → Confirmed
Changed in pacemaker (Ubuntu Eoan):
assignee: nobody → Rafael David Tinoco (rafaeldtinoco)
Changed in pacemaker (Ubuntu Disco):
assignee: nobody → Rafael David Tinoco (rafaeldtinoco)
Changed in pacemaker (Ubuntu Eoan):
importance: Undecided → Medium
Changed in pacemaker (Ubuntu Disco):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions