Activity log for bug #1813877

Date Who What changed Old value New value Message
2019-01-30 07:25:26 AceLan Kao bug added bug
2019-01-30 07:26:00 AceLan Kao nominated for series Ubuntu Disco
2019-01-30 07:26:00 AceLan Kao nominated for series Ubuntu Bionic
2019-01-30 07:26:00 AceLan Kao nominated for series Ubuntu Cosmic
2019-01-30 07:33:55 AceLan Kao bug added subscriber Canonical Hardware Enablement
2019-01-30 07:33:59 AceLan Kao tags originate-from-1811346 somerville
2019-04-15 06:54:16 AceLan Kao bug task added linux (Ubuntu Bionic)
2019-04-15 06:54:23 AceLan Kao bug task added linux (Ubuntu Cosmic)
2019-04-15 06:54:30 AceLan Kao bug task added linux (Ubuntu Disco)
2019-07-31 03:00:52 AceLan Kao description [Impact] The dell-uart-backlight driver has been loaded, but the backlight is controller by graphics driver instead of scalar IC. The old way to determinate weather the driver should be loaded is not working anymore, since the behavior of scalar command, show firmware version, is not the same as old platforms. [Fix] Using more a reliable command, get_scalar_status, to check if scalar is in charge of the AIO backlight. [Test] Verified on new Dell AIO platforms. [Regression Potential] Expected. The get_scalar_status command is not supported by the first generation AIO platforms, so the driver may not be loaded on old AIO machines due to get_scalar_status command returns 0. To ease the pain, the "force" parameter has been introduced to make the driver can be loaded regardless of the return value of get_scalar_status command. [Impact] The dell-uart-backlight driver has been loaded, but the backlight is controller by graphics driver instead of scalar IC. The old way to determinate weather the driver should be loaded is not working anymore, since the behavior of scalar command, show firmware version, is not the same as old platforms. [Fix] Using more a reliable command, get_scalar_status, to check if scalar is in charge of the AIO backlight. [Test] Verified on new Dell AIO platforms. [Regression Potential] Low. The quirk lists all old platforms which use the old way to check if scalar IC is in use. So, it won't change the behavior on old platforms, and apply the new method on new platforms.
2019-08-02 07:58:18 Alex Tu bug task added oem-priority
2019-11-07 06:28:55 AceLan Kao description [Impact] The dell-uart-backlight driver has been loaded, but the backlight is controller by graphics driver instead of scalar IC. The old way to determinate weather the driver should be loaded is not working anymore, since the behavior of scalar command, show firmware version, is not the same as old platforms. [Fix] Using more a reliable command, get_scalar_status, to check if scalar is in charge of the AIO backlight. [Test] Verified on new Dell AIO platforms. [Regression Potential] Low. The quirk lists all old platforms which use the old way to check if scalar IC is in use. So, it won't change the behavior on old platforms, and apply the new method on new platforms. [Impact] The dell-uart-backlight driver has been loaded, but the backlight is controller by graphics driver instead of scalar IC. The old way to determinate weather the driver should be loaded is not working anymore, since the behavior of scalar command, show firmware version, is not the same as old platforms. [Fix] Using more a reliable command, get_scalar_status, to check if scalar is in charge of the AIO backlight. For the old platforms which don't have the new command, I add a list to list them all and use the old way to determinate the scalar IC. [Test] Verified on old and new Dell AIO platforms. [Regression Potential] Low. The quirk lists all old platforms which use the old way to check if scalar IC is in use. So, it won't change the behavior on old platforms, and apply the new method on new platforms.
2019-11-07 06:32:48 AceLan Kao bug task added linux-oem (Ubuntu)
2019-11-07 06:32:57 AceLan Kao bug task deleted linux (Ubuntu Cosmic)
2019-11-07 06:33:05 AceLan Kao bug task deleted linux-oem (Ubuntu Cosmic)
2019-11-07 06:33:13 AceLan Kao bug task deleted linux-oem (Ubuntu Disco)
2019-11-07 06:33:26 AceLan Kao nominated for series Ubuntu Eoan
2019-11-07 06:33:26 AceLan Kao bug task added linux (Ubuntu Eoan)
2019-11-07 06:33:26 AceLan Kao bug task added linux-oem (Ubuntu Eoan)
2019-11-07 06:33:41 AceLan Kao bug task deleted linux-oem (Ubuntu Eoan)
2019-11-07 06:33:53 AceLan Kao bug task added linux-oem-osp1 (Ubuntu)
2019-11-07 06:34:19 AceLan Kao linux (Ubuntu): status In Progress Invalid
2019-11-07 06:34:19 AceLan Kao linux (Ubuntu): assignee AceLan Kao (acelankao)
2019-11-07 08:46:36 AceLan Kao linux-oem (Ubuntu Bionic): status New Fix Committed
2019-11-07 08:48:45 AceLan Kao tags originate-from-1811346 somerville originate-from-1811346 originate-from-1850265 somerville
2019-11-12 18:13:50 Connor Kuehl linux (Ubuntu Bionic): importance Undecided Medium
2019-11-12 18:13:50 Connor Kuehl linux (Ubuntu Bionic): status New In Progress
2019-11-12 18:13:50 Connor Kuehl linux (Ubuntu Bionic): assignee Kai-Heng Feng (kaihengfeng)
2019-11-12 18:14:56 Connor Kuehl linux (Ubuntu Bionic): assignee Kai-Heng Feng (kaihengfeng) AceLan Kao (acelankao)
2019-11-12 18:15:11 Connor Kuehl linux (Ubuntu Disco): importance Undecided Medium
2019-11-12 18:15:30 Connor Kuehl linux (Ubuntu Eoan): importance Undecided Medium
2019-11-12 18:15:30 Connor Kuehl linux (Ubuntu Eoan): status New In Progress
2019-11-12 18:15:30 Connor Kuehl linux (Ubuntu Eoan): assignee AceLan Kao (acelankao)
2019-11-12 22:31:28 Launchpad Janitor linux-oem (Ubuntu Bionic): status Fix Committed Fix Released
2019-11-12 22:31:28 Launchpad Janitor cve linked 2018-12207
2019-11-12 22:31:28 Launchpad Janitor cve linked 2019-0154
2019-11-12 22:31:28 Launchpad Janitor cve linked 2019-0155
2019-11-12 22:31:28 Launchpad Janitor cve linked 2019-11135
2019-11-12 22:31:28 Launchpad Janitor cve linked 2019-15098
2019-11-12 22:31:28 Launchpad Janitor cve linked 2019-17666
2019-11-18 09:40:46 Timo Aaltonen linux-oem-osp1 (Ubuntu Bionic): status New Fix Committed
2019-11-25 11:41:16 Timo Aaltonen tags originate-from-1811346 originate-from-1850265 somerville originate-from-1811346 originate-from-1850265 somerville verification-needed-bionic
2019-11-26 03:22:58 AceLan Kao tags originate-from-1811346 originate-from-1850265 somerville verification-needed-bionic originate-from-1811346 originate-from-1850265 somerville verification-done-bionic
2019-11-28 14:14:48 Stefan Bader linux (Ubuntu Eoan): status In Progress Fix Committed
2019-11-28 14:16:58 Stefan Bader linux (Ubuntu Disco): status In Progress Fix Committed
2019-11-28 14:17:09 Stefan Bader linux (Ubuntu Bionic): status In Progress Fix Committed
2019-12-02 13:36:15 Launchpad Janitor linux-oem-osp1 (Ubuntu Bionic): status Fix Committed Fix Released
2019-12-02 13:36:15 Launchpad Janitor cve linked 2019-15794
2019-12-03 13:01:06 Launchpad Janitor linux-oem (Ubuntu): status New Fix Released
2019-12-03 13:01:07 Launchpad Janitor linux-oem (Ubuntu): status New Fix Released
2019-12-03 13:02:04 Launchpad Janitor linux-oem-osp1 (Ubuntu): status New Fix Released
2019-12-03 15:43:19 Ubuntu Kernel Bot tags originate-from-1811346 originate-from-1850265 somerville verification-done-bionic originate-from-1811346 originate-from-1850265 somerville verification-done-bionic verification-needed-disco
2019-12-05 11:27:09 Ubuntu Kernel Bot tags originate-from-1811346 originate-from-1850265 somerville verification-done-bionic verification-needed-disco originate-from-1811346 originate-from-1850265 somerville verification-done-bionic verification-needed-disco verification-needed-eoan
2019-12-19 09:24:09 AceLan Kao tags originate-from-1811346 originate-from-1850265 somerville verification-done-bionic verification-needed-disco verification-needed-eoan originate-from-1811346 originate-from-1850265 somerville verification-done-bionic verification-done-disco verification-done-eoan
2020-01-06 12:53:38 Launchpad Janitor linux (Ubuntu Eoan): status Fix Committed Fix Released
2020-01-06 12:53:38 Launchpad Janitor cve linked 2019-14895
2020-01-06 12:53:38 Launchpad Janitor cve linked 2019-14896
2020-01-06 12:53:38 Launchpad Janitor cve linked 2019-14897
2020-01-06 12:53:38 Launchpad Janitor cve linked 2019-14901
2020-01-06 12:53:38 Launchpad Janitor cve linked 2019-18660
2020-01-06 12:53:38 Launchpad Janitor cve linked 2019-19055
2020-01-06 12:53:38 Launchpad Janitor cve linked 2019-19072
2020-01-06 13:12:44 Launchpad Janitor linux (Ubuntu Disco): status Fix Committed Fix Released
2020-01-06 13:12:44 Launchpad Janitor cve linked 2019-2214
2020-01-06 13:26:17 Launchpad Janitor linux (Ubuntu Bionic): status Fix Committed Fix Released
2020-01-06 13:26:17 Launchpad Janitor cve linked 2019-19083
2020-01-06 22:31:20 Launchpad Janitor linux (Ubuntu): status Invalid Fix Released
2020-01-06 22:31:20 Launchpad Janitor cve linked 2019-19078
2020-01-06 22:31:20 Launchpad Janitor cve linked 2019-19332
2020-01-07 08:16:47 Anthony Wong hwe-next: status New Fix Released