Random unrecoverable freezes on Ubuntu 18.10

Bug #1798961 reported by Douglas Silva on 2018-10-20
162
This bug affects 30 people
Affects Status Importance Assigned to Milestone
Linux
New
Undecided
Unassigned
linux (Ubuntu)
High
Unassigned
Bionic
High
Unassigned
Cosmic
High
Unassigned
Disco
High
Unassigned
xserver-xorg-video-intel (Ubuntu)
High
Unassigned
Bionic
High
Unassigned
Cosmic
High
Unassigned
Disco
High
Unassigned

Bug Description

First thing I notice is that the mouse cursor freezes as I'm using it, then I hit the CAPS LOCK key and the LED indicator doesn't respond. Then I try the "REISUB" command, but it doesn't do anything either. Only a hard reset works, pressing down the power button for a few seconds.

How to reproduce?
I couldn't figure out a consistent method. It is still random to me.

Version: Ubuntu 4.18.0-10.11-generic 4.18.12
System information attached.

Also happens under Arch Linux and Fedora.
I've talked to another user on IRC who seems to be having the same freezes.

ProblemType: Bug
DistroRelease: Ubuntu 18.10
Package: linux-image-4.18.0-10-generic 4.18.0-10.11
ProcVersionSignature: Ubuntu 4.18.0-10.11-generic 4.18.12
Uname: Linux 4.18.0-10-generic x86_64
ApportVersion: 2.20.10-0ubuntu13
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC1: dsilva 1213 F.... pulseaudio
 /dev/snd/controlC0: dsilva 1213 F.... pulseaudio
CurrentDesktop: XFCE
Date: Sat Oct 20 09:54:50 2018
InstallationDate: Installed on 2018-10-20 (0 days ago)
InstallationMedia: Xubuntu 18.10 "Cosmic Cuttlefish" - Release amd64 (20181017.2)
MachineType: Dell Inc. Inspiron 5458
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-4.18.0-10-generic root=/dev/mapper/xubuntu--vg-root ro quiet splash vt.handoff=1
RelatedPackageVersions:
 linux-restricted-modules-4.18.0-10-generic N/A
 linux-backports-modules-4.18.0-10-generic N/A
 linux-firmware 1.175
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 02/02/2018
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A15
dmi.board.name: 09WGNT
dmi.board.vendor: Dell Inc.
dmi.board.version: A00
dmi.chassis.type: 9
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA15:bd02/02/2018:svnDellInc.:pnInspiron5458:pvr01:rvnDellInc.:rn09WGNT:rvrA00:cvnDellInc.:ct9:cvr:
dmi.product.name: Inspiron 5458
dmi.product.sku: Inspiron 5458
dmi.product.version: 01
dmi.sys.vendor: Dell Inc.

Douglas Silva (o-alquimista) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

Did this issue start happening after an update/upgrade? Was there a
prior kernel version where you were not having this particular problem?

Would it be possible for you to test the latest upstream kernel? Refer
to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest
v4.19 kernel[0].

If this bug is fixed in the mainline kernel, please add the following
tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag:
'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as
"Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.19-rc8

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Douglas Silva (o-alquimista) wrote :

This is the bug report opened for Arch Linux [TASK FS#59483]:

https://bugs.archlinux.org/task/59483?string=freeze&project=1&type%5B0%5D=&sev%5B0%5D=&pri%5B0%5D=&due%5B0%5D=&reported%5B0%5D=&cat%5B0%5D=&status%5B0%5D=open&percent%5B0%5D=&opened=&dev=&closed=&duedatefrom=&duedateto=&changedfrom=&changedto=&openedfrom=&openedto=&closedfrom=&closedto=

The OP reports 4.17.10-1 being the problematic kernel version. What I can say for sure is that this problem did not exist in kernel versions 4.16 and older.

Yes, I can try the newest kernel, however these freezes are random and I don't know how to trigger them. I will take some time to experiment with it.

Douglas Silva (o-alquimista) wrote :

Affects the latest mainline build 4.19-rc8 as well.

Still cannot identify one way to reproduce it intentionally, although most of the time it happens when I have a video playing and/or multiple images being displayed with the image viewer.

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
tags: added: kernel-bug-exists-upstream
description: updated
Changed in linux (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Changed in linux (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → High
Micha Preußer (mipronimo) wrote :

Hey, have you found any solution? I have the same issue and changed the default kernel now to 4.15.0-36-generic. This is working, but it would be better with the new kernel.

Kai-Heng Feng (kaihengfeng) wrote :

Would it be possible for you to do a kernel bisection?

First, find the last good -rc kernel and the first bad -rc kernel from http://kernel.ubuntu.com/~kernel-ppa/mainline/

Then,
$ sudo apt build-dep linux
$ git clone git://git.kernel.org/pub/scm/linux/kernel/git/torvalds/linux.git
$ cd linux
$ git bisect start
$ git bisect good $(the good version you found)
$ git bisect bad $(the bad version found)
$ make localmodconfig
$ make -j`nproc` deb-pkg
Install the newly built kernel, then reboot with it.
If the issue still happens,
$ git bisect bad
Otherwise,
$ git bisect good
Repeat to "make -j`nproc` deb-pkg" until you find the commit that causes the regression.

Douglas Silva (o-alquimista) wrote :

The problem is, it could take days before the system freezes. I don't know how to reproduce, it simply happens. I don't even know where to start. Maybe 4.17-rc1 and so on. But that's a huge task and one needs a lot of patience to do it. I'm not sure I'll be able to.

Kai-Heng Feng (kaihengfeng) wrote :

The bug in #4 is for Ryzen platforms, so it doesn't apply to Inspiron 5458, which seems to be a Broadwell platform.

Please update the BIOS to A16. If you still see this issue, please attach `journalctl -b -1 -k` in next boot.

Douglas Silva (o-alquimista) wrote :

I have updated to A16 and so far no freezes, although it's still not uncommon for these to stop happening for a while and then return.

lb design (lbdesign) wrote :

I have the same freeze problem https://bugs.launchpad.net/ubuntu/+bug/1802902 and seemingly fixed it by deleting the folder .cache/thumbnails/fail

Hope it works so we can track this thing down.

Douglas Silva (o-alquimista) wrote :
Douglas Silva (o-alquimista) wrote :

It happened again.
See the attachment of the output of journalctl -b -1 -k

This time I was just editing the position of widgets on the xfce4-panel. I think it was around 11:45 on the clock.

And I do not have a .cache/thumbnails/fail folder.

no longer affects: linux (Arch Linux)
Kai-Heng Feng (kaihengfeng) wrote :

There are no noticeable error message. It can be hardware freeze. Can you try 4.20-rc2 and boot with kernel parameter `pcie_aspm=off`?

I also have had random system freezes ever since I upgraded from 18.04 to 18.10, Linux 4.18.0-10-generic, solved by always booting into 4.15.0-36-generic. When the freezes happen, the screen simply stops, and no input is accepted, not even the usual REISUB.

teresaejunior@laptop ~> inxi -Fz
System: Host: laptop Kernel: 4.15.0-36-generic x86_64 bits: 64 Desktop: Xfce 4.13.2
           Distro: Ubuntu 18.10 (Cosmic Cuttlefish)
Machine: Type: Laptop System: LENOVO product: 80JE v: Lenovo G40-80 serial: <filter>
           Mobo: LENOVO model: Lancer 4A1 v: SDK0E50515 STD serial: <filter> UEFI: LENOVO v: B0CN79WW
           date: 05/07/2015
Battery: ID-1: BAT0 charge: 26.4 Wh condition: 26.4/28.5 Wh (93%)
CPU: Topology: Dual Core model: Intel Core i5-5200U bits: 64 type: MT MCP L2 cache: 3072 KiB
           Speed: 1397 MHz min/max: 500/2700 MHz Core speeds (MHz): 1: 1146 2: 1000 3: 1079 4: 1039
Graphics: Device-1: Intel HD Graphics 5500 driver: i915 v: kernel
           Display: x11 server: X.Org 1.20.1 driver: modesetting unloaded: fbdev,vesa resolution: 1366x768~60Hz
           OpenGL: renderer: Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) v: 4.5 Mesa 18.2.2
Audio: Device-1: Intel Broadwell-U Audio driver: snd_hda_intel
           Device-2: Intel Wildcat Point-LP High Definition Audio driver: snd_hda_intel
           Sound Server: ALSA v: k4.15.0-36-generic
Network: Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet driver: r8169
           IF: enp2s0 state: down mac: <filter>
           Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter driver: ath9k
           IF: wlp3s0 state: up mac: <filter>
           Device-3: Atheros AR3012 Bluetooth 4.0 type: USB driver: btusb
           IF-ID-1: docker0 state: down mac: <filter>
Drives: Local Storage: total: 931.51 GiB used: 411.53 GiB (44.2%)
           ID-1: /dev/sda vendor: Seagate model: ST1000LM024 HN-M101MBB size: 931.51 GiB
Partition: ID-1: / size: 915.71 GiB used: 411.52 GiB (44.9%) fs: ext4 dev: /dev/sda2
Sensors: System Temperatures: cpu: 41.0 C mobo: N/A
           Fan Speeds (RPM): N/A
Info: Processes: 267 Uptime: 7h 12m Memory: 11.64 GiB used: 3.45 GiB (29.7%) Shell: fish inxi: 3.0.24

Douglas Silva (o-alquimista) wrote :

teresaejunior, could you try that:

"Can you try 4.20-rc2 and boot with kernel parameter `pcie_aspm=off`?"

I suggest first trying 4.20-rcX and seeing if it freezes at least once. If it does, try booting for a few days with pcie_aspm=off in the kernel parameters. Post back results.

I can't do that right now, because I'm not currently running Ubuntu 18.10.

After around two days of running with `pcie_aspm=off', it does not make any difference. I was just forced to do a hard reset of my laptop.

Kai-Heng Feng (kaihengfeng) wrote :

Please perform a kernel bisection to find which commit introduces the regression.

Torsten Römer (dode) wrote :

I just would like to add that I have the same problem about once a day on a DELL Latitude E5550, usually a relatively short while after resuming from standby. It never happens when I boot into the older 4.15.0-39-generic kernel.

On a Lenovo L420 that I have updated at the same time, I never had the problem so far.

mariana (yram) wrote :

I have the same problem very often during a day on a Lenovo ThinkCentre M900 (see specs below).

Often this problem is preceded by Chrome tabs blinking or blacking out but I can't be sure it is a related problem. In those cases, the only solution is to kill Chrome and restart the application.

When Ubuntu freezes it starts with either a frozen cursor or unable to use the cursor anywhere. Other times Ubuntu becomes very slow before freezing.

    product: 10FCS22R00 (LENOVO_MT_10FC_BU_LENOVO_FM_ThinkCentre M900)
       product: 30BC
          product: Intel(R) Core(TM) i7-6700 CPU @ 3.40GHz
             product: M378A1K43CB2-CRC
             product: M378A1K43CB2-CRC
          product: Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Host Bridge/DRAM Registers
             product: Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor PCIe Controller (x16)
                product: GK208B [GeForce GT 720]
                product: GK208 HDMI/DP Audio Controller
             product: 100 Series/C230 Series Chipset Family USB 3.0 xHCI Controller
             product: 100 Series/C230 Series Chipset Family MEI Controller #1
             product: Q170/Q150/B150/H170/H110/Z170/CM236 Chipset SATA Controller [AHCI Mode]
             product: Q170 Chipset LPC/eSPI Controller
             product: 100 Series/C230 Series Chipset Family Power Management Controller
             product: 100 Series/C230 Series Chipset Family HD Audio Controller
             product: 100 Series/C230 Series Chipset Family SMBus
             product: Ethernet Connection (2) I219-LM
             product: SanDisk SD8SB8U5
             product: DVD-RW DH16AFSH
             product: BUP Slim RD
       product: To Be Filled By O.E.M.

MURAOKA Taro (koron) wrote :

I tried Kernel/MainlineBuilds (https://kernel.ubuntu.com/~kernel-ppa/mainline/?C=N;O=D) with my Dell XPS13 (9343).

* v4.16 is OK
* v4.16.1 is NG
* v4.17.19, v4.19.x are NG

KH (uy) wrote :
Download full text (4.9 KiB)

I am running Kubuntu 18.10 w kernel 4.18.0-11-generic with AMD Ryzen 2700x CPU, I initially believed I had a Ryzen soft lockup issue, and I had posted in AMD community forums:

https://community.amd.com/thread/225795#

But I later realized the AMD soft lockup issue is one that required motherboard reset button to get out off. My issue is usually not so bad, most of the time, SSH and network and VIRTUAL MACHINES inside my server will still work. I could use the following command vis SSH to get back alive:

#sudo systemctl restart sddm

I am now inclined to suspect a Linux Kernel scheduler had caused some of my threads frozen, and X.org console frozen - mouse and keyboard stuck.

The latest discover on/right-after X'mas 2018 was that all CPUs logical & physical cores will still be running as seen in ksysguard graphs and top command, while some threads typically my late night crontab backup jobs, HANG FOR HOURS randomly and after hours, RESUME THEMSELVES. The backup was apparently all done - but up to after 12hours of delays!

I had also seen frozen X.org screen later refreshed a little after 45mins, but I could not wait further so I SSH a sddm restart as mentioned above.

I copy my post dated Dec.27.2018 on AMD community forum below:

Dear All,

Today my new discovery indicated that we may be heading wrong direction with regards to CPU core voltage and power states. It has got to be something else.

265px-Ksysguard1.png

I use the famous linux top command and ksysguard (above imgs) and I sort of AMBUSH the problem awaited to solidly catch a process that frozen.

And my chance came today. I caught my Virtual Machines Backup crontab jobs frozen at the vmware's vmrun suspend command. Info:

https://docs.vmware.com/en/VMware-Fusion/11/com.vmware.fusion.using.doc/GUID-24F54E24-EFB0-4E94-8A07-2AD791F0E497.html

My cron jobs put each virtual machines into suspend mode and backup into a harddisk. I got a clue few days ago when I check through my backups, their folder date time stamps suggested that the usual backup jobs which should all be done within 30 mins normally, had on 2 occasions took several hours! There was nothing else wrong beside the long time spent at late night to backup, the data seem quite completely backed up. That means, the lockup or freeze could unfreeze themselves and proceeded to a long delayed completion.

So I ssh into this Ryzen machine at my crontab job hour today, forwarded X and ran ksysguard and top at remote desktop. Yes the cron job frozen and backup was not happening. I also used the linux ps -aux | grep crontab & similar commands, it was confirm that crontab was hanging awaiting for vmrun to suspend the vm, and this command just frozen. It fronzen for almost 2 hours! & later it completed it after this long delay. And my script went ahead further to backup another virtual machine, and after backing up, it is suppose to do vmrun resume but agian, the resume frozen up and took more than 1 hour. After this even my ssh -X session died. I can not reconnect again.

During these hours, I had the top command and ksysguard showing me that other processes and thread were running, ALL my 16 logical (8 physical) CPU...

Read more...

Siavash (siavash-arya89) wrote :

This happens to me on a clean install with OS updates installed 19/01/01.

KH (uy) wrote :
Download full text (3.4 KiB)

My latest posting on this bug issue posted in AMD communities copied here FYI:

https://community.amd.com/thread/225795?start=90&tstart=0

102. Re: Ryzen linux kernel bug 196683 - Random Soft Lockup
uncle yap
uncle yap Jan 4, 2019 3:29 AM (in response to imshalla)

Dear All,

Some good news and discovery.

My crisis is greatly improved so far after 1st 5 hours running without lockup now. All I did essentially was changing my Linux Kernel from 4.18.0-11-generic to 4.15.0-43-generic

I had previously also tried 4.18.0-13-generic and found it equally bad.

My highest suspicion is 4.18.0-X kernel's thread scheduler is/are buggy with a same bug that would freeze up some threads randomly and up to 12hours long and later randomly unfreeze them. I call that random because I can not find any consistent pattern on how it freeze / unfreeze. These hardly require a hard reset unless it is left frozen for very long time. If I discovered soon enough and gave soft reset by SSH command sudo systemctl restart sddm it will be recovered. It would be gdm instead of sddm if you are in ubuntu instead of kubuntu.

My guess for this difference (between requiring a motherboard reset switch vs soft reset command) is that TOO MANY REPEATED THREAD FROZEN OVER LONGER TIME UNATTENDED. It is a guess only because I cannot afford the time to test and prove that. My faithful logical analysis and derivation is so, because this kernel thread scheduler bug will freeze more & more threads than it unfreeze over longer unattended time, and that critical kernel or driver module threads or ssh or bash itself could have been frozen, hence you have no more chance to soft reset / recover.

I have proven that when only 1 or 2 threads frozen, servers, ssh, bash, and even ksysguard (CPUs usage / load percentage graphs) will still be running and I never found any single CPU core nor logical CPU (hyperthread) completely stuck in ZERO% usage.

265px-Ksysguard1.png

When my X.org console freezes, mouse will freeze and CPU usage graph will all freeze, but usually still a good chance if I quickly ssh my favorite reset command sudo systemctl restart sddm it will be recovered. If I wasn't checking and left it frozen for long time, there had been a high chance of it completely not recoverable via ssh command, and reset switch became the only way to get system back rebooted up.

Today, when I checked my CPU Pstate via kernel, it is not running any C6, but I mt BIOS setting neither DISABLED C6 nor use TYPICAL CURRENT IDLE, nor I am using kernel boot idle=nowait , but I think my F4E version BIOS by Gigabyte X470 had DISABLED C6 power state & forced TYPICAL CURRENT IDLE:

    ~$ cat /sys/devices/system/cpu/cpu*/cpuidle/state*/name

    POLL

    C1

    C2

    POLL

    C1

    C2

    POLL

    C1

    C2

    POLL

    C1

    C2

    POLL

    C1

    C2

    POLL

    C1

    C2

    POLL

    C1

    C2

    POLL

    C1

    C2

    POLL

    C1

    C2

    POLL

    C1

    C2

    POLL

    C1

    C2

    POLL

From existing state of stability I am optimistic to expect no further debugging on my system for now.

My proposal for Kubuntu/Ubuntu users is to check kernel...

Read more...

Siavash (siavash-arya89) wrote :

I tried kernel 4.20 and 4.15 and keep having freezes.
I have a clean install. I used to have 17.10 on this machine without problems.

I have been using Linux 4.15 as a workaround too. I noticed I could reproduce the bug easily by watching YouTube on Chrome in fullscreen. I know it is related to the GPU, but in my case, the Intel drivers (Mesa DRI Intel HD Graphics 5500 (Broadwell GT2) v: 4.5 Mesa 18.2.2)

Alfonso (alfonso-ss-04) wrote :

Hello. I had been using Xubuntu 18.04 since May to November, with no problems. This problem began when I upgraded to Xubuntu 18.10, using the Upgrade GUI. I work with my laptop around 10 hours a day, sometimes more, and since I installed 18.10, it freezes between 3 to 7 times a day, sometimes more. I work mostly with Firefox, 5+ tabs open, mostly Google Drive. I also have Dropbox running in the background. It seems to happen more often when I upload an image to a Google Drive file, or while performing a screen capture. Some other times while scrolling on a file, and once while using Atom.

I performed a clean install of Xubuntu 18.10 a week ago, and the problem persisted.

This happened with kernel 4.18.0-10 & 4.18.0-13. So I downgraded last night to 4.15.0-43, and so far so good, though it's too soon. If it freezes, I'll post back.

Alfonso (alfonso-ss-04) wrote :

Today the problem presented itself, twice, with kernel 4.15.0-43-generic in Xubuntu 18.10.

Dane Balia (danebalia) wrote :

Also running into the same issue. It's been happening ever since I installed 18.10.

I can't seem to replicate it, but I have 2 patterns
1. when I use communication software, like Skype or TeamViewer - GNOME here resets and logs me out.
2. Interacting between VMPlayer (windows) and Ubuntu - freezes completely and have to reboot

I'm seeing a ton of this in SYSLOG:
nouveau 0000:01:00.0: gr: GPC0/TPC0/TEX: 80000009

Quite a bit of this:
Unrecoverable failure in required component org.gnome.Shell.desktop

I can't replicate.

Running 18.10 with 4.18.0-13-generic.

Josh Krull (cj64) wrote :

I am encountering a similar issue on a new Dell G5 5587. I've installed Ubuntu 18.10 (fresh download today) alongside Windows 10 on a 1TB nvme SSD.

I can boot into Ubuntu, but the system hangs shortly after boot, usually less than 5 minutes. I have not determined what specifically triggers the hanging. I have noticed that it does not happen all at once. By that I mean that I lose mouse first (touchpad and wireless mouse), but I can still use the keyboard (sometimes) for a few seconds after the mouse is gone. This makes me wonder if the system is actually frozen or if there is just no HID being recognized. I've also seen the system "lag" input from the keyboard: no response immediately but 30-40 seconds later characters that I typed will appear. I also notice that the fans kick on high, so there may be a runaway processes.

In the current state 18.10 is unusable. I haven't even been able tail the log files, I encounter the hang before I have time to troubleshoot the issue. I'm not sure if it's the same issue or something specific to my hardware, I'll update as I continue to try to troubleshoot.

Josh Krull (cj64) wrote :

I found a solution to my particular issue.
DISCLAIMER: I'm not positive that I experienced the same issue as other commenters since the problem was more pronounced than others have been describing. Since this is a new system, this was the first time I tried to install Ubuntu. I'll try to describe what I found in some detail since this was thread seemed like the most pertinent to my issue it may help others.

In my case I had neglected to enroll an MDK correctly. I was able to use the system a little longer by using Ctrl-Alt-F2 to login instead of using X. Once in the terminal I was able to see some useful messages when the lockup occured. In one instance I got a hard lockup:

[ 99.065138] NMI watchdog: Watchdog detected hard LOCKUP on cpu9

The more useful message occurred during another lockup which was a series of messages from nouveau. Here are the first and last messages:

[ 28.832124] nouveau 0000:01:00.0: secboot: error during falcon reset: -110
[ 43.811710] nouveau 0000:01:00.0: systemd-logind[1025]: failed to idle channel 2 [systemd-logind[1025]]

Steps to reproduce (from memory, not verified):
 - Select proprietary drivers during install with UEFI boot mode and Secure Boot enabled.
 - Enter password for MDK
 - Reboot
 - MDK management screen displayed, select continue to boot (THIS WAS THE MISTAKE)

I had never used an MDK before, so did not know that you had to elect to "Enroll" the MDK that was generated during the install process. I had expected to be prompted for a password at some point during the reboot based on the language in the installer. There is some user interaction required at that menu to enroll the MDK at which point the user is prompted for a password and then a reboot can be completed.

Description of MDK with some screenshots: https://wiki.ubuntu.com/UEFI/SecureBoot/DKMS

Steps to address issue once reproduced (basically remove nouveau, install NVIDIA official driver):

I blacklisted a number of modules in /etc/modprobe.d/blacklist.conf:

blacklist amd76x_edac
blacklist vga16fb
blacklist nouveau
blacklist rivafb
blacklist nvidiafb
blacklist rivatv

I got the list of modules from: https://askubuntu.com/questions/481414/install-nvidia-driver-instead-of-nouveau however I did not download the driver from NVIDIA, I used one from the repository:

sudo apt install nvidia-driver-410

This laptop uses an i7-8750H which (I think) contains integrated graphics. The 1060 should be feeding the display, but I'm not sure if the presence of a second graphics adapter introduced a conflict.

Dipak (patildipak) wrote :

I also faced this same bug. I was casting video from my laptop to chrome cast- for about one hour it worked fine and then suddenly video stopped and laptop did not respond at all. It did not take any input. So, I had to hit the power button and switch it off and start it again.

-Was using Chrome browser to cast the tab to watch the video online.
-My computer is Dell Inspiron 7000 with Intel core i7 8th gen cpu

Darek (d-paczko) on 2019-01-29
Changed in linux (Ubuntu Cosmic):
assignee: nobody → Darek (d-paczko)
Darek (d-paczko) wrote :

Ubuntu froze again. It happened after closing the lid. There were streaks on the screen after opening. I held the power button. The laptop would not turn on again. Even the welcome screen did not appear. Just a black screen. I had to turn on and off several times. Only after an hour I could enter the bios settings and start the system from the repair disk. The disk scan did not report any errors. I had this before and then I had to reinstall everything, because the bios did not detect the disk. It was only the format and reinstallation of Windows and Ubuntu that helped. Now it happened again, but fortunately Ubuntu is visible after the start. I will format disk again and install Ubuntu, but now without nvidia drivers

Darek (d-paczko) wrote :

It turns out that the installation without nvidia drivers and the secureboot option also causes errors. After some time using the laptop, the screen freezes and only holding down the power button allows you to turn off. Unfortunately, after switching on again, there was a problem with the grub welcome screen. I could not even enter the bios settings. There was only a black screen. I had to press the power button several times until I was able to do it after an hour.
I have been using ubuntu for several years and this has never happened to me. The problem appeared a week ago on January 23. Previously, everything was fine.

Oleg Nechiporuk (oneciporuks) wrote :

Same freezing error.
Clean 18.10 Ubuntu instal.
Processor: Ryzen
Nvidia drivers installed from nvidia homepage.

More frequently freezing when working with video inside kdenlive. But had freezes also when only chrome was playing music.

Peter Eric Butler (buttle) wrote :
Download full text (5.6 KiB)

Same freezing error.
Clean 18.10 install

Every time it has frozen I have been viewing a Youtube video in Firefox 65.0 (64bit).
The ONLY way out is a hard reboot from the power switch.

I have now installed nVIDIA drivers because I need to load CUDA toolkit to edit video, but this was freezing up before I installed nVIDIA, right from clean OS install. It is still freezing with the new nVIDIA drivers running.

Below is my system info:

W path Device Class Description
=================================================================
                                       system Veriton M490G (To Be Filled By O.E.M.)
/0 bus Veriton M490G
/0/0 memory 64KiB BIOS
/0/4 processor Intel(R) Core(TM) i3 CPU 530 @ 2.93GHz
/0/4/5 memory 128KiB L1 cache
/0/4/6 memory 512KiB L2 cache
/0/4/7 memory 4MiB L3 cache
/0/10 memory 2GiB System Memory
/0/10/0 memory DIMM [empty]
/0/10/1 memory DIMM [empty]
/0/10/2 memory 2GiB DIMM DDR3 Synchronous 1334 MHz (0.7 ns)
/0/10/3 memory DIMM [empty]
/0/100 bridge Core Processor DRAM Controller
/0/100/1 bridge Core Processor PCI Express x16 Root Port
/0/100/1/0 display GT218 [GeForce 210]
/0/100/1/0.1 multimedia High Definition Audio Controller
/0/100/16 communication 5 Series/3400 Series Chipset HECI Controller
/0/100/16.2 storage 5 Series/3400 Series Chipset PT IDER Controller
/0/100/16.3 communication 5 Series/3400 Series Chipset KT Controller
/0/100/1a bus 5 Series/3400 Series Chipset USB2 Enhanced Host Controller
/0/100/1a/1 usb1 bus EHCI Host Controller
/0/100/1a/1/1 bus Integrated Rate Matching Hub
/0/100/1a/1/1/5 scsi6 storage USB2.0-CRW
/0/100/1a/1/1/5/0.0.0 /dev/sdd disk Compact Flash
/0/100/1a/1/1/5/0.0.0/0 /dev/sdd disk
/0/100/1a/1/1/5/0.0.1 /dev/sde disk SM/xD-Picture
/0/100/1a/1/1/5/0.0.1/0 /dev/sde disk
/0/100/1a/1/1/5/0.0.2 /dev/sdf disk SD/MMC
/0/100/1a/1/1/5/0.0.2/0 /dev/sdf disk
/0/100/1a/1/1/5/0.0.3 /dev/sdg disk MS/MS-Pro/HG
/0/100/1a/1/1/5/0.0.3/0 /dev/sdg disk
/0/100/1a/1/1/5/0.0.4 /dev/sdh disk SD/MMC/MS/MSPRO
/0/100/1a/1/1/5/0.0.4/0 /dev/sdh disk
/0/100/1b multimedia 5 Series/3400 Series Chipset High Definition Audio
/0/100/1d ...

Read more...

Changed in linux (Ubuntu Cosmic):
assignee: Darek (d-paczko) → nobody
Jürgen (j-w-ott) wrote :

I have the Problem with Kerner 4.15.0-43.

rdesktop sometimes hangs fullscreen and can only be killed via ssh from another pc.

With this bug however I cannot restart sddm and after killing rdesktop the screen stays frozen with the rdesktop output.

Alfonso (alfonso-ss-04) wrote :

I have been using kernel 4.18.0-15-generic for 3 weeks now, and I haven't had this issue anymore.

Running Xubuntu 18.10 with 4.18.0-15-generic

I'm using this same version of ubuntu. Before crash I've opened new terminal window Ctrl + Alt + F1 and then I 'saw NMI watchdog: BUG: soft lockup - CPU#2 stuck for 23s! [plymouthd:305]'.
In my case this do the trick:
https://askubuntu.com/questions/875173/nmi-watchdog-bug-soft-lockup-cpu2-stuck-for-23s-plymouthd305

Paco Angulo (3rpako) wrote :

Had same frozen display problem with Ubuntu, most times coincident with a very busy video adapter (MVP, Gimp, GMaps..)
Hardware: Laptop Acer Aspire 5735Z
Ubuntu 18.10
Linux 4.18.0-13-generic

Workaround:
sudo nano /usr/share/X11/xorg.conf.d/20-intel.conf
...add
Section "Device"
 Identifier "Intel Graphics"
  Driver "intel"
 Option "AccelMethod" "sna"
 Option "TearFree" "true"
 Option "DRI" "3"
EndSection

Result: Still ok after several hours and tasks.

MURAOKA Taro (koron) wrote :

I confirmed that 3rpako's settings work for my env too.
My env is Dell XPS13 (9343) + Xubuntu 18.10.

Torsten Römer (dode) wrote :

For me on a DELL Latitude E5550 it seems the issue is solved since update to 4.18.0-16-generic (kubuntu). Running for a week now with several suspend/resume cycles - no more frost. Spring is coming :-)

Nikita Travkin (travmurav) wrote :

I think that I have similar issue:
On Kernel 4.18.0-16-generic I had:
 1) Two unrecoverable freezes (sound looped, unable to SSH)
 2) Random software crashes with segfault in dmesg
 3) Random Chrome tab crashes with "trap invalid opcode" in dmesg

To reproduce segfaults I downloaded latest Kernel sources and make -j10 them (several times) to get some "realistic" load. Most of compilations failed with segfault. One ended with coomplete freeze and only one or two succeed.
After booting with mainline 4.15.0-041500-generic from kernel.ubuntu.com I was able to compile kernel successfuly 3 times in a row.

I have newly built PC with Ryzen 5 2600 and I am sure that my RAM is OK.

Attached small parts of logs with segfaults and trap messages.

Torsten Römer (dode) wrote :

Unfortunately I have to revoke my comment #44 - had again two freezes with 4.18.0-16-generic in the last few days.

@dode Have you tried #42?

Torsten Römer (dode) wrote :

@teresaejunior Yes, currently trying it, will report back!

Joseph McGarvey (mcgstrategic) wrote :

I have a freeze issue when it sits unused for about 15 minutes. The issue I found is that the Keychain is using a massive amount of system resources. I have launch a console session with alt+F# (which takes about 5 minutes to show), run top, and then kill the keychain process. Then the system responds like normal. This never happened with 18.04, only after upgrade to 18.10.

adrhc (adrhc) wrote :

Is it the same as https://askubuntu.com/questions/1133341/xubuntu-18-10-locking-weird-behavior ?

CTRL + ALT + F7 brings the lock window on allowing to unlock.

Jeff Walter (jeffreydwalter) wrote :

I have encountered this problem on Ubuntu Bionic (running in VMWare Fusion) with Chrome latest open. Chrome will start drawing the page randomly (I've seen that on really old versions of Chrome on Mac). When it starts doing that I can lock-up my OS by doing a `killall chrome` from terminal. When I do that, I can still move my mouse, but clicking doesn't register. I end up having to reboot my VM.

This bug has become a catchall for any type of system unresponsiveness. I had hope the hard-lockup problem would be solved on Linux 5.0, Ubuntu 19.04, but it wasn't. I'll try the solution from #42 and report back. The probable root cause of the problem may be investigated on the diff from comment #23.

Torsten Römer (dode) wrote :

After uptime 15 days, 10:34 with countless standby/resume cycles, I think it is pretty safe to say that the solution from #42 works for me too.

Mariano Draghi (chaghi) wrote :

The workaround from #42 seems to make the hard lockup less frequent for me, but it's not completely gone. I still experience a complete freeze from time to time. It's completely aleatory, and it doesn't seem related to the workload, although I suspect that it's related to powersaving. From my experience, the probability of being hit by the freeze increases around a standby or resume event, or around plugging / unplugging the laptop.

When the hardlock occurs, the only thing I can do is to turn off the laptop by long-pressing the power button. I can't switch to a virtual tty, I can't reach the machine via SSH, REISUB doesn't work, etc.

Upon restarting, there's absolutely nothing in the kernel logs that could be remotely related to the lockup. In fact, many times the last entry in `journalctl -b -1` is from several minutes *before* the lockup.

I suspected of a hardware problem for a while, but the fact that every hardware test I've run finds nothing, coupled with the fact that the frequency of the freeze has *definitely* decreased with successive Ubuntu/kernel/mesa versions convinced me otherwise.

My specs:
 - Lenovo ThinkPad T470s
 - Intel Core i5-7200U (Kaby Lake)
 - Intel HD Graphics 620 (rev 02)
 - Currenly on Ubuntu 18.10, kernel 4.18.0-17-generic, although for me this bug has been present ever since Ubuntu 17.10, kernel 4.13

Torsten Römer (dode) wrote :

Unfortunately I have to confirm that the workaround from #42 only makes the hard freeze less frequent and doesn't solve it like I stated in #53.
I also have the impression that standby/resume increases the probability of a freeze, but I just had one about one hour after a fresh new start.

I haven't been bitten by this bug with an uptime of 9 days with workaround #42. But I had not the opportunity to test suspending my laptop during this time.

Also, I recommend creating /etc/X11/xorg.conf.d/20-intel.conf instead of /usr/share/X11/xorg.conf.d/20-intel.conf. Files under /usr/share can be lost during package updates.

Changed in xserver-xorg-video-intel (Ubuntu):
status: New → Invalid
Changed in xserver-xorg-video-intel (Ubuntu Cosmic):
status: New → Invalid
Changed in xserver-xorg-video-intel (Ubuntu Bionic):
status: New → Invalid
importance: Undecided → High
Sebastien Bacher (seb128) wrote :

Seems like a kernel issue, marking invalid for intel but feel free to reopen if it proves out to be an issue with the driver (not that -intel is deprecated in favor of modesetting nowadays)

Changed in xserver-xorg-video-intel (Ubuntu Disco):
status: New → Invalid
Changed in xserver-xorg-video-intel (Ubuntu):
importance: Undecided → High
Changed in xserver-xorg-video-intel (Ubuntu Cosmic):
importance: Undecided → High
Changed in xserver-xorg-video-intel (Ubuntu Disco):
importance: Undecided → High
S Prasanth (prasanth-s-cmi) wrote :

I've had these freeze issues for a while, and I've been following this thread for a while (comment #42 helped, though I still have occasional freezes).

Googled "Fedora random freeze" today and found this: https://fedoraproject.org/wiki/Common_F28_bugs#Certain_laptops_.28Lenovo.29_hang_randomly

Apparently an issue in Ubuntu also: https://www.phoronix.com/forums/forum/software/desktop-linux/1020821-fedora-workstation-28-is-shaping-up-to-be-another-terrific-update?p=1020982#post1020982

And the timing of these bugreports/comments coincides with when these freezes started affecting me...

Long story short, we can try adding `ahci.mobile_lpm_policy=1` or `ahci.mobile_lpm_policy=0` to the kernel options in grub. Supposedly confirmed to help Lenovo G50-80, X250 and T450s. We have a G40-80 and T470s affected on this thread, and mine's a Lenovo G500s (similar to G50-80). Maybe it'll help? (praying that it helps)

It's possible that these freezes have multiple causes, and won't be completely fixed even if the workaround helps at all.

pekon (pekon-gupta) wrote :

I also confirm that Paco Angulo (3rpako)'s suggestion (#42) worked for my laptop too. It's Asus with I7 core running Debian-10. Thanks Paco Angulo.

The correct solution to the problem I've been facing was finally solved on comment #58, thanks @prasanth-s-cmi. I've contacted the kernel developer responsible for these patches introduced around Linux 4.16.1 on https://bugzilla.redhat.com/show_bug.cgi?id=1571330 , and he will blacklist my laptop model (Lenovo G40-80) for newer versions of Linux. Meanwhile, `ahci.mobile_lpm_policy=0` can workaround this problem.

I was getting random freezes on a Dell Latitude E7450 with Intel HD Graphics 5500, with no hints as to the cause in logs that I could find. Freezes could happen multiple times a day when in heavy use, but often more like once a week. I followed the advice in #42 a month ago and have had no freezes since (fingers crossed!).

Currently on 18.04.2 LTS with 4.15.0-50-generic, but also had freezes on 16.04 LTS, starting around autumn 2018. Although had been using this laptop since 2015 without problem before that.

Warren (warren2016) wrote :

Hi All.

I am getting system freezes on a dual boot base unit with Ryzen 1700 and a R9 380 graphics card. I'm running Kubuntu 19.04. The whole system locks up and I have to hard power down with the power button. This is happening at least once a day. I don't think its worth trying fixes #43 and #58 because this is not a laptop and my graphics card is not Intel.

This is annoying as I have just migrated over to Brave but now I have gone back to FF (if this doesn't get fixed) for good.

Warren (warren2016) wrote :

Sorry I thought this was a thread about Brave Browser and freezing, not just Ubuntu in general. Well touch wood I only get freezes with Braze meaning I'll have to ditch Brave Browser.

Karl Pickett (karl-pickett) wrote :

I am using 19.04. I have a Pentium G4600 desktop (Intel NUC, kaby lake, intel 630 HD graphics) and have gotten hard lockups on average every 24 hours, and always while playing video usually in chrome. This system was rock solid with 18.04 :(

@karl-piccket try booting with ahci.mobile_lpm_policy=0, and then try comment #42 if it doesn't work.

Peter (peter1095) on 2019-06-22
Changed in linux (Ubuntu):
status: Triaged → Confirmed
Karl Pickett (karl-pickett) wrote :

ahci.mobile_lpm_policy=0 did not fix it, it hung in a few days. I will downgrade to 18.04. And small correction, this is an asrock deskmini h110m-stx system, not a NUC.

Michael Skelton (sk3l) wrote :

I had been experiencing the freeze/lockup on 18.10. My main machine is a Lenovo ThinkPad laptop with switchable graphics (Intel & Nvidia), and Intel Xeon E-2176M CPU.

Originally, my guess was that the lockup was graphics related. Back in March 2019, I applied the xorg.conf edits recommended in comment #42. This seemed to eliminate the hard freezes, at least for a while. However, not long ago, perhaps around mid-June, the freezes returned. Also, I encountered the freezes not only with Intel graphics engaged, but when the system was using the discrete Nvidia chip too. I tried to correlate the freezing with use of Chromium, but it occurred using Firefox too, and in fact happened with no browser running.

As a last ditch attempt to avoid re-installation, I upgraded the system from 18.10 ~> 19.04, hopeful that kernel version 5 would make the situation better. In my case, this has been so. //Since upgrading to 19.04, and running various increments of kernel 5 (5.0.0-[17,19,20]-generic,) I haven't encountered any freezes// 5 days now and counting (FWIW)

From reading prior posts, seems some folks are already using kernel 5, and their freeze problem remains. Nevertheless, for my case, with a laptop with newer hardware, upgrading Ubuntu and kernel version was helpful.

I had accumulated a collection of crash dumps from my old Ubuntu version (18.10 and kernel 4.18), which I will attach to the ticket. Hopefully they might be of use for investigation.

Michael Skelton (sk3l) wrote :

kernel crash logs attached

total 32M
-rw-r--r-- 1 root root 329K Jun 25 21:16 initramfs-tools.0.crash
-rw-r--r-- 1 root root 76K Jun 23 21:09 nvidia-dkms-410.0.crash
-rw-r--r-- 1 root root 16M Jun 23 21:01 _usr_bin_dpkg.0.crash
-rw-r--r-- 1 root root 622K Jun 23 20:50 _usr_bin_kglobalaccel5.1000.crash
-rw-r--r-- 1 root root 379K Jun 23 21:16 _usr_bin_sddm.0.crash
-rw-r--r-- 1 root root 15M Jun 23 21:07 _usr_bin_sddm-greeter.109.crash
-rw-r--r-- 1 root root 683K Jun 23 20:48 _usr_lib_udisks2_udisksd.0.crash

Manu (mce35) wrote :

I was also getting random freeze (multiple times a day), and using the ahci.mobile_lpm_policy=0 appears to solve the issue as well (didn't try another value).
BTW, I am using Debian (kernel 4.19.0-5-amd64 #1 SMP Debian 4.19.37-3 (2019-05-15))
Laptop: HP 15-ay005nf (core i3 5005U with Intel graphics 5500)
The bug happens with the original 1TB WD Blue (WD10JPVX) HDD and with a Samsung 860 EVO 250GB SSD.

I tried to flash the latest UEFI and it still needs the ahci.mobile_lpm_policy=0 to work properly.

Brad Figg (brad-figg) on 2019-07-24
tags: added: ubuntu-certified
Uttam Pal (uttam2707) wrote :

I am having the same issue since 18.04. I monitored the memory usage in system monitor. The total RAM uses increases gradually after the boot. Even if no program is running it goes on increasing until it is 100% and then everything freezes. The memory uses by the processes doesn't add up to the total memory uses shown. Whichever program is eating the RAM is not listed in the processes. The issue remains in 19.04.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.