Support Japanese new era "令和 (Reiwa)"

Bug #1838322 reported by Mathieu Trudel-Lapierre on 2019-07-29
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
icu (Ubuntu)
Medium
Unassigned
Xenial
Medium
Unassigned
Bionic
Medium
Unassigned
Disco
Medium
Unassigned

Bug Description

[Background]
Many packages are affected by the requirement to support the new era "Reiwa" (令和)

This is the meta bug to track packages that need fixes; which packages have already been SRUd to previous releases, how to prioritize the work needed, and general test cases for verifying that things are working as expected.

[Impact]
Users who run Ubuntu in Japanese.

[Test cases]

Unicode data embedded into icu should include REIWA like it includes HEISEI.

== Date conversion ==

On applications that support writing dates in long form, or with symbols to denote era (either in X00.00.00 format or in GG1G5G1G format (G- glyph; X- character):

1) Enable date formatting in each of the above formats that are supported (long form or symbols)
2) Type in '2019/05/01' to be formatted, verify that it shows as "令和1年5月1日" or "R1.05.01"
3) Type in '2019/04/30' to be formatted, verify that it shows as "平成31年4月30日" or "H31.4.30"

== Character maps / font support ==

1) Search for character "SQUARE ERA NAME"
2) Verify that the results include at least "SQUARE ERA NAME HEISEI" and "SQUARE ERA NAME REIWA" (there should also be Syouwa, Taisyou and Meizi), and that the glyphs are readable:

 - SQUARE ERA NAME HEISEI: ㍻
 - SQUARE ERA NAME REIWA: 令和 (in a single glyph)

Display of the Reiwa square glyph is font-specific; it may show simply as a empty square or a square with hex characters. If that is the case, the unicode data supports the new character, but the selected font does not include the new glyph.

[Regression potential]
This is a potentially large change as it impacts font display, character sets as well as date conversions. As such, extreme care should be taken to ensure that regressions are avoided, such that dates previous to May 1, 2019 continue to display as before, and dates onward are displayed with the new era symbols. The included test cases account for verifying the continued behavior or previous dates.

There are mentions of Reiwa in icu in eoan. I'm not sure if this is a complete fix, since the code appears to have changed somewhat from the version of icu in Bionic and Disco.

Bionic certainly looks unfixed. Disco doesn't incldue the mentions of "reiwa" that are present in the eoan code base.

Changed in icu (Ubuntu):
status: New → Fix Released
tags: added: id-5d42faf102235814f5011aa4
Adolfo Jayme (fitojb) on 2019-08-13
Changed in icu (Ubuntu):
importance: Undecided → Medium
Changed in icu (Ubuntu Xenial):
importance: Undecided → Medium
Changed in icu (Ubuntu Bionic):
importance: Undecided → Medium
Changed in icu (Ubuntu Disco):
importance: Undecided → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers