libcurl-gnutls segfaults spotify client

Bug #1832882 reported by mrvanes on 2019-06-14
158
This bug affects 32 people
Affects Status Importance Assigned to Milestone
curl (Ubuntu)
High
Unassigned
Disco
High
Unassigned

Bug Description

The latest release of Spotify client segfaults in libcurl-gnutls as can be read in this thread on spotify support forum:
https://community.spotify.com/t5/Desktop-Linux/Ubuntu-19-04-deb-package-segfault/td-p/4761479

According to one participant the work-around is to install debian packages libgnutls30_3.6.8-1_amd64.deb and libcurl3-gnutls_7.64.0-3_amd64.deb

Ubuntu 19.04 version of the packages:
libgnutls30 3.6.5-2ubuntu1.1
libcurl3-gnutls 7.64.0-2ubuntu1.1

As the bug can be resolved by installing debian packages, I assume Ubuntu's version of the packages is at fault and should be upgraded to match debian's level as soon as possible.

meijer.o (meijer-o) wrote :

I can confirm this bug.

Installing libcurl3-gnutls_7.64.0-3_amd64.deb or loading the libraries of libcurl3-gnutls_7.64.0-3_amd64.deb from the Debian will solve the issue.

Dinand Mentink (k-mail-k) wrote :

Can confirm. Installing libcurl3-gnutls_7.64.0-3_amd64.deb and libgnutls30_3.6.8-1_amd64.deb from the debian repositories solves the issue on Ubuntu 19.04.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in curl (Ubuntu):
status: New → Confirmed
tags: added: rls-dd-incoming
Changed in curl (Ubuntu Disco):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

The spotify community post suggest using the snap as a workaround (which is a good idea since the snap is maintained by upstream directly and those are less likely to be impact by OS issues like that one)

Changed in curl (Ubuntu):
importance: Undecided → High
Changed in curl (Ubuntu Disco):
importance: Undecided → High
tags: added: rls-ee-incoming
Sebastien Bacher (seb128) wrote :

There is no stacktrace there but that new Debian revision fixes a segfault, so it's probably worth SRU that change
https://packages.qa.debian.org/c/curl/news/20190512T204836Z.html

damluk (damluk) wrote :

There is a stack trace mentioned in [1]. I got lucky and could reproduce almost all details of that trace with spotify-client [2]. Usually I get a trace where stream is NULL. The eoan version of libcurl3-gnutls fixes the issue for me as well.

[1] https://github.com/curl/curl/issues/3541
[2] https://pastebin.com/zsbu8bjU

tags: removed: rls-dd-incoming
Changed in curl (Ubuntu):
status: Confirmed → Fix Released
tags: removed: rls-ee-incoming
tags: added: id-5d14f42606a1fc59984d531b
Kevin Funk (kfunk) wrote :

Pardon my ignorance about the Launchpad bug metadata states, but: is there going to be an update for Ubuntu Disco fixing this issue?

grimpressive (grimpressive) wrote :

Can confirm the segfault.

Actually snap package is not a solution, it has a different behaviour with media keys (not working without an explicit mapping) that's why the deb package is preferrable.

Yoaat (yoaat) wrote :

I can confirm this issue as well.

Although for the workaround, libcurl3-gnutls_7.64.0-3 is no longer available from http://http.us.debian.org/debian/pool/main/c/curl/, but installing libcurl3-gnutls_7.64.0-4 works just as well.

ericc (eric-cheminot) wrote :

Using snap is not even always a possibility (besides other problems). See https://bugs.launchpad.net/snappy/+bug/1620771

Unfortunately, marked as "Won't fix".

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.