The option to select LTS notifications should be masked in non-LTS versions

Bug #1783328 reported by Chris Rainey on 2018-07-24
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
software-properties (Ubuntu)
Cosmic
Undecided
Unassigned
ubuntu-release-upgrader (Ubuntu)
Cosmic
Undecided
Łukasz Zemczak
update-manager (Ubuntu)
Medium
Łukasz Zemczak
Cosmic
Medium
Łukasz Zemczak

Bug Description

I have been bitten by _not_ knowing that selecting "Notify me of a new Ubuntu version: For long-term support versions" in a non-LTS(17.10) software-properties-gtk dialog box would simply silently fail to inform users that they are no longer receiving updates to their Ubuntu installs.

Please mask or hide the option to select "For long-term support versions" if the currently running version is a non-LTS version(grep or awk the /etc/os-release file or some-such for the LTS string).

It is non-intuitive to see this option as available to select and not receive warning of its hazards.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: ubuntu-release-upgrader-core 1:18.04.21
ProcVersionSignature: Ubuntu 4.15.0-29.31-generic 4.15.18
Uname: Linux 4.15.0-29-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
CrashDB: ubuntu
Date: Tue Jul 24 07:30:11 2018
InstallationDate: Installed on 2018-05-21 (64 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: ubuntu-release-upgrader
UpgradeStatus: No upgrade log present (probably fresh install)
mtime.conffile..etc.update-manager.release-upgrades: 2018-05-24T11:23:48.670462

Related branches

Chris Rainey (ckrzen) wrote :
tags: added: rls-cc-incoming
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in software-properties (Ubuntu):
status: New → Confirmed
Changed in ubuntu-release-upgrader (Ubuntu):
status: New → Confirmed
Brian Murray (brian-murray) wrote :

This was discussed in #ubuntu-meeting on 20180726 and the solution presented was to have the release upgrader do the "right" thing by upgrading your system until you hit an LTS. So if you are running zesty and have "Prompt=lts" set then it would upgrade you to artful, then bionic and then stop because bionic is an LTS release.

tags: removed: rls-cc-incoming
Download full text (3.1 KiB)

Thanks, Brian. That sounds reasonable and would---in fact, accomplish what
I _thought_ it was supposed to do when I was setting it on end-user
installs so that I could expose features and functionality of a non-LTS
version while assuming it would pause at the next LTS.

I appreciate you feedback. Any ideas when this might be implemented? Is
there a bug I can track to be notified of the functionality changes?

On Thu, Jul 26, 2018 at 11:51 AM Brian Murray <email address hidden> wrote:

> This was discussed in #ubuntu-meeting on 20180726 and the solution
> presented was to have the release upgrader do the "right" thing by
> upgrading your system until you hit an LTS. So if you are running zesty
> and have "Prompt=lts" set then it would upgrade you to artful, then
> bionic and then stop because bionic is an LTS release.
>
> ** Also affects: software-properties (Ubuntu Cosmic)
> Importance: Undecided
> Status: Confirmed
>
> ** Also affects: ubuntu-release-upgrader (Ubuntu Cosmic)
> Importance: Undecided
> Status: Confirmed
>
> ** Tags removed: rls-cc-incoming
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1783328
>
> Title:
> The option to select LTS notifications should be masked in non-LTS
> versions
>
> Status in software-properties package in Ubuntu:
> Confirmed
> Status in ubuntu-release-upgrader package in Ubuntu:
> Confirmed
> Status in software-properties source package in Cosmic:
> Confirmed
> Status in ubuntu-release-upgrader source package in Cosmic:
> Confirmed
>
> Bug description:
> I have been bitten by _not_ knowing that selecting "Notify me of a new
> Ubuntu version: For long-term support versions" in a non-LTS(17.10)
> software-properties-gtk dialog box would simply silently fail to
> inform users that they are no longer receiving updates to their Ubuntu
> installs.
>
> Please mask or hide the option to select "For long-term support
> versions" if the currently running version is a non-LTS version(grep
> or awk the /etc/os-release file or some-such for the LTS string).
>
> It is non-intuitive to see this option as available to select and not
> receive warning of its hazards.
>
> ProblemType: Bug
> DistroRelease: Ubuntu 18.04
> Package: ubuntu-release-upgrader-core 1:18.04.21
> ProcVersionSignature: Ubuntu 4.15.0-29.31-generic 4.15.18
> Uname: Linux 4.15.0-29-generic x86_64
> ApportVersion: 2.20.9-0ubuntu7.2
> Architecture: amd64
> CrashDB: ubuntu
> Date: Tue Jul 24 07:30:11 2018
> InstallationDate: Installed on 2018-05-21 (64 days ago)
> InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64
> (20180426)
> PackageArchitecture: all
> ProcEnviron:
> TERM=xterm-256color
> PATH=(custom, no user)
> LANG=en_US.UTF-8
> SHELL=/bin/bash
> SourcePackage: ubuntu-release-upgrader
> UpgradeStatus: No upgrade log present (probably fresh install)
> mtime.conffile..etc.update-manager.release-upgrades:
> 2018-05-24T11:23:48.670462
>
> To manage notifications about this bug go to:
>
> https://bugs.launchpad.net/ubuntu/+source/software-properties/+bug/1783328/+subs...

Read more...

tags: added: id-5b59f8e7d2955653d35919d8
Brian Murray (brian-murray) wrote :

This would actually need to be fixed in update-manager's UpdateManager/Core/MetaRelease.py around where the prompt checks are done.

Changed in ubuntu-release-upgrader (Ubuntu Cosmic):
status: Confirmed → Invalid
Changed in update-manager (Ubuntu Cosmic):
status: New → Triaged
importance: Undecided → Medium
Changed in update-manager (Ubuntu Cosmic):
assignee: nobody → Łukasz Zemczak (sil2100)
Changed in ubuntu-release-upgrader (Ubuntu Cosmic):
assignee: nobody → Łukasz Zemczak (sil2100)
Changed in software-properties (Ubuntu Cosmic):
status: Confirmed → Invalid
Changed in ubuntu-release-upgrader (Ubuntu Cosmic):
status: Invalid → In Progress
Changed in update-manager (Ubuntu Cosmic):
status: Triaged → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package update-manager - 1:18.10.4

---------------
update-manager (1:18.10.4) cosmic; urgency=medium

  [ Łukasz 'sil2100' Zemczak ]
  * Ignore Prompt=lts for non-LTS series. This way if a user is on a non-LTS
    and has Prompt=lts, he/she will be upgraded to the next supported series
    until finally reaching an LTS. (LP: #1783328)

 -- Brian Murray <email address hidden> Fri, 31 Aug 2018 15:38:33 -0700

Changed in update-manager (Ubuntu Cosmic):
status: In Progress → Fix Released
Changed in ubuntu-release-upgrader (Ubuntu Cosmic):
status: In Progress → Invalid
Chris Rainey (ckrzen) on 2018-09-28
no longer affects: software-properties (Ubuntu)
no longer affects: ubuntu-release-upgrader (Ubuntu)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers