CONFIG_CC_STACKPROTECTOR is now defined on Makefile

Bug #1776242 reported by Thadeu Lima de Souza Cascardo on 2018-06-11
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
QA Regression Testing
Undecided
Steve Beattie
linux (Ubuntu)
Status tracked in Cosmic
Cosmic
High
Steve Beattie

Bug Description

https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-cosmic-canonical-kernel-team-bootstrap/cosmic/amd64/l/linux/20180524_171024_2701c@/log.gz

15:41:48 ERROR| [stderr] CONFIG_CC_STACKPROTECTOR set ... FAIL

commit 2bc2f688fdf8808de4f36be563ccdb0bde7c0c54
    Makefile: move stack-protector availability out of Kconfig

+ ifndef stackp-broken
+ # If the stack protector is functional, enable code that depends on it.
+ KBUILD_CPPFLAGS += -DCONFIG_CC_STACKPROTECTOR
+ endif

Changed in linux (Ubuntu Cosmic):
assignee: nobody → Steve Beattie (sbeattie)

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1776242

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
Changed in linux (Ubuntu Cosmic):
status: Incomplete → Confirmed

Hi, Steve.

Can you take a look at this? The test needs to be updated to reflect the kconfig changes.

Thanks.
Cascardo.

Changed in linux (Ubuntu Cosmic):
importance: Undecided → High
Steve Beattie (sbeattie) on 2018-07-17
Changed in linux (Ubuntu Cosmic):
status: Confirmed → Invalid
Steve Beattie (sbeattie) wrote :

This was not an issue in the kernel; rather the qa-regression-testing script needed to take into account the auto-detection of the compiler's ability to perform stack protection and the restructuring of the config option due to that. I have fixed this in https://git.launchpad.net/qa-regression-testing/commit/?id=69b1392a208985e90857facbe367e3af635c8228 .

Unfortunately, it looks to change a bit again in the 4.18 kernel, but I think I have the checks set up to work properly when that lands as well.

Changed in qa-regression-testing:
assignee: nobody → Steve Beattie (sbeattie)
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers