ASUS GU501GM touchpad not detected

Bug #1770862 reported by wereturtle on 2018-05-12
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Status tracked in Cosmic
Cosmic
Medium
Unassigned

Bug Description

The touchpad on the new ASUS GU501GM (the junior Zephyrus M that is a Best Buy exclusive) does not seem to be detected whatsoever. Below is a printout of "xinput list". I've also attached output files for devices, dmesg, lspci -vnvn, Xorg.0.log, and version.log. I suspect it is an Elantech. I did manage to get one command to print ELAN120x (x being some number). Alas, I don't remember the command now, and none of what I've attached is showing it. (Sorry, I've had a long night of troubleshooting.) The Windows 10 device manager won't even list the brand, even though it's working there. Still, I am fairly confident it's Elan, as that's what ASUS seems to roll with these days.

I've tried various combinations of i8042.* kernel parameters, but to no avail. I've also tried blacklisting i2c_hid. It's like it thinks the touchpad is a keyboard? I'm on Ubuntu 18.04. I've tried the mainstream kernel 4.16.7, also to no avail. The latest release candidate (#4) for 4.17 would not let me log in past SDDM, and I noticed no touchpad miracle while I was in the SDDM login screen.

If you have any further suggestions of what I could try, I would very much appreciate it! Thanks in advance!

xinput list:

⎡ Virtual core pointer id=2 [master pointer (3)]
⎜ ↳ Virtual core XTEST pointer id=4 [slave pointer (2)]
⎜ ↳ ASUSTeK Computer Inc. N-KEY Device id=14 [slave pointer (2)]
⎜ ↳ Logitech USB Optical Mouse id=15 [slave pointer (2)]
⎣ Virtual core keyboard id=3 [master keyboard (2)]
    ↳ Virtual core XTEST keyboard id=5 [slave keyboard (3)]
    ↳ Power Button id=6 [slave keyboard (3)]
    ↳ Asus Wireless Radio Control id=7 [slave keyboard (3)]
    ↳ Video Bus id=8 [slave keyboard (3)]
    ↳ Video Bus id=9 [slave keyboard (3)]
    ↳ Power Button id=10 [slave keyboard (3)]
    ↳ Sleep Button id=11 [slave keyboard (3)]
    ↳ ASUSTeK Computer Inc. N-KEY Device id=12 [slave keyboard (3)]
    ↳ ASUSTeK Computer Inc. N-KEY Device id=13 [slave keyboard (3)]
    ↳ USB2.0 HD UVC WebCam: USB2.0 HD id=16 [slave keyboard (3)]
    ↳ Asus WMI hotkeys id=17 [slave keyboard (3)]
    ↳ AT Translated Set 2 keyboard id=18 [slave keyboard (3)]
    ↳ ASUSTeK Computer Inc. N-KEY Device id=19 [slave keyboard (3)]
---
ApportVersion: 2.20.9-0ubuntu7
Architecture: amd64
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: mustangsally 1416 F.... pulseaudio
CurrentDesktop: KDE
DistroRelease: Ubuntu 18.04
InstallationDate: Installed on 2018-05-12 (0 days ago)
InstallationMedia: Kubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
MachineType: ASUSTeK COMPUTER INC. ROG GU501GM
NonfreeKernelModules: nvidia_modeset nvidia
Package: linux (not installed)
ProcFB: 0 inteldrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-20-generic root=UUID=899a1b40-3034-4afc-9f21-299d52a753ab ro quiet splash i8042.noloop=1 i8042.nomux=1 i8042.kbdreset=1 i8042.reset vt.handoff=1
ProcVersionSignature: Ubuntu 4.15.0-20.21-generic 4.15.17
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-20-generic N/A
 linux-backports-modules-4.15.0-20-generic N/A
 linux-firmware 1.173
Tags: bionic
Uname: Linux 4.15.0-20-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip lpadmin plugdev sambashare sudo
_MarkForUpload: True
dmi.bios.date: 03/16/2018
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: GU501GM.301
dmi.board.asset.tag: ATN12345678901234567
dmi.board.name: GU501GM
dmi.board.vendor: ASUSTeK COMPUTER INC.
dmi.board.version: 1.0
dmi.chassis.asset.tag: No Asset Tag
dmi.chassis.type: 10
dmi.chassis.vendor: ASUSTeK COMPUTER INC.
dmi.chassis.version: 1.0
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvrGU501GM.301:bd03/16/2018:svnASUSTeKCOMPUTERINC.:pnROGGU501GM:pvr1.0:rvnASUSTeKCOMPUTERINC.:rnGU501GM:rvr1.0:cvnASUSTeKCOMPUTERINC.:ct10:cvr1.0:
dmi.product.family: ROG
dmi.product.name: ROG GU501GM
dmi.product.version: 1.0
dmi.sys.vendor: ASUSTeK COMPUTER INC.

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1770862

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected bionic
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
Joseph Salisbury (jsalisbury) wrote :

This issue appears to be an upstream bug, since you tested the latest upstream kernel. Would it be possible for you to open an upstream bug report[0]? That will allow the upstream Developers to examine the issue, and may provide a quicker resolution to the bug.

Please follow the instructions on the wiki page[0]. The first step is to email the appropriate mailing list. If no response is received, then a bug may be opened on bugzilla.kernel.org.

Once this bug is reported upstream, please add the tag: 'kernel-bug-reported-upstream'.

[0] https://wiki.ubuntu.com/Bugs/Upstream/kernel

Changed in linux (Ubuntu):
importance: Undecided → Medium
status: Confirmed → Triaged
wereturtle (wereturtle) on 2018-05-15
tags: added: kernel-bug-reported-upstream
wereturtle (wereturtle) wrote :

Attached is a zip containing updated dmesg and acpidump output against Kernel 4.17 RC5, per the upstream maintainer's request. It also contains other outputs (xinput, devices, Xorg.0.log, etc.) for said Kernel version.

Sheoak (sheoak) wrote :

I had this problem on the Zephyrus M GS501M, it suddenly disappeared. I'm not sure what fixed it but i suspect:

- Try going to the bios, disable and enable the trackpad again, save and retry. (do it even if it's already enable, it seems to fix a windows 10 bug with proprietary bios settings when using Rog Gaming Center).

- If it doesn't work, try installing the bios update via windows 10 if you have it in dual boot. For some reason this bios was only available on windows update and I could not download it from Asus website.

After doing this my trackpad start being detected and worked without any additionnal settings.

I have "acpi_osi=" in my kernel parameters otherwise I have hardware detection problems.
I use libinput 1.11.0-1 on arch linux, I haven't tested ubuntu yet.

BIOS Information
        Vendor: American Megatrends Inc.
        Version: GM501GS.303
        Release Date: 04/23/2018

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers