[SRU] Screen sharing panels abort using an non-existent vino gsettings key

Bug #1741027 reported by errors.ubuntu.com bug bridge on 2018-01-03
88
This bug affects 18 people
Affects Status Importance Assigned to Milestone
unity-control-center (Ubuntu)
High
Khurshid Alam
Bionic
High
Khurshid Alam
unity-settings-daemon (Ubuntu)
High
Khurshid Alam
Bionic
High
Khurshid Alam
vino (Ubuntu)
Low
Unassigned

Bug Description

*Impact

This happens because Gnome removed that particular gsettings key. The removal did not happen with the ui removal but rather much later than that. That is why it doesn't work with the latest version of vino.

As of now If users try to open the new sharing panel, unity-control-center will crash. This sort behavior is not desired on LTS release (18.04).

Test Case

1) Go to unity-control-center
2) Click sharing (Remote desktop)

* Regression potential

None

------------
The Ubuntu Error Tracker has been receiving reports about a problem regarding unity-control-center. This problem was most recently seen with package version 15.04.0+17.10.20171225-0ubuntu1, the problem page at https://errors.ubuntu.com/problem/be6d095e2145d77c79a6e47e17c94dfe70bcaa0a contains more details, including versions of packages affected, stacktrace or traceback, and individual crash reports.
If you do not have access to the Ubuntu Error Tracker and are a software developer, you can request it at http://forms.canonical.com/reports/.

Specifically, the error report

 "Settings schema 'org.gnome.Vino' does not contain a key named 'enabled' "

Related branches

summary: - /usr/bin/unity-control-
- center:5:g_settings_schema_get_value:g_settings_schema_key_init:g_settings_bind_with_mapping:cc_screen_sharing_panel_init:g_type_create_instance
+ screen sharing panels abort using an unexistant vino gsettings key
Changed in unity-control-center (Ubuntu):
importance: Undecided → High
Jeremy Bicha (jbicha) on 2018-01-26
description: updated
Changed in unity-control-center (Ubuntu):
status: New → Confirmed

This happens because Gnome removed that particular gsettings key. The removal did not happen with the ui removal but rather much later than that. That is why it doesn't work with the latest version of vino. I have prepared a small patch to restore that key. The key will be functional for unity session only and will not affect other sessions.

Khurshid Alam (khurshid-alam) wrote :

This is the patch. I expect Ubuntu to distro patch this only for 18.04 cycle.

Khurshid Alam (khurshid-alam) wrote :

This is the patch (updated). I expect Ubuntu to distro patch this only for 18.04 cycle.

The attachment "12_vino_unity.patch" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Sebastien Bacher (seb128) wrote :

Did Jeremy said he would sponsor that one? If not sponsors should be subscribed

Changed in vino (Ubuntu):
importance: Undecided → Low
assignee: nobody → Khurshid Alam (khurshid-alam)
Khurshid Alam (khurshid-alam) wrote :

No. Patching vino is not a good idea. I am porting sharing-panel from g-c-c.

Changed in unity-control-center (Ubuntu):
assignee: nobody → Khurshid Alam (khurshid-alam)
Changed in unity-settings-daemon (Ubuntu):
assignee: nobody → Khurshid Alam (khurshid-alam)
Changed in vino (Ubuntu):
assignee: Khurshid Alam (khurshid-alam) → nobody
Changed in unity-settings-daemon (Ubuntu):
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

That sounds a better solution indeed, closing the vino part of the bug

Changed in vino (Ubuntu):
status: New → Invalid
summary: - screen sharing panels abort using an unexistant vino gsettings key
+ [FFE] screen sharing panels abort using an unexistant vino gsettings key
description: updated
description: updated

OK from the release team POV providing you've tested it and it works.

DigiAngel (jlay) wrote :

Seeing the same here:

May 12 08:27:36 analysis unity-control-c[17749]: Settings schema 'org.gnome.Vino' does not contain a key named 'enabled'

Currently on latest Bionic

Zakhar (alainb06) wrote :

Here is an ugly 3 steps workaround:

-1) Edit the org.gnome.Vino schema to restore the missing "enabled" parameter (copying from 16.04)

sudo nano /usr/share/glib-2.0/schemas/org.gnome.Vino.gschema.xml

Add this key:
    <key name='enabled' type='b'>
      <summary>Enable remote access to the desktop</summary>
      <description>
        If true, allows remote access to the desktop via the RFB
        protocol. Users on remote machines may then connect to the
        desktop using a VNC viewer.
      </description>
      <default>false</default>
    </key>

-2) Compile the schemas for Gnome:

sudo glib-compile-schemas /usr/share/glib-2.0/schemas

-3) Now the screen sharing panel in unity-control-center works... but this is not enough to get vino running! So you need to add in the programs at session start: Vino-server with the following command line:

/usr/lib/vino/vino-server

Now you can VNC your 18.04-Unity!

summary: - [FFE] screen sharing panels abort using an unexistant vino gsettings key
+ screen sharing panels abort using an unexistant vino gsettings key
summary: - screen sharing panels abort using an unexistant vino gsettings key
+ Screen sharing panels abort using an non-existent vino gsettings key
summary: - Screen sharing panels abort using an non-existent vino gsettings key
+ [FFE] Screen sharing panels abort using an non-existent vino gsettings
+ key
tags: added: cosmic ffe
removed: bionic

I'm confused. Is this patch rolled out? I'm getting this issue. Has it really been impossible to VNC into an upgraded Ubuntu for over eight months?

Changed in unity-control-center (Ubuntu):
status: Confirmed → In Progress
Changed in unity-settings-daemon (Ubuntu):
status: Confirmed → In Progress
Changed in unity-settings-daemon (Ubuntu):
importance: Undecided → High
Khurshid Alam (khurshid-alam) wrote :

To Ubuntu Release Team,

Hi,

I have tested this back and forth and confirm that it works in cosmic.

This is a major bug which affects all the unity users. In previous cycle, Laney from release team approved it (see above comment). But it didn't go through. This cycle Trevinho from desktop team reviewed it and approved it, but he didn't have upload rights. I was told by Laney to comment here & set the bug status to new.

Please review and upload it before the release of 18.10 if possible.

Thanks.

PPA: unity7maintainers/unity7-desktop

Testing: https://community.ubuntu.com/t/testing-of-sharing-panel-in-u-c-c-bionic/4215

Changed in unity-control-center (Ubuntu):
status: In Progress → New
Changed in unity-settings-daemon (Ubuntu):
status: In Progress → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity-control-center (Ubuntu):
status: New → Confirmed
Changed in unity-settings-daemon (Ubuntu):
status: New → Confirmed
summary: - [FFE] Screen sharing panels abort using an non-existent vino gsettings
- key
+ Screen sharing panels abort using an non-existent vino gsettings key
tags: added: disco
removed: cosmic

Still an issue here on 18.04 ... Tried the PPA ppa:unity7maintainers/unity7-desktop by curiosity... but this is loaded with crippling bugs that render it unusable and does not have the desktop sharing icon anymore.

The workaround from comment number 11, from Zakhar (alainb06) worked for me:

Direct link: https://bugs.launchpad.net/ubuntu/+source/unity-control-center/+bug/1741027/comments/11

Khurshid Alam (khurshid-alam) wrote :

I can't reproduce the problem on 18.04. Sharing-Panel now appears under system. See https://community.ubuntu.com/t/testing-of-sharing-panel-in-u-c-c-bionic/4215/

AndrewDucker (andrew-ducker) wrote :

Still an issue for me. Software Updater says no further updates currently available.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-control-center - 15.04.0+19.04.20181122-0ubuntu1

---------------
unity-control-center (15.04.0+19.04.20181122-0ubuntu1) disco; urgency=medium

  [ Khurshid Alam ]
  * Import sharing panel from gnome-control-center (LP: #1741027)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Thu, 22 Nov 2018 00:22:16 +0000

Changed in unity-control-center (Ubuntu):
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity-settings-daemon - 15.04.1+19.04.20181122-0ubuntu1

---------------
unity-settings-daemon (15.04.1+19.04.20181122-0ubuntu1) disco; urgency=medium

  [ Khurshid Alam ]
  * Add sharing plugin (LP: #1741027)

 -- Marco Trevisan (Treviño) <mail@3v1n0.net> Thu, 22 Nov 2018 00:21:48 +0000

Changed in unity-settings-daemon (Ubuntu):
status: Confirmed → Fix Released
AndrewDucker (andrew-ducker) wrote :

Has this been pushed out to 18.04 LTS users?

I'm not seeing any updates available, but it's still crashing on launch of the Desktop Sharing from the System Settings.

tags: added: rls-bb-incoming
summary: - Screen sharing panels abort using an non-existent vino gsettings key
+ [SRU] Screen sharing panels abort using an non-existent vino gsettings
+ key
description: updated
description: updated
tags: added: verification-needed
Ninad (ninadm) wrote :

When can we expect this fix to be back-ported to 18.04?

Khurshid Alam (khurshid-alam) wrote :

@Ninad

It needs to be sponsored (who has merge access) for 18.04. I have asked in the mailing list here https://lists.launchpad.net/unity7maintainers/msg00026.html, You can also ask in #ubuntu-desktop on irc.freenode.net but be polite. Meanwhile you can use unity-7 maintainers PPA.

Gunnar Hjalmarsson (gunnarhj) wrote :

@Khurshid:

Maybe I'm missing something, but to me these desired 18.04 uploads don't seem to be very sponsor friendly.

* I see a 18.04 repository for unity-control-center (just created a
  link to it), but it does not seem to include the changelog update.

* As regards unity-settings-daemon I see neither a repository nor
  debdiff for 18.04. So what is there to sponsor?

* No bionic bug tasks - I just added those.

Once it's clear what the desired uploads are, I think you should subscribe ubuntu-sponsors so this bug gets listed here:

http://reqorts.qa.ubuntu.com/reports/sponsoring/

no longer affects: vino (Ubuntu Bionic)
Changed in unity-control-center (Ubuntu Bionic):
assignee: nobody → Khurshid Alam (khurshid-alam)
importance: Undecided → High
status: New → In Progress
Changed in unity-settings-daemon (Ubuntu Bionic):
assignee: nobody → Khurshid Alam (khurshid-alam)
importance: Undecided → High
status: New → In Progress
Ninad (ninadm) wrote :

Thanks Khurshid and Gunnar.
Hi Khurshid, can you help provide the details per comment #24 to proceed further?

Khurshid Alam (khurshid-alam) wrote :

@Gunnar

Sorry I was not available in previous week.

It seems u-c-c part was already merged https://bazaar.launchpad.net/~unity-control-center-team/unity-control-center/18.04/revision/12913

The issue is unity-settings-daemon doesn't have any 18.04 branch. Can you create that branch ? Then I will open a merge for that branch.

Once it gets merged in 18.04 branch, it can be released.

Thanks.

tags: removed: rls-bb-incoming
Gunnar Hjalmarsson (gunnarhj) wrote :

@Khurshid: My turn to be late..

Yes, the u-c-c part is merged, but it's not uploaded. Some sponsor needs to do that - maybe they can pick the changelog entry from disco:

https://launchpad.net/ubuntu/+source/unity-control-center/15.04.0+19.04.20181122-0ubuntu1

I don't have access to anything Unity. But I would suggest that you skip the branch and simply prepare a debdiff on top of the uploaded unity-settings-daemon bionic source. A sponsor can then upload the debdiff.

Jarek Gołębiowski (jarekgol) wrote :

I've got same problem at 18.04 with Unity and I confirm that #11 helped.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.