dep8/lxd: test fails due to unrelated message to stderr

Bug #1825968 reported by Stefan Bader on 2019-04-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubuntu-fan (Ubuntu)
Medium
Stefan Bader
Xenial
Medium
Unassigned
Bionic
Medium
Unassigned

Bug Description

[SRU Justification]

== Impact ==
The LXD DEP8 test fails because of an unrelated message to stderr during containser setup (sd_bus_open_system: No such file or directory Exit request sent.). The test itself successfully runs to completion.

== Fix ==
Change the test control to ignore messages on stderr sicne the test itself should exit with a non-zero return code if some test error happens.

== Testcase ==
ADT testing

== Risk of Regression ==
None, no code change, only DEP8 testing modified

Stefan Bader (smb) on 2019-04-23
Changed in ubuntu-fan (Ubuntu Xenial):
importance: Undecided → Medium
status: New → Triaged
Changed in ubuntu-fan (Ubuntu Bionic):
importance: Undecided → Medium
status: New → Triaged
Changed in ubuntu-fan (Ubuntu):
status: In Progress → Fix Released

Hello Stefan, or anyone else affected,

Accepted ubuntu-fan into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/ubuntu-fan/0.12.8~16.04.3 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in ubuntu-fan (Ubuntu Xenial):
status: Triaged → Fix Committed
tags: added: verification-needed verification-needed-xenial
Stefan Bader (smb) wrote :

Since the only change was a modification to dep8 tests, there is nothing else to validate than the successful pass of all arches in xenial (http://autopkgtest.ubuntu.com/packages/u/ubuntu-fan).

tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubuntu-fan - 0.12.8~16.04.3

---------------
ubuntu-fan (0.12.8~16.04.3) xenial; urgency=medium

  * dep8: Allow output on stderr without failing (LP: #1825968)

 -- Stefan Bader <email address hidden> Tue, 23 Apr 2019 12:37:17 +0200

Changed in ubuntu-fan (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for ubuntu-fan has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers