Screensaver is not disabled during install

Bug #1814875 reported by Will Cooke
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Fix Released
Medium
Iain Lane
Bionic
Triaged
Medium
Iain Lane

Bug Description

I was running the screenreader desktop ISO tests and while the install was progressing the screen blanked and locked.

This meant that when the install was complete the screenreader didnt tell me and so I had no way of knowing what was going on.

Speaking to Laney about this, the code which previously disabled the screensaver needed updating to work with different gsettings keys.

Related branches

Will Cooke (willcooke)
Changed in ubiquity (Ubuntu):
status: New → Confirmed
Revision history for this message
Iain Lane (laney) wrote :

thanks, once the disco merge request is reviewed and in, we can look at backporting

Changed in ubiquity (Ubuntu Bionic):
assignee: nobody → Iain Lane (laney)
Changed in ubiquity (Ubuntu):
assignee: nobody → Iain Lane (laney)
Changed in ubiquity (Ubuntu Bionic):
status: New → Confirmed
Changed in ubiquity (Ubuntu):
importance: Undecided → Medium
Changed in ubiquity (Ubuntu Bionic):
importance: Undecided → Medium
Changed in ubiquity (Ubuntu):
status: Confirmed → Triaged
Changed in ubiquity (Ubuntu Bionic):
status: Confirmed → Triaged
Revision history for this message
Iain Lane (laney) wrote :

ubiquity (19.04.6) disco; urgency=medium

  * Automatic update of included source packages: user-setup
    1.63ubuntu6.
  * gtk: Disable screen blanking for Shell.
    With the switch to GNOME Shell, we're no longer using GNOME Screensaver
    to handle blanking the screen. Setting the `idle-delay' to 0 disables
    this for Shell.
  * gtk, kde: Don't allow going back once we are anywhere past partitioning.
    The effect of this is that proceeding backwards from usersetup to
    timezone is not permitted any more. This is a harmful thing to be able
    to do because the timezone step 'resets' debconf after it finishes, and
    this might break an ongoing installation.
    https://bugs.launchpad.net/ubuntu/+source/ubiquity/+bug/1799097

 -- Iain Lane <email address hidden> Thu, 28 Feb 2019 10:59:39 +0000

Changed in ubiquity (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers