OEM switch to end user results in wifi not being available.

Bug #1665384 reported by Dave Morley
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
ubiquity (Ubuntu)
Fix Released
Medium
Dimitri John Ledkov
Xenial
New
Undecided
Unassigned
Bionic
New
Undecided
Unassigned
Focal
New
Undecided
Unassigned

Bug Description

STEPS:
1. Grab the latest xenial iso from http://cdimages.ubuntu.com/xenial/daily-live/current/
2. Install in oem mode
3. In the OEM desktop double click on Prepare for end user type in your password and reboot
4. Run through the end user wizard setting up wifi as you go
5. Login to the end user session
6. Note the empty Wifi symbol in indicator
7. Run nmcli d and see something like
DEVICE TYPE STATE CONNECTION
enp3s0 ethernet Unavailable --
wlo1 wifi Unavailable --
lo loopback Unmanagaed --

WORKAROUND:
reboot
After reboot everything works as expected and the system autoconnects as expected.

Tags: iso-testing
Revision history for this message
Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/1665384

tags: added: iso-testing
Revision history for this message
Mathieu Trudel-Lapierre (cyphermox) wrote :

This is most likely a ubiquity bug; where the connection is created with the wrong permission settings.

affects: network-manager (Ubuntu) → ubiquity (Ubuntu)
Changed in ubiquity (Ubuntu):
assignee: nobody → Mathieu Trudel-Lapierre (cyphermox)
status: New → Triaged
importance: Undecided → Medium
Changed in ubiquity (Ubuntu):
assignee: Mathieu Trudel-Lapierre (cyphermox) → Dimitri John Ledkov (xnox)
Changed in ubiquity (Ubuntu):
status: Triaged → Fix Committed
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package ubiquity - 20.10.11

---------------
ubiquity (20.10.11) groovy; urgency=medium

  [ Jean-Baptiste Lallement ]
  * Remove popularity-contest.
  * Initialize text variables to fix crash in OEM mode (LP: #1898029)

  [ Sebastien Bacher ]
  * Updated translations (LP: #1897444)

  [ Dimitri John Ledkov ]
  * oem-config.target: Correct name of the NetworkManager.service unit
    (LP: #1665384)
  * localechooser.patch: set my (Burmese) as the default Myanmar language.
    (LP: #1872186)

 -- Dimitri John Ledkov <email address hidden> Wed, 14 Oct 2020 13:18:26 +0100

Changed in ubiquity (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers