Smokeping 2.6.11-4 probe FPing is not compatible with fping 4.0 when setting sourceaddress option.

Bug #1749942 reported by xavier
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
smokeping (Ubuntu)
Low
Unassigned
Bionic
Low
Unassigned

Bug Description

Smokeping 2.6.11-4 probe FPing is not compatible with fping 4.0 when setting sourceaddress option.

It happens because the '-S' option is expecting the 3.13 help output but it has changed in 4.0.

In smokeping version 2.7.1 the '-S' option checking has changed to be compatible with 3.13 and 4.0.

Version 2.6.11 (FPing.pm line 70)
        $self->{enable}{S} = (`$binary -h 2>&1` =~ /\s-S\s/);
Version 2.7.1 (FPing.pm line 70)
        $self->{enable}{S} = (`$binary -h 2>&1` =~ /\s-S[,\s]/);

It also affects to other options like '-O'.

Reported in 2017-June in Smokeping github (https://github.com/oetiker/SmokePing/issues/90)

I propose to update Smokeping to version 2.7.1.

xavier (xavier-o)
description: updated
xavier (xavier-o)
description: updated
Revision history for this message
Gabriel Filion (gabriel-filion) wrote :

Hi there!

I've recently started co-maintaining the smokeping package in debian with Antoine Beaupré and I've worked on updating the package to 2.7.3.

it was recently brought to my attention (on the smokeping users mailing list) that this bug existed in the ubuntu version of smokeping. This bug is specific to bionic (at least in terms of ubuntu LTS releases) because the version of smokeping shipped in bionic is not compatible with the version of fping.

I've written a fix for upstream that was merged before 2.7.3 was released, and so I believe that by cherry-picking this patch we'd be fixing the issue for ubuntu.

The patch in question is here:

https://github.com/oetiker/SmokePing/commit/681457d0872057f79e2b2f97fa6ff8b6b415b48c

I'm currently trying to figure out how to produce a debdiff for easier consumption by someone that can push a change to ubuntu. If I don't send a debdiff this week-end though and someone is able to easily integrate the above patch in the package, then please do go ahead and don't wait for my input! I'll try and do my best to format this during the week-end though.

Revision history for this message
Gabriel Filion (gabriel-filion) wrote :

Oh.. actually to completely fix smokeping's compatibility with smokeping we need also a second patch (which is actually addressing the original bug report *harrumpf*).

Tobias, the upstream author fixed compatibility for the -O and -S options in the following patch, so it also needs to be included:

https://github.com/oetiker/SmokePing/commit/72ed1570fbb4ae0b90846625e1a3bd5d2bade531

Revision history for this message
Gabriel Filion (gabriel-filion) wrote :

Here's (attached) my first attempt at the debdiff thing. I'm hoping that I did this correctly but I'm not used to this process so please tell me if I need to correct some aspect of it.

Revision history for this message
Gabriel Filion (gabriel-filion) wrote :

oops. seems like I based my changes on the wrong package version. bionic has 2.6.11-4, not -2

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "Import two compatibility patches for fping 4.0" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Revision history for this message
Gabriel Filion (gabriel-filion) wrote :

ook, 2nd trial. I've reapplied the same changes on the right version this time. so smokeping 2.6.11-4

I've allowed dch to make it version -4.1 since it's a divergence from -4 but -5 has already been released and is different. however, I don't know if this respects ubuntu's version numbering policy. please advise if I need to change this -- or even better, change the version number without my intervention :)

Mathew Hodson (mhodson)
Changed in smokeping (Ubuntu):
importance: Undecided → Low
Changed in smokeping (Ubuntu Bionic):
importance: Undecided → Low
Changed in smokeping (Ubuntu):
status: New → Fix Released
tags: added: patch-accepted-upstream
removed: fping smokeping
Revision history for this message
Simon Quigley (tsimonq2) wrote :

Hello Gabriel, thanks for your work on this bug!

There are two points that need to be looked at prior to this change being sponsored. Since you asked about the version number, I will point you at the standard for versions in stable releases: https://wiki.ubuntu.com/SecurityTeam/UpdatePreparation#Update_the_packaging

The second of which is that the bug description must be updated to follow the template for Stable Release Updates. You can find that here: https://wiki.ubuntu.com/StableReleaseUpdates#SRU_Bug_Template

I am unsubscribing the Ubuntu Sponsors Team; please resubscribe the team when those two points are dealt with.

Thanks again!

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in smokeping (Ubuntu Bionic):
status: New → Confirmed
Revision history for this message
Logan V (loganv) wrote :

Bionic currently has fping 4.0-6 and smokeping 2.6.11-4. So unfortunately the buggy smokeping version combined with the more recent fping version break smokeping's detection:

"FPing: WARNING: your fping binary doesn't support source address setting (-S), I will ignore any sourceaddress configurations - see http://bugs.debian.org/198486."

How can we get this fix released into an updated smokeping package for Bionic so it can work correctly with fping?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.