Recognize NVMe devices

Bug #1742787 reported by dann frazier on 2018-01-11
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
parted (Debian)
Fix Released
Unknown
parted (Ubuntu)
Undecided
dann frazier
Xenial
Undecided
Unassigned
Zesty
Undecided
Unassigned
Artful
Undecided
Unassigned
Bionic
Undecided
dann frazier

Bug Description

[Impact]
parted reports NVMe devices as "Unknown", which propagates up to d-i:

  ┌────────────────────────┤ [!!] Partition disks ├─────────────────────────┐
  │ │
  │ Note that all data on the disk you select will be erased, but not │
  │ before you have confirmed that you really want to make the changes. │
  │ │
  │ Select disk to partition: │
  │ │
  │ /dev/nvme0n1 - 450.1 GB Unknown │
  │ SCSI1 (0,0,0) (sdi) - 240.1 GB ATA INTEL SSDSC2BB24 │
  │ SCSI3 (0,0,0) (sdj) - 800.2 GB ATA SDLFOCAM-800G-1H │
  │ │
  │ <Go Back> │
  │ │
  └─────────────────────────────────────────────────────────────────────────┘

While d-i works fine with this device as-is, the "Unknown" string is a source of consternation with some users who aren't sure if NVMe is supported.

[Test Case]
Current:
$ sudo parted -s /dev/nvme0n1 p
Model: Unknown
Disk /dev/nvme0n1: 512GB
[...]

Expected:
$ sudo parted -s /dev/nvme0n1 p
Model: NVMe Device (nvme)
Disk /dev/nvme0n1: 512GB
[...]

[Regression Risk]
There maybe user code out there relying on the existing "Unknown" output.

Changed in parted (Debian):
status: Unknown → New
dann frazier (dannf) on 2018-01-12
Changed in parted (Ubuntu Bionic):
status: New → In Progress
assignee: nobody → dann frazier (dannf)
dann frazier (dannf) on 2018-01-12
description: updated

Hello dann, or anyone else affected,

Accepted parted into artful-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/parted/3.2-18ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-artful to verification-done-artful. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-artful. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in parted (Ubuntu Artful):
status: New → Fix Committed
tags: added: verification-needed verification-needed-artful
Changed in parted (Ubuntu Zesty):
status: New → Won't Fix
Changed in parted (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed-xenial
Łukasz Zemczak (sil2100) wrote :

Hello dann, or anyone else affected,

Accepted parted into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/parted/3.2-15ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Simon Déziel (sdeziel) wrote :

Verified on Xenial with parted 3.2-15ubuntu0.1:

$ sudo parted -s /dev/nvme0n1 p | head -n1
Model: NVMe Device (nvme)

tags: added: verification-done-xenial
removed: verification-needed-xenial
dann frazier (dannf) wrote :

artful verification:

ubuntu@d05-6:~$ sudo parted -s /dev/nvme0n1 p
Error: /dev/nvme0n1: unrecognised disk label
Model: Unknown (unknown)
Disk /dev/nvme0n1: 1600GB
Sector size (logical/physical): 512B/512B
Partition Table: unknown
Disk Flags:
ubuntu@d05-6:~$ sudo apt install parted
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following additional packages will be installed:
  libparted2
Suggested packages:
  libparted-dev libparted-i18n parted-doc
The following packages will be upgraded:
  libparted2 parted
2 upgraded, 0 newly installed, 0 to remove and 29 not upgraded.
Need to get 142 kB of archives.
After this operation, 0 B of additional disk space will be used.
Do you want to continue? [Y/n]
Get:1 http://ports.ubuntu.com/ubuntu-ports artful-proposed/main arm64 parted arm64 3.2-18ubuntu0.1 [37.4 kB]
Get:2 http://ports.ubuntu.com/ubuntu-ports artful-proposed/main arm64 libparted2 arm64 3.2-18ubuntu0.1 [104 kB]
Fetched 142 kB in 0s (434 kB/s)
(Reading database ... 67864 files and directories currently installed.)
Preparing to unpack .../parted_3.2-18ubuntu0.1_arm64.deb ...
Unpacking parted (3.2-18ubuntu0.1) over (3.2-18) ...
Preparing to unpack .../libparted2_3.2-18ubuntu0.1_arm64.deb ...
Unpacking libparted2:arm64 (3.2-18ubuntu0.1) over (3.2-18) ...
Setting up libparted2:arm64 (3.2-18ubuntu0.1) ...
Setting up parted (3.2-18ubuntu0.1) ...
Processing triggers for libc-bin (2.26-0ubuntu2) ...
Processing triggers for man-db (2.7.6.1-2) ...
ubuntu@d05-6:~$ sudo parted -s /dev/nvme0n1 p
Error: /dev/nvme0n1: unrecognised disk label
Model: NVMe Device (nvme)
Disk /dev/nvme0n1: 1600GB
Sector size (logical/physical): 512B/512B
Partition Table: unknown
Disk Flags:

tags: added: verification-done verification-done-artful
removed: verification-needed verification-needed-artful
Changed in parted (Debian):
status: New → Fix Released
dann frazier (dannf) on 2018-01-24
Changed in parted (Ubuntu Bionic):
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package parted - 3.2-20

---------------
parted (3.2-20) unstable; urgency=medium

  * Amend patches added in 3.2-19 to include corresponding patches to files
    generated by "make dist".

 -- Colin Watson <email address hidden> Wed, 17 Jan 2018 01:43:32 +0000

Changed in parted (Ubuntu Bionic):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package parted - 3.2-18ubuntu0.1

---------------
parted (3.2-18ubuntu0.1) artful; urgency=medium

  * Cherry-pick upstream patch to add support NVMe devices (LP: #1742787).

 -- dann frazier <email address hidden> Fri, 12 Jan 2018 15:57:05 -0700

Changed in parted (Ubuntu Artful):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for parted has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Łukasz Zemczak (sil2100) wrote :

For xenial it seems that the udisks2 autopkgtest seems to be constantly failing for this package for s390x. To make sure it's not a regression caused by the parted landing, I have run a no-trigger autopkgtest for this architecture. This way we'll see if the package is also failing with the current state of xenial on s390x.

http://autopkgtest.ubuntu.com/packages/u/udisks2/xenial/s390x

Łukasz Zemczak (sil2100) wrote :

Confirmed the test is failing for release xenial. Releasing as is.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package parted - 3.2-15ubuntu0.1

---------------
parted (3.2-15ubuntu0.1) xenial; urgency=medium

  * Cherry-pick upstream patch to add support NVMe devices (LP: #1742787).

 -- dann frazier <email address hidden> Fri, 12 Jan 2018 16:21:42 -0700

Changed in parted (Ubuntu Xenial):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.