'nm' autopkgtest fails due to GI stderr output

Bug #1825946 reported by Dan Streetman on 2019-04-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
network-manager (Ubuntu)
Undecided
Unassigned
Xenial
Low
Unassigned
Bionic
Low
Till Kamppeter

Bug Description

[impact]

'nm' testcase contains:
from gi.repository import NetworkManager, NMClient, GLib

which generates output to stderr:
/tmp/autopkgtest.naU0ts/build.riU/src/debian/tests/nm:23: PyGIWarning: NetworkManager was imported without specifying a version first. Use gi.require_version('NetworkManager', '1.0') before import to ensure that the right version gets loaded.

the gi.require_version call has already been added to cosmic and disco.

[test case]

see http://autopkgtest.ubuntu.com/packages/network-manager bionic test results.

[other info]

this only fails intermittently, but the failure is clearly not an actual problem.

Dan Streetman (ddstreet) on 2019-04-23
Changed in network-manager (Ubuntu):
status: New → Fix Released
Changed in network-manager (Ubuntu Xenial):
status: New → In Progress
Changed in network-manager (Ubuntu Bionic):
status: New → In Progress
Changed in network-manager (Ubuntu Xenial):
importance: Undecided → Low
Changed in network-manager (Ubuntu Bionic):
importance: Undecided → Low
Changed in network-manager (Ubuntu Xenial):
assignee: nobody → Dan Streetman (ddstreet)
Changed in network-manager (Ubuntu Bionic):
assignee: nobody → Dan Streetman (ddstreet)
Dan Streetman (ddstreet) on 2019-05-13
Changed in network-manager (Ubuntu Bionic):
assignee: Dan Streetman (ddstreet) → Till Kamppeter (till-kamppeter)
Changed in network-manager (Ubuntu Xenial):
assignee: Dan Streetman (ddstreet) → nobody
Changed in network-manager (Ubuntu Bionic):
status: In Progress → Fix Committed
Changed in network-manager (Ubuntu Xenial):
assignee: nobody → Till Kamppeter (till-kamppeter)
Dan Streetman (ddstreet) on 2019-05-13
Changed in network-manager (Ubuntu Xenial):
assignee: Till Kamppeter (till-kamppeter) → Dan Streetman (ddstreet)
Till Kamppeter (till-kamppeter) wrote :

network-manager 1.10.14-0ubuntu2 witrh the fix for this bug got transferred to bionic-updates. Thanks to the SRU team for the great cooperation.

Changed in network-manager (Ubuntu Bionic):
status: Fix Committed → Fix Released
Till Kamppeter (till-kamppeter) wrote :

Dan, if you are on it, preparing a network-manager SRU for Xenial, could you also add the patch which fixes bug 1754671? Here we also need a network-manager SRU for.

Dan Streetman (ddstreet) wrote :

> could you also add the patch which fixes bug 1754671

Can you create a debdiff? It's not clear to me which patch, exactly, fixes that bug; the upload containing the fix contains a large amount of changes.

Dan Streetman (ddstreet) on 2019-05-25
Changed in network-manager (Ubuntu Xenial):
assignee: Dan Streetman (ddstreet) → nobody
status: In Progress → New
Dan Streetman (ddstreet) wrote :

A fix for this was added for bionic at version 1.10.14-0ubuntu2, but that was reverted due to regressions, so this is not yet fixed in bionic-updates

Changed in network-manager (Ubuntu Bionic):
status: Fix Released → In Progress

Hello Dan, or anyone else affected,

Accepted network-manager into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager/1.10.6-2ubuntu1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in network-manager (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic

All autopkgtests for the newly accepted network-manager (1.10.6-2ubuntu1.2) for bionic have finished running.
The following regressions have been reported in tests triggered by the package:

network-manager/1.10.6-2ubuntu1.2 (amd64, arm64, i386, ppc64el)
systemd/237-3ubuntu10.31 (i386, ppc64el)
netplan.io/0.98-0ubuntu1~18.04.1 (arm64)

Please visit the excuses page listed below and investigate the failures, proceeding afterwards as per the StableReleaseUpdates policy regarding autopkgtest regressions [1].

https://people.canonical.com/~ubuntu-archive/proposed-migration/bionic/update_excuses.html#network-manager

[1] https://wiki.ubuntu.com/StableReleaseUpdates#Autopkgtest_Regressions

Thank you!

Dan Streetman (ddstreet) wrote :

nm test no longer fails due to stderr output as listed in description. nm test does now fail due to the test thinking dnsmasq is not available, but that's a separate bug.

tags: added: verification-done verification-done-bionic
removed: verification-needed verification-needed-bionic
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package network-manager - 1.10.6-2ubuntu1.2

---------------
network-manager (1.10.6-2ubuntu1.2) bionic; urgency=medium

  [ Till Kamppeter ]
  * debian/tests/nm: Add gi.require_version() calls for NetworkManager
    and NMClient to avoid stderr output which fails the test. (LP: #1825946)

  [ Dariusz Gadomski ]
  * d/p/fix-dns-leak-lp1754671.patch: backport of DNS leak fix. (LP: #1754671)
  * d/p/lp1790098.patch: retry activating devices when the parent becomes
    managed. (LP: #1790098)

 -- Dariusz Gadomski <email address hidden> Sat, 07 Sep 2019 16:10:59 +0200

Changed in network-manager (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for network-manager has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Dan Streetman (ddstreet) wrote :

> nm test no longer fails due to stderr output as listed in description. nm
> test does now fail due to the test thinking dnsmasq is not available, but
> that's a separate bug.

For this I opened bug 1850267

Dan Streetman (ddstreet) on 2019-12-06
tags: added: block-proposed-xenial

Hello Dan, or anyone else affected,

Accepted network-manager into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/network-manager/1.2.6-0ubuntu0.16.04.4 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in network-manager (Ubuntu Xenial):
status: New → Fix Committed
tags: added: verification-needed verification-needed-xenial
removed: verification-done
Dan Streetman (ddstreet) wrote :
tags: added: verification-done verification-done-xenial
removed: verification-needed verification-needed-xenial
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers