Kodi crashes with “nouveau_vp3_video_buffer_create: Assertion `templat->interlaced' failed”

Bug #1836979 reported by Tina Russell on 2019-07-18
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
mesa (Ubuntu)
Undecided
Unassigned
Bionic
High
Timo Aaltonen

Bug Description

Buggy as Kodi is, this seems to be a problem specifically with mesa-va-drivers.

Kodi has worked just fine on my system, as recently as July 6th of this year, but yesterday (July 16) I tried Kodi again: I got a blank screen and a pause for a few moments, followed by an unceremonious crash-to-desktop. This happens every time I start Kodi, now.

If I run it through the command-line, I get this:

libva info: VA-API version 1.1.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/nouveau_drv_video.so
libva info: Found init function __vaDriverInit_1_1
libva info: va_openDriver() returns 0
kodi-x11: ../src/gallium/drivers/nouveau/nouveau_vp3_video.c:91: nouveau_vp3_video_buffer_create: Assertion `templat->interlaced' failed.
Aborted (core dumped)

I’ve been using the same version of Kodi (“18.3 Git:20190621-89472b7”, package version 2:18.3+git20190621.1610-final-0bionic, from the Team-XBMC PPA) since its release in June, but in between July 6th and 16th, I did upgrade the Mesa packages, from 18.2.8-0ubuntu0~18.04.2 19.0.2-1ubuntu1.1~18.04.1. If I downgrade the “mesa-va-drivers” package to 18.0.0~rc5-1ubuntu1 (the version in the base, non-updates Bionic repository), however, Kodi works again, without even requiring me to restart my machine. So, this is likely a problem with “mesa-va-drivers”.

I tried looking in Xorg.0.log:

[ 17185.557] (II) NOUVEAU(0): EDID vendor "SEC", prod id 12620
[ 17185.557] (II) NOUVEAU(0): Printing DDC gathered Modelines:
[ 17185.558] (II) NOUVEAU(0): Modeline "1366x768"x0.0 72.33 1366 1414 1446 1526 768 770 775 790 -hsync -vsync (47.4 kHz eP)

…that’s all that appears in the log when I try to load Kodi and a crash happens.

I’m using Ubuntu MATE 18.04.2 LTS 64-bit on a Compaq Presario CQ60; if you need more information, I’ve attached a hardinfo report, too. I hope this bug can get fixed, soon. Thanks!

Tina Russell (tinarussell) wrote :
description: updated
description: updated
description: updated
description: updated
Tina Russell (tinarussell) wrote :

There was an update to Mesa over in the Ubuntu-X-Swat PPA today (by which I mean the “Updates” one), from 19.0.2-1ubuntu1.1~18.04.1 to 19.0.8-0ubuntu0~18.04.1. …Sadly, as I discovered—after installing the updates, then restarting and trying Kodi again—this bug is still present and still works exactly the same.

(While I’m here, does anyone know how I would file a bug with the nvidia-340 package? I mean, I don’t know how much we can do about that driver, given its proprietary nature, but I want to try, at least. I just want one of my graphics drivers working so I can use my media player again… (sigh))

Tina Russell (tinarussell) wrote :

Sweet mother of the Muses, I just downgraded the mesa-va-drivers package to 18.0.0~rc5-1ubuntu1 (since that’s the one from the non-updates Bionic repository) and Kodi works again! Then, this is a problem specifically with the mesa-va-drivers package. I’ll have to update the description accordingly.

description: updated
no longer affects: xserver-xorg-video-nouveau (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed
Alex Moldovan (alexmoldovan) wrote :

Comfirmed.

Alex Moldovan (alexmoldovan) wrote :

Using Ubuntu 18.04.3 LTS with 4.15.0-55-generic #60-Ubuntu SMP Tue Jul 2 18:22:20 UTC 2019 x86_64 x86_64 x86_64 GNU/Linux

Output:

libva info: VA-API version 1.1.0
libva info: va_getDriverName() returns 0
libva info: Trying to open /usr/lib/x86_64-linux-gnu/dri/nouveau_drv_video.so
libva info: Found init function __vaDriverInit_1_1
libva info: va_openDriver() returns 0
kodi-x11: ../src/gallium/drivers/nouveau/nouveau_vp3_video.c:91: nouveau_vp3_video_buffer_create: Assertion `templat->interlaced' failed.
Aborted (core dumped)
Traceback (most recent call last):
  File "/usr/bin/apport-unpack", line 74, in <module>
    pr.extract_keys(f, bin_keys, dir)
  File "/usr/lib/python3/dist-packages/problem_report.py", line 270, in extract_keys
    [item for item, element in b64_block.items() if element is False])
ValueError: ['UserGroups'] has no binary content
Crash report available at /home/calin/kodi_crashlog-20190808_093922.log

Alex Moldovan (alexmoldovan) wrote :

kodi_crashlog-20190808_093922.log

Timo Aaltonen (tjaalton) wrote :

This is caused by the change to use meson as the build system, and meson < 0.47 is buggy when handling some build options, and due to that assertions are enabled while they shouldn't be

the fix is to add -DNDEBUG to CFLAGS manually, please test the update from this ppa:
https://launchpad.net/~canonical-x/+archive/ubuntu/x-staging

Changed in mesa (Ubuntu):
status: Confirmed → Invalid
Changed in mesa (Ubuntu Bionic):
status: New → Incomplete
assignee: nobody → Timo Aaltonen (tjaalton)
importance: Undecided → High
Timo Aaltonen (tjaalton) on 2019-08-23
description: updated
Timo Aaltonen (tjaalton) wrote :

hum, there's some build issue that needs sorting out first

Timo Aaltonen (tjaalton) wrote :

should be available soon

Daniel van Vugt (vanvugt) wrote :

Are you sure about those duplicates?

Timo Aaltonen (tjaalton) wrote :

assertions shouldn't be enabled

Timo Aaltonen (tjaalton) wrote :

then again, this case isn't protected by NDEBUG, so... meh

Timo Aaltonen (tjaalton) on 2019-08-26
description: updated
Changed in mesa (Ubuntu Bionic):
status: Incomplete → Confirmed
Changed in mesa (Ubuntu):
status: Invalid → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in mesa (Ubuntu):
status: New → Confirmed
Csimbi (turbotalicska) wrote :

Hello,
I got this error, too:

kodi-x11: ../src/gallium/drivers/nouveau/nouveau_vp3_video.c:91: nouveau_vp3_video_buffer_create: Assertion `templat->interlaced' failed.

Fresh install of Ubuntu Server 18.04 (+SSH +Samba)
Kodi install like so:
sudo apt-get install software-properties-common
sudo add-apt-repository ppa:team-xbmc/ppa
sudo apt-get update
sudo apt-get install kodi
sudo apt-get install xauth xorg xinit xserver-xorg-core xserver-xorg xserver-common
sudo apt-get install lightdm
sudo adduser kodi
sudo usermod -a -G cdrom,audio,video,plugdev,users,dialout,dip,input kodi

sudo dpkg-reconfigure xserver-xorg-legacy
-> Select Anybody

sudo nano /etc/X11/Xwrapper.config
Add to the file:
needs_root_rights=yes

+Service:
[Unit]
Description = Kodi-standalone using xinit
After = remote-fs.target systemd-user-sessions.service sound.target network-online.target

[Service]
User = kodi
Group = kodi
Type = simple
ExecStart = /usr/bin/xinit /usr/bin/dbus-launch /usr/bin/kodi-standalone -- :0 -nolisten tcp
Restart = on-abort

[Install]
WantedBy = multi-user.target

+Enable service:
sudo systemctl enable kodi.service

+edit /etc/security/limits.conf and add :
kodi - nice -1

Does a workaround exist?

Thank you!

Timo Aaltonen (tjaalton) wrote :

could you test with ppa:ubuntu-x-swat/updates which has a newer mesa backported from eoan?

Changed in mesa (Ubuntu Bionic):
status: Confirmed → Incomplete
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers