Users in group 'admin' get automatically added to group 'lxd'

Bug #1950635 reported by Paride Legovini
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
lxd (Ubuntu)
Fix Released
Undecided
Unassigned
Bionic
Confirmed
Undecided
Unassigned

Bug Description

The Bionic lxd.preinst script has:

# Add each admin user to the lxd group - for systems installed
# before precise
for u in $(getent group admin | sed -e "s/^.*://" -e "s/,/ /g"); do
    adduser "$u" lxd >/dev/null || true
done

however the "admin" group has no special meaning in Ubuntu >= 12.04, see [1]. I installed a clean Bionic system from ISO and the group doesn't even get created in the installed system. This means that the group is arbitrary, and can also be a remote group.

I think the admin -> lxd auto-add code should be dropped from lxd.preinst. See LP: #1942195 for a very similar issue affecting samba, solved by dropping the auto-add code.

[1] https://wiki.ubuntu.com/PrecisePangolin/ReleaseNotes/UbuntuDesktop#PrecisePangolin.2FReleaseNotes.2FCommonInfrastructure.Common_Infrastructure

Revision history for this message
Paride Legovini (paride) wrote :

I marked the main task as Fix Released as the lxd snap doesn't have this issue. This only affected supported release is Bionic.

Changed in lxd (Ubuntu):
status: New → Fix Released
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in lxd (Ubuntu Bionic):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers