[LTCTest][OPAL][OP920] lsmcode -A is not showing any output

Bug #1751986 reported by bugproxy on 2018-02-27
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
The Ubuntu-power-systems project
High
Canonical Foundations Team
lsvpd (Ubuntu)
High
Brian Murray
Bionic
High
Brian Murray

Bug Description

-- SRU Bionic --
[Impact]
lsmcode does not display product version information on Power system (AC922) with OPAL firmware (OP920).

[Test]
Running lsmcode -A command on Power system does not print the "Product Version" information.
$ sudo lsmcode -A | grep "Product Version" || { echo "failed to print product version"; exit ; }

[Fix]
Comment #3 identifies the patches needed to fix this issue.

[Regression Potential]
None

== Comment: #5 - Pridhiviraj Paidipeddi <email address hidden> - 2018-02-26 11:02:21 ==
We are missing Product Version in lsmcode output, due to which "lsmcode -A" fails.
lsmcode(incorrect output)
=================
Version of System Firmware :
 Product Name : OpenPOWER Firmware
 Product Extra : occ-fce2d94
 Product Extra : skiboot-v5.9-238-g43eb8bbcbaa5
 Product Extra : buildroot-2017.11-5-g65679be
 Product Extra : capp-ucode-p9-dd2-v2
 Product Extra : petitboot-v1.6.6-p91994c3
 Product Extra : sbe-86ae83c
 Product Extra : hostboot-binaries-8b5adb5
 Product Extra : machine-xml-4374657
 Product Extra : hostboot-52ca812
 Product Extra : linux-4.14.13-openpower1-pdb952b4

lsmcode(correct output)
================
Version of System Firmware :
 Product Name : OpenPOWER Firmware
 Product Version : open-power-SUPERMICRO-P9DSU-V1.03-20180205-imp
 Product Extra : occ-577915f
 Product Extra : skiboot-v5.9-240-g081882690163-pcbedce4
 Product Extra : petitboot-v1.6.6-p019c87e
 Product Extra : sbe-095e608
 Product Extra : machine-xml-fb5f933
 Product Extra : hostboot-9bfb201
 Product Extra : linux-4.14.13-openpower1-p78d7eee

So we need two fixes here, one is to form Product Version string and another one is to fix "lsmcode -A" empty output bug when there is no Product Version available.

== Comment: #6 - Pridhiviraj Paidipeddi <email address hidden> - 2018-02-26 11:10:23 ==
Attached patch will fix "lsmcode -A" empty output issue.

[root@ltc-wspoon2 lsvpd]# ./lsmcode -A
enP5p1s0f0 !.5719-v1.43 NCSI v1.3.12.0
enP5p1s0f1 !.5719-v1.43 NCSI v1.3.12.0
sg0 0:0:0:0 sda !ST1000NX0313.BE35
sg1 1:0:0:0 sdb !ST1000NX0313.BE35
[root@ltc-wspoon2 lsvpd]# ./lsmcode -v
lsmcode 1.7.8
[root@ltc-wspoon2 lsvpd]# ./lsmcode
Version of System Firmware :
 Product Name : OpenPOWER Firmware
 Product Extra : occ-fce2d94
 Product Extra : skiboot-v5.9-238-g43eb8bbcbaa5
 Product Extra : buildroot-2017.11-5-g65679be
 Product Extra : capp-ucode-p9-dd2-v2
 Product Extra : petitboot-v1.6.6-p91994c3
 Product Extra : sbe-86ae83c
 Product Extra : hostboot-binaries-8b5adb5
 Product Extra : machine-xml-4374657
 Product Extra : hostboot-52ca812
 Product Extra : linux-4.14.13-openpower1-pdb952b4

Tested on a AC922 system where the failure occurs when it is having a firmware OP920.

bugproxy (bugproxy) on 2018-02-27
tags: added: architecture-ppc64le bugnameltc-165131 severity-high targetmilestone-inin1804
Changed in ubuntu:
assignee: nobody → Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage)
affects: ubuntu → lsvpd (Ubuntu)
Frank Heimes (frank-heimes) wrote :

Looks like the patches are attached to the Bugzilla system only - please can you sync these over to Launchpad as well? Thx

Changed in ubuntu-power-systems:
importance: Undecided → High
tags: added: triage-g
Changed in ubuntu-power-systems:
status: New → Incomplete
Changed in ubuntu-power-systems:
assignee: nobody → Canonical Foundations Team (canonical-foundations)
Steve Langasek (vorlon) on 2018-02-28
Changed in lsvpd (Ubuntu):
status: New → Incomplete

------- Comment From <email address hidden> 2018-02-28 01:36 EDT-------
Hi

Fixes sent to mailing list for review. Will update here when those gets merged in upstream.

Thanks

Manoj Iyer (manjo) on 2018-03-05
Changed in lsvpd (Ubuntu):
assignee: Ubuntu on IBM Power Systems Bug Triage (ubuntu-power-triage) → Canonical Foundations Team (canonical-foundations)
importance: Undecided → High
bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-03-07 04:39 EDT-------
Below three commits should resolve this issue.

commit 45cc84fd958b530aedcc2f9e19f9e11d196d9ee6 (HEAD -> master, origin/next, origin/master, origin/HEAD)
Author: Vasant Hegde <email address hidden>
Date: Thu Mar 1 15:58:00 2018 +0530

vpdupdate: Validate file presence before reading data

commit 604132155fd5242411f178b2afdd3b50d841956e
Author: Pridhiviraj Paidipeddi <email address hidden>
Date: Sat Mar 3 13:27:58 2018 +0530

lsmcode: Add product version string to firmware information

Author: Pridhiviraj Paidipeddi <email address hidden>
Date: Fri Mar 2 10:39:56 2018 +0530

lsmcode: Fix failure of displaying all device possible micro code

-Vasant

------- Comment From <email address hidden> 2018-03-07 04:42 EDT-------
Hello Canonical.

I've attached three patches to bugzilla.. Not sure whether patches are pushed to launchpad properly...

Otherwise can you pull commits mentioned in bugzilla from upstream? It applies cleanly on top of Ubuntu 18.04 version...Let me know if you need any clarification.

-Vasant

------- Comment (attachment only) From <email address hidden> 2018-03-07 04:40 EDT-------

------- Comment (attachment only) From <email address hidden> 2018-03-07 04:41 EDT-------

------- Comment (attachment only) From <email address hidden> 2018-03-07 04:41 EDT-------

Changed in ubuntu-power-systems:
status: Incomplete → Triaged
Manoj Iyer (manjo) on 2018-04-05
Changed in lsvpd (Ubuntu):
status: Incomplete → Triaged

------- Comment From <email address hidden> 2018-04-17 05:51 EDT-------
*** Bug 165256 has been marked as a duplicate of this bug. ***

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-04-19 09:36 EDT-------
(In reply to comment #21)
> Hello Canonical.
>
> I've attached three patches to bugzilla.. Not sure whether patches are
> pushed to launchpad properly...
>
> Otherwise can you pull commits mentioned in bugzilla from upstream? It
> applies cleanly on top of Ubuntu 18.04 version...Let me know if you need any
> clarification.
>
> -Vasant

Any update ?

-Vasant

tags: added: id-5ad8b66ecdf740a0f53a6c03
Patricia Gaughen (gaughen) wrote :

This did not make the 18.04 release, after the release has GAd, we will dive into this one deeper and evaluate for SRU into 18.04.

bugproxy (bugproxy) wrote :

------- Comment From <email address hidden> 2018-04-26 02:17 EDT-------
*** Bug 165645 has been marked as a duplicate of this bug. ***

tags: added: triage-a
removed: triage-g
Changed in lsvpd (Ubuntu):
status: Triaged → In Progress
assignee: Canonical Foundations Team (canonical-foundations) → Brian Murray (brian-murray)
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lsvpd - 1.7.8-2ubuntu2

---------------
lsvpd (1.7.8-2ubuntu2) cosmic; urgency=medium

  * Merge three upstream commits. (LP: #1751986)
    - 0001-lsmcode-Fix-failure-of-displaying-all-device-possibl.patch
    - 0002-lsmcode-Add-product-version-string-to-firmware-infor.patch
    - 0003-vpdupdate-Validate-file-presence-before-reading-data.patch

 -- Brian Murray <email address hidden> Wed, 30 May 2018 08:28:17 -0700

Changed in lsvpd (Ubuntu):
status: In Progress → Fix Released
description: updated
Brian Murray (brian-murray) wrote :

To continue with a stable release update of lsvpd in Ubuntu 18.04 we could use a test case to verify that the fix in fact works. Could someone provide one?

Thanks in advance!

Changed in lsvpd (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → High
Manoj Iyer (manjo) on 2018-06-08
description: updated
Manoj Iyer (manjo) on 2018-06-11
Changed in lsvpd (Ubuntu Bionic):
assignee: nobody → Canonical Foundations Team (canonical-foundations)
tags: added: triage-g
removed: triage-a
Changed in lsvpd (Ubuntu Bionic):
assignee: Canonical Foundations Team (canonical-foundations) → Brian Murray (brian-murray)
status: Triaged → In Progress

Hello bugproxy, or anyone else affected,

Accepted lsvpd into bionic-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/lsvpd/1.7.8-2ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-bionic to verification-done-bionic. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-bionic. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in lsvpd (Ubuntu Bionic):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-bionic

------- Comment From <email address hidden> 2018-06-15 01:12 EDT-------
I have installed the lsvpd package available in the bionic-proposed.

root@ltc-wspoon11:~# apt-get install lsvpd/bionic-proposed
Reading package lists... Done
Building dependency tree
Reading state information... Done
Selected version '1.7.8-2ubuntu1.1' (Ubuntu:18.04/bionic-proposed [ppc64el]) for 'lsvpd'
The following packages will be upgraded:
lsvpd
1 upgraded, 0 newly installed, 0 to remove and 40 not upgraded.
Need to get 192 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://ports.ubuntu.com/ubuntu-ports bionic-proposed/main ppc64el lsvpd ppc64el 1.7.8-2ubuntu1.1 [192 kB]
Fetched 192 kB in 1s (256 kB/s)
(Reading database ... 189430 files and directories currently installed.)
Preparing to unpack .../lsvpd_1.7.8-2ubuntu1.1_ppc64el.deb ...
Unpacking lsvpd (1.7.8-2ubuntu1.1) over (1.7.8-2ubuntu1) ...
Setting up lsvpd (1.7.8-2ubuntu1.1) ...
Processing triggers for man-db (2.8.3-2) ...
root@ltc-wspoon11:~# which lsvpd
/usr/sbin/lsvpd
root@ltc-wspoon11:~# dpkg -S /usr/sbin/lsvpd
lsvpd: /usr/sbin/lsvpd
root@ltc-wspoon11:~# dpkg --list | grep lsvpd
ii lsvpd 1.7.8-2ubuntu1.1 ppc64el Utility to List Device Vital Product Data (VPD)

Then executed the lsmcode -A command to verify the fixes.

root@ltc-wspoon11:~# lsmcode -A
sys0!system: witherspoon-ibm-OP9-v2.0.3-2.17
enP5p1s0f0 !.5719-v1.43 NCSI v1.3.12.0
enP5p1s0f1 !.5719-v1.43 NCSI v1.3.12.0
sg0 1:0:0:0 sda !ST1000NX0313.BE30
sg1 0:0:0:0 sdb !STORE.5.00

The bug is resolved with the latest packages available in bionic-proposed.

tags: added: verification-done-bionic
removed: verification-needed verification-needed-bionic
Changed in ubuntu-power-systems:
status: Triaged → Won't Fix
status: Won't Fix → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package lsvpd - 1.7.8-2ubuntu1.1

---------------
lsvpd (1.7.8-2ubuntu1.1) bionic; urgency=medium

  * Merge three upstream commits. (LP: #1751986)
    - 0001-lsmcode-Fix-failure-of-displaying-all-device-possibl.patch
    - 0002-lsmcode-Add-product-version-string-to-firmware-infor.patch
    - 0003-vpdupdate-Validate-file-presence-before-reading-data.patch

 -- Brian Murray <email address hidden> Tue, 12 Jun 2018 11:32:31 -0700

Changed in lsvpd (Ubuntu Bionic):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for lsvpd has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Changed in ubuntu-power-systems:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers