[DNV]Watchdog can not reboot system

Bug #1792536 reported by quanxian on 2018-09-14
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
intel
Medium
Unassigned
linux (Ubuntu)
Medium
Unassigned
Bionic
Medium
Unassigned
Cosmic
Medium
Unassigned

Bug Description

Description:
Watchdog not work on Denverton and KBL-NUC platform.

Commit IDs:851a15114895c5bce163a6f2d57e0aa4658a1be4
Target Kernel: 4.19

Target Release: 19.04

quanxian (quanxian-wang) wrote :

if needed, it can also cherry picked to 18.10 or 16.04.x. Dawson Canyon is supported by Canonical with OEM image.

Chih-Hsyuan Ho (chih) wrote :

@Quanxian, Dawson Canyon has already been migrated to 16.04.5. We will get the Canonical kernel team to review this patch and see if it can be back ported to Xenial.

affects: ubuntu → linux (Ubuntu)

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1792536

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

@Quanxian, by the way, can you share with us how exactly we can verify this feature in Dawson Canyon after we add this commit please?

Changed in linux (Ubuntu Bionic):
status: New → Triaged
Changed in linux (Ubuntu Cosmic):
status: Incomplete → Triaged
Changed in linux (Ubuntu Bionic):
importance: Undecided → Medium
Changed in linux (Ubuntu Cosmic):
importance: Undecided → Medium
Changed in intel:
importance: Undecided → Medium
status: New → Triaged
quanxian (quanxian-wang) wrote :

this commit only fix DNV, instead of KBL-NUC. Our engineer is contacting upstream for confirmation. The commit will be soon for KBL-NUC. I will input the commit here.

About the testing,

1) loading two modules
#modprobe i2c_i801
#modprobe iTCO_wdt
2) check watchdog device
ls /dev/watchdog*
3) run this command, it should reboot the machine after a while.
cat /dev/watchdog; for i in `seq 1 100`; do echo $i; sleep 1; done

quanxian (quanxian-wang) wrote :

KBL will use another bug.

Changed in intel:
status: Triaged → Fix Released
Changed in linux (Ubuntu):
status: Triaged → Fix Released
Changed in linux (Ubuntu Cosmic):
status: Triaged → Fix Released
summary: - [DNV][KBL-NUC]Watchdog can not reboot system
+ [DNV]Watchdog can not reboot system
quanxian (quanxian-wang) wrote :

for KBL, it will old watchdog driver. Not a kernel issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers