rmmod b43 hangs

Bug #1763967 reported by Boris Gjenero on 2018-04-14
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
Medium
Joseph Salisbury
Bionic
Medium
Joseph Salisbury

Bug Description

I'm running Ubuntu on a Dell Inspiron 6400 with a 14e4:4328 "Dell Wireless 1500 Draft 802.11n WLAN Mini-Card". Running "rmmod b43" always hangs. So far I have only tried it while connected to a wireless network. I immediately disconnect from the wireless network, so it seems module removal does begin. But the rmmod process never finishes and is unkillable. The hang seems indefinite, and a normal reboot is not possible, the rapid ctrl-alt-del systemd emergency reboot is impossible, and only a Magic SysRq reboot works.

This worked in Ubuntu 17.10, but always fails in Ubuntu 18.04.

(I was unloading the module before suspend due to occasional problems after resume. I tracked this down when wondering why suspend was hanging. Even running the "rmmod b43" on its own without suspend happening causes the hang. Right now I disabled that automatic unloading.)

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: linux-image-4.15.0-13-generic 4.15.0-13.14
ProcVersionSignature: Ubuntu 4.15.0-13.14-generic 4.15.10
Uname: Linux 4.15.0-13-generic x86_64
AlsaVersion: Advanced Linux Sound Architecture Driver Version k4.15.0-13-generic.
ApportVersion: 2.20.9-0ubuntu4
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: Intel [HDA Intel], device 0: STAC9200 Analog [STAC9200 Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: bgjenero 1560 F.... pulseaudio
Card0.Amixer.info:
 Card hw:0 'Intel'/'HDA Intel at 0xefffc000 irq 24'
   Mixer name : 'SigmaTel STAC9200'
   Components : 'HDA:83847690,102801bd,00102201 HDA:14f12bfa,14f100c3,00090000'
   Controls : 22
   Simple ctrls : 9
CurrentDesktop: XFCE
Date: Sat Apr 14 11:54:36 2018
HibernationDevice: RESUME=UUID=46f322d9-a161-4e1f-8a08-432d79aeac18
InstallationDate: Installed on 2012-01-19 (2277 days ago)
InstallationMedia: Xubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
Lsusb:
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
 Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
 Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
MachineType: Dell Inc. MM061
ProcFB: 0 radeondrmfb
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-13-generic root=UUID=54eeb2ee-ee10-4c6b-9c61-1b790e52fd1e ro resume=/dev/sda6 nopti
RelatedPackageVersions:
 linux-restricted-modules-4.15.0-13-generic N/A
 linux-backports-modules-4.15.0-13-generic N/A
 linux-firmware 1.173
RfKill:
 0: phy0: Wireless LAN
  Soft blocked: no
  Hard blocked: no
SourcePackage: linux
UpgradeStatus: Upgraded to bionic on 2018-03-11 (34 days ago)
dmi.bios.date: 06/13/2007
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A17
dmi.board.name: 0XD720
dmi.board.vendor: Dell Inc.
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.modalias: dmi:bvnDellInc.:bvrA17:bd06/13/2007:svnDellInc.:pnMM061:pvr:rvnDellInc.:rn0XD720:rvr:cvnDellInc.:ct8:cvr:
dmi.product.name: MM061
dmi.sys.vendor: Dell Inc.

Boris Gjenero (boris-gjenero) wrote :

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the latest upstream kernel? Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Please test the latest v4.16 kernel[0].

If this bug is fixed in the mainline kernel, please add the following tag 'kernel-fixed-upstream'.

If the mainline kernel does not fix this bug, please add the tag: 'kernel-bug-exists-upstream'.

Once testing of the upstream kernel is complete, please mark this bug as "Confirmed".

Thanks in advance.

[0] http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.17-rc1/

Changed in linux (Ubuntu):
importance: Undecided → Medium
Joseph Salisbury (jsalisbury) wrote :

Also, does this issue go away if you boot back into the prior kernel?

tags: added: kernel-da-key
Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Boris Gjenero (boris-gjenero) wrote :

Bug does not exist in 4.16.2-041602-generic. I did rmmod b43 4 times and it always succeeded immediately. It never worked properly in 4.15.0-13-generic so I am confident this isn't just random success, and it means the bug is fixed in upstream.

What older version should I try? Currently I don't have any old versions available.

Changed in linux (Ubuntu Bionic):
status: Incomplete → Confirmed
tags: added: kernel-fixed-upstream
Joseph Salisbury (jsalisbury) wrote :

Would it be possible for you to test the proposed kernel and post back if it resolves this bug?
See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed.

Thank you in advance!

Boris Gjenero (boris-gjenero) wrote :

rmmod b43 works in 4.15.0-21-generic

Changed in linux (Ubuntu):
status: Confirmed → Fix Committed
Changed in linux (Ubuntu Bionic):
status: Confirmed → Fix Committed
Changed in linux (Ubuntu):
assignee: nobody → Joseph Salisbury (jsalisbury)
Changed in linux (Ubuntu Bionic):
assignee: nobody → Joseph Salisbury (jsalisbury)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers