Ubuntu 18.04 d-i install screen becomes blurry on Huawei server in EFI boot mode

Bug #1762940 reported by Zhanglei Mao on 2018-04-11
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
linux (Ubuntu)
High
Unassigned
Bionic
High
Unassigned

Bug Description

For all(as I know) Huawei servers, the vga adapter are embed in the iBMC chips. Those server can install from ISO manually for 16.04.4 and screen display normally. But for 18.04 ( tested both for daily and final beta)version, the install screen is blur. One of tested server is Huawei 2855 v5, the certification link for 16.04 are https://certification.ubuntu.com/hardware/201707-25596/.

Below are key difference of dmesg. It seems might related with DRM.

18.04 install screen is blur
dmesg
...
[ 2.039009] fb0: EFI VGA frame buffer device
...
[ 4.178058] [drm] Supports vblank timestamp caching Rev 2 (21.10.2013).
[ 4.191435] [drm] No driver support for vblank timestamp query.
[ 4.209338] checking generic (90000000 300000) vs hw (0 0)
[ 4.209384] fbcon: hibmcdrmfb (fb1) is primary device
[ 4.209385] fbcon: Remapping primary device, fb1, to tty 1-63
...
[ 5.357024] hibmc-drm 0000:07:00.0: fb1: hibmcdrmfb frame buffer device
[ 5.380085] [drm] Initialized hibmc 1.0.0 20160828 for 0000:07:00.0 on minor 0
...
[ 5.636624] vga16fb: initializing
[ 5.636627] vga16fb: mapped to 0x0000000048a7a1d2
[ 5.636630] checking generic (90000000 300000) vs hw (a0000 10000)
[ 5.636676] fb2: VGA16 VGA frame buffer device
...

16.04.4 install screen is fine (no screen blur)
dmesg
...
[ 2.000419] fb0: EFI VGA frame buffer device
....
[ 8.795065] vga16fb: initializing
[ 8.795068] vga16fb: mapped to 0xffff8800000a0000
[ 8.795071] checking generic (98000000 300000) vs hw (a0000 10000)
[ 8.795121] fb1: VGA16 VGA frame buffer device
...

summary: - Ubuntu 1804 install screen becomes blur on Huawei server
+ Ubuntu 18.04 install screen becomes blur on Huawei server

This bug is missing log files that will aid in diagnosing the problem. While running an Ubuntu kernel (not a mainline or third-party kernel) please enter the following command in a terminal window:

apport-collect 1762940

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete
tags: added: bionic

Hey Mao, Is this visible after install?

In other words can you install 16.04 on the failing system, then add the 4.15 kernel and boot into it?

Once you do that, does the issue appear?

Just to summarize where we are:

16.04, 4.13: No problem
18.04, 4.15: Problem with frame buffer
16.04, 4.15: ???

Changed in linux (Ubuntu):
importance: Undecided → High
tags: added: kernel-key
Changed in linux (Ubuntu Bionic):
status: Incomplete → Triaged
Zhanglei Mao (zhanglei-mao) wrote :

The screen also get blur after ubuntu 18.04 beta2 was installed by legacy bios on Huawei server (VGA card is SM750 which was embedded in Hi1710 iMBC chips). The ubuntu-destktop was installed by "apt-get install ubuntu-desktop and init 5 to switch to x.

Zhanglei Mao (zhanglei-mao) wrote :

For Xenial ubuntu-deskto on Huawei server testing (UEFI), all kernel 4.4 (default) and 4.13 (hwe) and 4.15 (hwe-edge) works well (no screen blur).

no longer affects: install-package (Ubuntu)
Zhanglei Mao (zhanglei-mao) wrote :

Today, Huawei side did x-window testing 16.04.04 in legacy BIOS model, all 4.4,4.13(hwe),4.15(hwe-edge which as as 18.04), 4.17rc1 works fine (no screen blur).

Zhanglei Mao (zhanglei-mao) wrote :

Below image uses the Subiquity and it can be installed successfully. But after install ubuntu-desktop, the login screen would become screen blur after reboot or init 5, but it can be start by startx after init 3 in the terminal.
http://releases.ubuntu.com/18.04/ubuntu-18.04-live-server-amd64.iso.

For ISO of classic Debian installer (d-i) which was download from below, the setup (install) would still become bur and can't continue to finish install by manual which was tested by iMBC(KVM) and virtual CD-ROM.
http://cdimage.ubuntu.com/releases/18.04/release/ubuntu-18.04-server-amd64.iso

Zhanglei Mao (zhanglei-mao) wrote :

Blur screen for GDM login was caused by wayland, it can be fix by force to use Xorg in /etc/gdm3/customer.conf to uncoment WaylandEnable=false

tags: added: kernel-da-key
removed: kernel-key
Zhanglei Mao (zhanglei-mao) wrote :

For ISO of classic Debian installer (d-i), it would become screen blur after kernel load and in the first screen of "select a langue"

Jeff Lane (bladernr) on 2018-05-18
summary: - Ubuntu 18.04 install screen becomes blur on Huawei server
+ Ubuntu 18.04 d-i install screen becomes blurry on Huawei server in EFI
+ boot mode
Zhanglei Mao (zhanglei-mao) wrote :

This bug seems related with 4.15.0-20, the test result on UEFI model for different combination of 16.04, 18.04 and their kernel are below:
18.04(d-i not subiquity) with 4.13 kerel: no screen blur
18.04(d-i not subiquity) with 4.15.22 kerenl: no screen blur
16.04 with 4.15.20 kernel screen blur
18.04(d-i) with 4.15.20 kernel screen blur
Notes: 4.13 kernel come from 16.04.4 ISO
       4.15.0-22 kernel come from upgrading installed 18.04
       screen blur means blur screen picture for language select page
       Test with customized ISO which was replaced by vmlinux and initrd (new kernel)

Zhanglei Mao (zhanglei-mao) wrote :

In #18, 4.13 should replaced with 4.4.0-116 which used by 16.04.4 ISO.

Zhanglei Mao (zhanglei-mao) wrote :

The daily build is still use 4.15.0-20 kernel. It was expecting of update and fix this blur problem. http://cdimage.ubuntu.com/ubuntu-server/bionic/daily/20180625/bionic-server-amd64.iso

Rod Smith (rodsmith) wrote :

This looks to me as if Ubuntu (the kernel, Wayland, and/or the X server, depending on when the problem occurs) is delivering a video mode that the display device can't handle. (With VGA, the display should deliver its capabilities to the computer via EDID, but this doesn't always work correctly.) Thus, the first question is what that "display device" is. The screen shots look like a remote KVM of some sort. Is that the BMC's built-in screen-sharing tool, a network-accessible KVM hardware device (like a Raritan or Avocent), or something else? If possible, I recommend testing in person with a plain monitor plugged directly into the computer, at least as a diagnostic procedure. If that works, then it's likely that the issue is either a matter of a restrictive set of video modes in the remote-access tool, miscommunication between the remote-access tool and the kernel/Wayland/X, or both. Also, if a physical monitor is plugged into the server while it's being accessed remotely, it's conceivable that the kernel/Wayland/X is taking its cues about video mode from the physical monitor rather than from the remote-access tool, thus creating a mismatch. If the problem is caused by the remote access tool, or by an interaction between that and the kernel/Wayland/X, then updating the remote access tool's firmware may fix the problem.

Note that the video mode used can vary depending on the kernel version, X vs. Wayland, EFI vs. BIOS boot mode, and other factors. Such variables likely explain why earlier kernels worked but newer ones don't.

As a workaround, it might be possibly to forcibly reconfigure the system to use a video mode that will work with the display device. Unfortunately, there are a lot of different ways to do this, depending on the subsystem involved. For instance:

* Kernel parameters can set the kernel's video mode. Unfortunately, there are
  a lot of possibilities even here, including, but not limited to:
  * nomodeset
  * video=vga16fb:off
  * vga16fb.modeset=0
  * video=efifb:width:640,height:480
  * Try Googling "kernel video mode setting" or something similar for
    additional possibilities.
* X configuration
  * If you can get X working, even temporarily, you can use the GUI
    setup tools to change the resolution.
  * The xrandr tool can be used to probe and set video options; see
    https://www.x.org/wiki/Projects/XRandR/
  * I've not kept up with text-mode (manual) X configuration, but
    you may be able to find some documentation on how to get it
    to change video mode. Start here:
    https://help.ubuntu.com/community/VideoDriverHowto#Xorg.conf.d
* Wayland configuration
  * I'm even less of an expert on this, so I suggest you try
    Googling "wayland set resolution" or something similar.

Finally, note that Ubuntu server certification doesn't cover display devices, so this is NOT a certification blocker.

Zhanglei Mao (zhanglei-mao) wrote :

This bug seems related with the kernel or 4.15.0-20 of d-i ISO. Please refer to #18 for test results on different kernel.

Zhanglei Mao (zhanglei-mao) wrote :

The daily build is still use 4.15.0-20 kernel.
http://cdimage.ubuntu.com/ubuntu-server/bionic/daily/current/bionic-server-amd64.iso

Anyone can confirm that the 18.04.1 d-i install iso would update the kernel.

Zhanglei Mao (zhanglei-mao) wrote :

I have tested with 18.04.1 on Huawei FusionServer 2288 again. The screen blure is same. The kernel of this iso have been update to 4.15.0-29-generic.

Zhanglei Mao (zhanglei-mao) wrote :

I just tested with /boot/vmlinuz-4.15.0-29-generic which from my laptop ( to replace install/vmlinuz with this file), it would be screen blur. If I use 4.15.0-32-generic, blur would disappear.

Zhanglei Mao (zhanglei-mao) wrote :

I test 16.04.5 ga-kernel would not be screen blur but the hwe-kernel(4.15.0-29) which is same as 18.04.1 would become screen blur.

The 16.04.5 hwe (blur) syslog are enclosed.

Zhanglei Mao (zhanglei-mao) wrote :

The 16.04.5 ga-kernel wouldn't be screen blur and their syslog are enclosed.

Zhanglei Mao (zhanglei-mao) wrote :

The 18.04.1 ga-kernel (4.15.0-29) would be screen blur. The syslog are enclosed too.

Zhanglei Mao (zhanglei-mao) wrote :

replace 18.04.1 with 4.15.0-29 kernel from my laptop (16.04) and it would be screen blur too. The syslog are enclosed here. If I replacing it with 4.15.0-32-generic from my laptop, it would not be screen bure on language select screen, but the system seems hanged (died) in case I can't switch to tty2 or press "enter" key to continue.

Zhanglei Mao (zhanglei-mao) wrote :

In the screen blur kernel syslog, it show below error which 16.04.5 GA kernel don't have this error:
...
Aug 21 10:25:50 kernel: [ 0.589408] ACPI Exception: Could not find/resolve named package element: LNKA (20170831/dspkginit-381)
(repeated 942 lines)
...

Zhanglei Mao (zhanglei-mao) wrote :

ACPI Exception have been reported here and it seems not related to screen blur

https://bugzilla.kernel.org/show_bug.cgi?id=198167

Zhanglei Mao (zhanglei-mao) wrote :

Tested on 17.10 server d-i install, it would be screen blur too during installation, the kernel is 4.13.0.

Zhanglei Mao (zhanglei-mao) wrote :

Tested with 18.04.1 Desktop, it wouldn't screen blur. The kernel log are enclosed.

Zhanglei Mao (zhanglei-mao) wrote :

In case 18.04.1 server and destop iso use same kernel of v4.15.0-29 and the GUI works fine on destop, so the kernel should not be blamed.

In 18.04.1 server installation, if I kill bterm process of below:
/usr/bin/bterm -f /lib/unifont.bgf -l C.UTF-i /lib/debian-installer/menu

Some blur picture would be gone. Please see attach screen shot.

Zhanglei Mao (zhanglei-mao) wrote :

Huawei hisilicon team thought it might be caused by hibmc_drm which are upstream and included in v4.10 kernel for their ARM64 server. It is right. After disable this module by:
 modprobe.blacklist=hibmc_drm
In the grub whiling booting iso. The install screen blur was disappeared.

Zhanglei Mao (zhanglei-mao) wrote :

Hisilicon team said this driver (hibmc_drm) are only for arm64. For X86 architecture, it need to use default driver for this SM750.

It seems we incorrectly include this model in X86.

Hisicon team have plans to fix in upstream source code which to limit this modules configure options only to arm64 to prevent someone compile (configure) it for x86.

dann frazier (dannf) wrote :

This issue also occurs on arm64. Attached is a screenshot from a HiSilicon D05 running 18.04.

Why would hibmc_drm be arm64-specific? It is the same PCI device (19e5:1711), so shouldn't it use the same driver regardless of architecture?

dann frazier (dannf) wrote :
dann frazier (dannf) wrote :

As observed on x86, disabling wayland also avoids the problem on ARM.

Zhanglei Mao (zhanglei-mao) wrote :

For #37 screen shot and #39. We found this wayland issues for 18.04 and Huawei x86 server, but it seems no for 18.04.1. In my test, apt-get install ubuntu-desktop and reboot works fine.

For #37 "Why would hibmc_drm be arm64-specific?", I guess it might because vendors (sm750 vga) have already provided driver x86.

Zhanglei Mao (zhanglei-mao) wrote :

For #37-#39

This screen blur issues during install are only happened on Huawei X86 server for 18.04 and 18.04.1 d-i iso. As I know, 18.04 and even 18.04.1 ARM64 iso works fine with this new hibmc-drm module for installation on Hisilicon D05 board.

dann frazier (dannf) wrote :

This is definitely reproducible on a D05 (arm64) with 18.04 running wayland, and the symptoms look identical. I re-tested with the 18.04.1 ISO and confirmed.

no longer affects: install-package (Ubuntu Bionic)
Zhanglei Mao (zhanglei-mao) wrote :

Dann,

For the wanland issues, I understood it as comments in #15, that is:

      Blur screen for GDM login was caused by wayland, it can be fix by force to use Xorg in
      /etc/gdm3/customer.conf to uncoment WaylandEnable=false

Is this right for your wanland issues on D05?

In 18.04, we found 2 issues on Huawei X86 server. One is screen blur during d-i install on UEFI model in Language selection screen, but it works for legacy bios model. The other is after start GUI (x-window or Ubuntu desktop). After we sucessfully installed 18.04 in legacy bios model on X86 Huawei server, I tried to start X-windows via apt-get install ubuntu-dekstop and reboot, we would get this blur screen again. This seems caused by this wanyland and can be fixed by this "WaylandEnable=false".

As I know, this wayland issues have been happened for D05 but I don't think D05 have above issues
during install.

AaronMa (mapengyu) wrote :

@Zhanglei

Could you try these 2 patches?

https://patchwork.freedesktop.org/patch/246810/
https://patchwork.freedesktop.org/patch/246811/

I think these 2 patches will fix the issue that dual GPU install on UEFI boot mode.

dann frazier (dannf) wrote :

@Mao: correct, I do not observe screen blur in d-i on D05.

btw, note also bug 1780076

Zhanglei Mao (zhanglei-mao) wrote :

@AaronMa
Do you have docs for how to compile a new kernel. I can found below doc link
https://help.ubuntu.com/community/Kernel/Compile
But it seems a bit old.

The other difficult is how to get compile config from d-i iso kernel. I found if I use a kernel from running/installed system to replace d-i iso kernel, it would hang (died) after booting in the first language selection screen.

AaronMa (mapengyu) wrote :

Hi:
Please refer to this wiki:
https://wiki.ubuntu.com/Kernel/BuildYourOwnKernel

Usually you just need to do the following first:

1, git clone xxx;
2, apply patches;

dann frazier (dannf) wrote :

With 18.04 UEFI on x86, does passing the kernel parameter "video=efifb:off" make a difference?

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.