Intel wifi bluetooth coexistence issue in 18.04

Bug #1756824 reported by Erki Hallingu
56
This bug affects 12 people
Affects Status Importance Assigned to Milestone
linux-firmware (Ubuntu)
Medium
Seth Forshee
Bionic
Medium
Seth Forshee

Bug Description

(Intel wifi/bluetooth 8260 and 8265)

Bluetooth does not work (bluetooth keyboard and mouse do not connect) when wifi enabled.

Upstream bug seems to be fixing this, copying intel firmware from this bug fixes the issue:
https://bugzilla.kernel.org/show_bug.cgi?id=197147

Ubuntu firmware package update from last couple of days still comes with broken intel firmware.

Other way to get bluetooth working with intel firmware from ubuntu package is to add following parameter in modprobe:

options iwlwifi bt_coex_active=0
to /etc/modprobe-d/iwlwifi.conf
---
ApportVersion: 2.20.8-0ubuntu10
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Dependencies:

DistroRelease: Ubuntu 18.04
InstallationDate: Installed on 2014-10-24 (1241 days ago)
InstallationMedia: Ubuntu 14.10 "Utopic Unicorn" - Release amd64 (20141022.1)
NonfreeKernelModules: wl
Package: linux-firmware 1.173 [modified: lib/firmware/intel/ibt-12-16.ddc lib/firmware/intel/ibt-12-16.sfi]
PackageArchitecture: all
ProcVersionSignature: Ubuntu 4.15.0-12.13-generic 4.15.7
Tags: bionic wayland-session
Uname: Linux 4.15.0-12-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dip kvm libvirt lpadmin lxd netdev plugdev sambashare sudo vboxusers
_MarkForUpload: True

Erki Hallingu (erkiha)
affects: xubuntu-meta (Ubuntu) → linux-firmware (Ubuntu)
description: updated
Revision history for this message
Seth Forshee (sforshee) wrote :

Can you please indicate which Ubuntu release you're running, and what version of the linux-firmware package you currently have installed? Thanks!

Changed in linux-firmware (Ubuntu):
status: New → Incomplete
Revision history for this message
Erki Hallingu (erkiha) wrote :

linux-firmware version 1.173
Ubuntu 18.04

Changed in linux-firmware (Ubuntu):
status: Incomplete → New
Revision history for this message
Erki Hallingu (erkiha) wrote : JournalErrors.txt

apport information

tags: added: apport-collected bionic wayland-session
description: updated
Revision history for this message
Erki Hallingu (erkiha) wrote : ProcCpuinfoMinimal.txt

apport information

Revision history for this message
Erki Hallingu (erkiha) wrote : ProcEnviron.txt

apport information

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in linux-firmware (Ubuntu):
status: New → Confirmed
Revision history for this message
Sebastian 'polrus' Tur (dpbasti) wrote :
Revision history for this message
Erki Hallingu (erkiha) wrote :

It's probably not. This issue described here is specific for intel hardware (8260 and 8265) and its fixed already in upstream firmware specific for these intel cards.

Revision history for this message
Crusoe (daniel-a-joyce) wrote :

I understand the nature of LTS, but its frustrating to me as the owner of a DELL xps 13 to be hamstrung by how slowly drivers/firmwares get into LTS. This bug has been around for almost a year now and nothing. Why use LTS if I have to use 2+ year old hardware because its so slow accepting patches...

Revision history for this message
Seth Forshee (sforshee) wrote :

I built a package with the bluetooth firmware files from the bug updated from the tip of linux-firmware. Can you please give this a try and confirm it fixes your issue? Thanks!

http://people.canonical.com/~sforshee/lp1756824/linux-firmware_1.173.3+lp1756824v201902081042_all.deb

Changed in linux-firmware (Ubuntu):
assignee: nobody → Seth Forshee (sforshee)
importance: Undecided → Medium
status: Confirmed → Incomplete
Changed in linux-firmware (Ubuntu Bionic):
assignee: nobody → Seth Forshee (sforshee)
importance: Undecided → Medium
status: New → Incomplete
Changed in linux-firmware (Ubuntu):
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers