Weather data failure

Bug #1827486 reported by lotuspsychje on 2019-05-03
16
This bug affects 3 people
Affects Status Importance Assigned to Milestone
inxi (Ubuntu)
Undecided
Unassigned
Bionic
Undecided
Unassigned
Cosmic
Undecided
Unassigned

Bug Description

Ubuntu desktop 18.04.2 up to date @ 3/5/2019 with kernel 4.15.0-48-generic

and Inxi version 2.3.56-1

inxi -wxxx fails to report the weather

Weather: Weather data failure: Fri May 3 10:00:33 CEST 2019
           Error: weather info downloaded but no data detected.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: inxi 2.3.56-1
ProcVersionSignature: Ubuntu 4.15.0-48.51-generic 4.15.18
Uname: Linux 4.15.0-48-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.6
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Fri May 3 10:00:41 2019
InstallationDate: Installed on 2018-08-17 (258 days ago)
InstallationMedia: Ubuntu 18.04 LTS "Bionic Beaver" - Release amd64 (20180426)
PackageArchitecture: all
ProcEnviron:
 TERM=xterm-256color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=nl_BE.UTF-8
 SHELL=/bin/bash
SourcePackage: inxi
UpgradeStatus: No upgrade log present (probably fresh install)

lotuspsychje (lotuspsychje) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in inxi (Ubuntu):
status: New → Confirmed
rue (ruenoak) wrote :

I can't test it in 18.04 but it seems to be working in 19.04, in the Application and the Notification area

Paul White (paulw2u) wrote :

Also confirming on Ubuntu 18.04.
FWIW, the later version I have on Fedora 30 works correctly.

lotuspsychje (lotuspsychje) wrote :

workaround: edit /etc/inxi.conf, make line 2 B_ALLOW_UPDATE=true, then in terminal do> sudo inxi -U

Harald Hope (lontact) wrote :

This is not a bug, the weather source that was in inxi 2.x and 3.0.31 and earlier is gone. The only fix for weather is to update to current inxi (3.0.33 in ubuntu, and 3.0.34 in master branch of github inxi).

The reason later versions work is because they point to a new weather data source.

Unit 193 (unit193) wrote :

Howdy,

As noted by the upstream maintainer, this bug was fixed in version 3.0.31 with the following changelog entry:

 3. BIG: current inxi weather will probably fail if not updated to this or
 newer versions!! Not an inxi bug per se, but your users will see it as one.

This will, of course, affect all versions prior to that release.

Changed in inxi (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers