No display plugins found.

Bug #1783209 reported by John Runyon
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
growl-for-linux (Ubuntu)
High
Unassigned
Bionic
High
Unassigned
Cosmic
High
Unassigned

Bug Description

$ gol

** (gol:24321): CRITICAL **: 16:52:13.507: No display plugins found.
$

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: growl-for-linux 0.8.5-2
ProcVersionSignature: Ubuntu 4.15.0-24.26-generic 4.15.18
Uname: Linux 4.15.0-24-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.2
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Mon Jul 23 16:51:36 2018
InstallationDate: Installed on 2018-03-07 (138 days ago)
InstallationMedia: Ubuntu 16.04.2 LTS "Xenial Xerus" - Release amd64 (20170215.2)
SourcePackage: growl-for-linux
UpgradeStatus: Upgraded to bionic on 2018-06-18 (35 days ago)

Revision history for this message
John Runyon (failureyousuck) wrote :
description: updated
Revision history for this message
John Runyon (failureyousuck) wrote :

N.B. the following sequence works:

sudo apt-get build-dep growl-for-linux
apt-get source growl-for-linux
cd growl-for-linux*/
./configure --prefix=/usr/local --enable-appindicator
make
aclocal
make
sudo make install
sudo apt-get remove growl-for-linux
hash -r
gol

Which makes it even sadder that the package is broken.

Revision history for this message
Hans Joachim Desserud (hjd) wrote :

Thanks for taking your time to report this issue and help making Ubuntu better.

I get the same error message when attempting to run gol from growl-for-linux 0.8.5-3 on Ubuntu Cosmic. However, I was not able to reproduce the issue on Debian Sid, so it may be an Ubuntu-specific bug.

I have not yet tried a rebuild, did you try one with the debuild tools, or just configure/make? The former would rebuild the package including any added patches, though I haven't checked.

Changed in growl-for-linux (Ubuntu):
status: New → Confirmed
tags: added: cosmic
Revision history for this message
John Runyon (failureyousuck) wrote :

#2 shows the exact steps I took to build it. Frankly I have no idea how to build it "with the debuild tools" :)

Revision history for this message
Hans Joachim Desserud (hjd) wrote :

"The debuild tools way" is running with the same tools which were used to make the original Debian package, so something like:
sudo apt build-dep growl-for-linux
apt source growl-for-linux
cd growl-for-linux*/
debuild -us -uc
cd ..
sudo apt install ./growl-for-linux_0.8.5-3_amd64.deb
gol

Which should be rather equivalent of the steps you performed. I just tried a rebuild of the Debian package though, and it still had the same results afterwards. So it might be something with the way it is built or any additional patches included which isn't triggered in the same way when you build and install it outside the package system.

Revision history for this message
John Runyon (failureyousuck) wrote :

When building with debuild on 18.04 I can confirm it does not work.

I also tested my steps from #2 with "./configure --prefix=/usr/local" (no --enable-appindicator) and it works fine.

Revision history for this message
Kentaro Hayashi (kenhys) wrote :

Hi, This problem is caused by inappropriate hardening flags.

Here is the patch to solve issue:

$ diff -ur growl-for-linux-0.8.5.orig/ growl-for-linux-0.8.5
diff -ur growl-for-linux-0.8.5.orig/debian/rules growl-for-linux-0.8.5/debian/rules
--- growl-for-linux-0.8.5.orig/debian/rules 2019-02-22 15:40:42.773259521 +0900
+++ growl-for-linux-0.8.5/debian/rules 2019-02-22 15:41:27.179728969 +0900
@@ -4,7 +4,7 @@
 # Uncomment this to turn on verbose mode.
 #export DH_VERBOSE=1

-export DEB_BUILD_MAINT_OPTIONS=hardening=+all,-pie
+export DEB_BUILD_MAINT_OPTIONS=hardening=+all,-pie,-bindnow
 DPKG_EXPORT_BUILDFLAGS=1
 include /usr/share/dpkg/buildflags.mk

tags: added: patch
Revision history for this message
Jeremy Bicha (jbicha) wrote :

This bug was fixed in the package growl-for-linux - 0.8.5-4

---------------
growl-for-linux (0.8.5-4) unstable; urgency=medium

  * debian/rules
    - Disable bindnow hardening build flag (LP#1783209)
  * debian/control
    - Bump standard version to 4.2.0. No other changes are required.

 -- Kentaro Hayashi <email address hidden> Fri, 22 Feb 2019 22:19:08 +0900

Changed in growl-for-linux (Ubuntu):
status: Confirmed → Fix Released
Changed in growl-for-linux (Ubuntu Bionic):
status: New → Triaged
importance: Undecided → High
Changed in growl-for-linux (Ubuntu Cosmic):
status: New → Triaged
importance: Undecided → High
Changed in growl-for-linux (Ubuntu):
importance: Undecided → High
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers